Joined: 12 May 2004
|Posted: Fri Oct 28, 2005 11:50 am Post subject: [ GLSA 200510-23 ] TikiWiki: XSS vulnerability
|Gentoo Linux Security Advisory
Title: TikiWiki: XSS vulnerability (GLSA 200510-23)
Date: October 28, 2005
Updated: May 22, 2006
TikiWiki is vulnerable to cross-site scripting attacks.
TikiWiki is a web-based groupware and content management system (CMS), using PHP, ADOdb and Smarty.
Vulnerable: < 188.8.131.52
Unaffected: >= 184.108.40.206
Architectures: All supported architectures
Due to improper input validation, TikiWiki can be exploited to perform cross-site scripting attacks.
A remote attacker could exploit this to inject and execute malicious script code or to steal cookie-based authentication credentials, potentially compromising the victim's browser.
There is no known workaround at this time.
All TikiWiki users should upgrade to the latest version:
Note: Users with the vhosts USE flag set should manually use webapp-config to finalize the update.
|# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/tikiwiki-220.127.116.11"
Last edited by GLSA on Tue Feb 10, 2009 4:16 am; edited 10 times in total