Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
"ALT-GR" Taste funktioniert unter KDE nicht
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
x000x
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jun 2002
Posts: 86
Location: Germany - Hamburg

PostPosted: Thu Jun 20, 2002 10:23 pm    Post subject: "ALT-GR" Taste funktioniert unter KDE nicht Reply with quote

Moin, moin,

habe folgendes Problem:
Unter KDE funtioniert meine "ALT-GR" Taste nicht.
Das ist immer dann ärgerlich, wenn man eMailen bzw.
das "PIPE" Zeichen tippen will.

Zur Info:
Starte ich ein xterm, und gebe
Code:
echo $LANG

ein, wird mir folgendes angezeigt:
Code:
de-DE@euro


Danke fuer Eure Hilfe -=Gruss Peter =-
Back to top
View user's profile Send private message
Beforegod
Bodhisattva
Bodhisattva


Joined: 10 Apr 2002
Posts: 1493
Location: Frankfurt/Main

PostPosted: Fri Jun 21, 2002 6:31 am    Post subject: Reply with quote

Probiers mal mit
de_DE@euro

Gruß,
Beforegod
Back to top
View user's profile Send private message
x000x
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jun 2002
Posts: 86
Location: Germany - Hamburg

PostPosted: Fri Jun 21, 2002 4:48 pm    Post subject: Reply with quote

Beforegod wrote:
Probiers mal mit
de_DE@euro

Gruß,
Beforegod


Sorry, mein Fehler... Es ist genauso eingetragen
Code:
de_DE@euro

_________________
-= Gruss Peter =-
-= alias x000x =-
Peter wrote:
perl -e 'print "\x47\x72\x75\x73\x73\x20\x50\x65\x74\x65\x72\x20\x3b\x2d\x29\x0a";'
Back to top
View user's profile Send private message
Beforegod
Bodhisattva
Bodhisattva


Joined: 10 Apr 2002
Posts: 1493
Location: Frankfurt/Main

PostPosted: Sat Jun 22, 2002 11:17 am    Post subject: Reply with quote

Geh mal unter "Einstellungen" in die Kategorie "Tastatur" und sieh nach ob dort der "XFree 4.x" Modus angwählt ist
Back to top
View user's profile Send private message
x000x
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jun 2002
Posts: 86
Location: Germany - Hamburg

PostPosted: Tue Jun 25, 2002 6:06 am    Post subject: Reply with quote

Beforegod wrote:
Geh mal unter "Einstellungen" in die Kategorie "Tastatur" und sieh nach ob dort der "XFree 4.x" Modus angwählt ist


Ist jetzt genau so eingestellt. Hat auch nichts gebracht. Das Problem ist nicht nur im xterm, sondern KDE weit. Sprich: Im Editor wie überall funktioniert die ALT-GR Taste nicht; ich kann also kein "@" Zeichen schreiben. Dieses hier habe ich kopiert.
_________________
-= Gruss Peter =-
-= alias x000x =-
Peter wrote:
perl -e 'print "\x47\x72\x75\x73\x73\x20\x50\x65\x74\x65\x72\x20\x3b\x2d\x29\x0a";'
Back to top
View user's profile Send private message
sulu
Guru
Guru


Joined: 21 May 2002
Posts: 399
Location: Dornbirn/Austria

PostPosted: Tue Jun 25, 2002 10:26 am    Post subject: Reply with quote

Hi.

Ich habe im LINUX-User einen schönen Artikel über Key-Belegung u.s.w.
gefunden. Falls am Abend mein Gehirn noch funktioniert werde ich mal nachsehen was man da so machen kann.

Gruss
Sulu
Back to top
View user's profile Send private message
x000x
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jun 2002
Posts: 86
Location: Germany - Hamburg

PostPosted: Tue Jun 25, 2002 12:41 pm    Post subject: Reply with quote

sulu wrote:
Hi.

Ich habe im LINUX-User ...

Wäre nett...
Dann will ich mal hoffen, das Dein Gehirn noch funzt ;-)
_________________
-= Gruss Peter =-
-= alias x000x =-
Peter wrote:
perl -e 'print "\x47\x72\x75\x73\x73\x20\x50\x65\x74\x65\x72\x20\x3b\x2d\x29\x0a";'
Back to top
View user's profile Send private message
dek
l33t
l33t


Joined: 16 May 2002
Posts: 657
Location: Germany

PostPosted: Tue Jun 25, 2002 4:01 pm    Post subject: Reply with quote

Wie sieht denn der entsprechende Teil deiner XF86Config aus ? Hast du das richtige Layout und die nodeadkeys eingetragen ? Bei mir haben die gefehlt und ich musste Tasten in Verbindung mit ALT-GR zweimal drücken.
So funktionierts bestens:
Code:

Section "InputDevice"
    Identifier  "Keyboard1"
    Driver      "Keyboard"
    Option "AutoRepeat" "250 30"
    Option "XkbRules"   "xfree86"
    Option "XkbModel"   "itouch"
    Option "XkbLayout"  "de"
    Option "XkbVariant" "nodeadkeys"
EndSection
Back to top
View user's profile Send private message
sulu
Guru
Guru


Joined: 21 May 2002
Posts: 399
Location: Dornbirn/Austria

PostPosted: Tue Jun 25, 2002 7:26 pm    Post subject: Reply with quote

Hi.

Habe Artikel gefunden. Der handelt aber mehr davon wie man z.B Caps-Lock ein sinnvollere Belegung beibringt.

Aber zu deinem Problem:
Was hat Du für ein Keyboard in /etc/XF86Config eingetragen ?

Ich habe PC-Tastatur mit 104 Tasten eingestellt.

Option "XkbModel" "pc104"

Wie schaut es bei dir aus ?

Gruss Andy

@dek
Merci für den Tip. Das doppelte Drücken in Verbindung mit AltGr it nervig.
Werde gleich mal meine /etc/XF86Config adaptieren.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum