Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Please confirm working MLdonkey on Alpha CPU
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
jws
n00b
n00b


Joined: 15 Jun 2002
Posts: 38

PostPosted: Wed Oct 19, 2005 4:45 pm    Post subject: Please confirm working MLdonkey on Alpha CPU Reply with quote

I'm getting segfaults when trying to run MLdonkey on my alpha server. It's written in ocaml, which I believe runs in a memory-managed virtual machine. That leads me to suspect that the problem is in ocaml itself. Probably a 64-bit bug.

If anyone has a working install of MLdonkey on an Alpha, please post the details here.

I'm using-

net-p2p/mldonkey-2.6.4-r2 (~alpha)
dev-lang/ocaml-3.08.3 (marked stable)
I've turned my build options back to -O2, since the ebuild for ocaml wants it that way.

If I run the 'mlnet' binary with strace, it connects to www.mldonkey.net, reads data, closes the connection and immediately segfaults.
Back to top
View user's profile Send private message
Kloeri
Retired Dev
Retired Dev


Joined: 02 Sep 2002
Posts: 144

PostPosted: Sun Oct 23, 2005 7:28 pm    Post subject: Reply with quote

I'm a bit confused as to why this bug report is posted on forums instead of http://bugs.gentoo.org.. But your problem looks like a (somewhat) recently fixed glibc problem. Please file a bug if remerging / upgrading glibc doesn't fix the problem.
Back to top
View user's profile Send private message
HuskyDog
n00b
n00b


Joined: 20 Feb 2003
Posts: 56
Location: Wiltshire, UK

PostPosted: Tue Nov 01, 2005 1:32 pm    Post subject: It used to work for me. Reply with quote

I have used mldonkey on Alpha quite extensively and it worked just fine. I have however had problems with the more recent versions not building properly (I am at work, so I can't check details). I think that 2.6.0 worked fine, but I couldn't get 2.6.4 to compile. I haven't tried to build a new version for a while, so that problem might be fixed.

I have never seen any problems when building ocaml.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum