Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE 3.5beta1 released!
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
cocoliso
n00b
n00b


Joined: 07 Mar 2004
Posts: 68

PostPosted: Wed Sep 21, 2005 3:03 pm    Post subject: KDE 3.5beta1 released! Reply with quote

woot! 8)

http://www.kde.org/info/3.5beta1.php

ebuilds??? heheh :lol:
Back to top
View user's profile Send private message
firephoto
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1560
Location: +48° 5' 23.40", -119° 48' 30.00"

PostPosted: Wed Sep 21, 2005 7:25 pm    Post subject: Reply with quote

monolithic ebuilds are in portage now.
_________________
#gentoo-kde on freenode
Back to top
View user's profile Send private message
irondog
l33t
l33t


Joined: 07 Jul 2003
Posts: 715
Location: Voor mijn TV. Achter mijn pc.

PostPosted: Wed Sep 21, 2005 9:13 pm    Post subject: Reply with quote

Are the meta ebuilds ready yet ?? => Time to break my Linux!!
_________________
Alle dingen moeten onzin zijn.
Back to top
View user's profile Send private message
wintersommer
n00b
n00b


Joined: 28 May 2004
Posts: 33

PostPosted: Wed Sep 21, 2005 9:22 pm    Post subject: Reply with quote

monolitic ebuilds are meta ebuilds btw.

and my question is : are the packages masked ??? so i have to unmask them ?
Back to top
View user's profile Send private message
Benson
Apprentice
Apprentice


Joined: 23 Feb 2004
Posts: 156
Location: Switzerland

PostPosted: Wed Sep 21, 2005 9:23 pm    Post subject: Reply with quote

Is it now possible to use alsa instead of arts - i mean i can already compile kde with -arts, but then kde doesn't play system messages etc....
Back to top
View user's profile Send private message
dschaefer78
n00b
n00b


Joined: 30 Aug 2004
Posts: 27

PostPosted: Thu Sep 22, 2005 8:23 am    Post subject: Problem with kdewebdev-3.5 beta1 emerging Reply with quote

Hi,

I emerged kde 3.5 beta1 and it stops on kdewebdev-3.5 beta 1
here is the error:

make[4]: *** [xsldbgthread.lo] Error 1
make[4]: *** Waiting for unfinished jobs....
make[4]: Leaving directory `/var/tmp/portage/kdewebdev-3.5_beta1/work/kdewebdev-3.4.91/kxsldbg/kxsldbgpart/libxsldbg'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/kdewebdev-3.5_beta1/work/kdewebdev-3.4.91/kxsldbg/kxsldbgpart'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/kdewebdev-3.5_beta1/work/kdewebdev-3.4.91/kxsldbg'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kdewebdev-3.5_beta1/work/kdewebdev-3.4.91'
make: *** [all] Error 2

!!! ERROR: kde-base/kdewebdev-3.5_beta1 failed.
!!! Function kde_src_compile, Line 170, Exitcode 2
!!! died running emake, kde_src_compile:make
!!! If you need support, post the topmost build error, NOT this status message

Does anyone have an idea how to solve it ?
Thanks
Dominique
Back to top
View user's profile Send private message
Blue Lightning
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jan 2003
Posts: 137
Location: Auckland, New Zealand

PostPosted: Thu Sep 22, 2005 8:38 am    Post subject: Reply with quote

Hmm, it seems to require a hard masked version of dbus if you have "hal" in your USE flags :(
Back to top
View user's profile Send private message
dschaefer78
n00b
n00b


Joined: 30 Aug 2004
Posts: 27

PostPosted: Thu Sep 22, 2005 9:12 am    Post subject: same problem Reply with quote

Hi,
I've tried to emerge the last version of dbus, but I have the same problem with kdewebdev.
Do you have an idea ?
Thanks.
Back to top
View user's profile Send private message
hans0r
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2005
Posts: 122
Location: Germany

PostPosted: Thu Sep 22, 2005 1:20 pm    Post subject: Reply with quote

Code:
!!! If you need support, post the topmost build error, NOT this status message


you didn't post the topmost build error
Back to top
View user's profile Send private message
Blue Lightning
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jan 2003
Posts: 137
Location: Auckland, New Zealand

PostPosted: Fri Sep 23, 2005 7:22 am    Post subject: Reply with quote

kdewebdev seems to have compiled OK here.
Back to top
View user's profile Send private message
chetan13
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jul 2003
Posts: 125
Location: chennai,india

PostPosted: Fri Sep 23, 2005 7:28 am    Post subject: Reply with quote

Benson wrote:
Is it now possible to use alsa instead of arts - i mean i can already compile kde with -arts, but then kde doesn't play system messages etc....

In the genkdesvn ebuilds, a patch posted in the gentoo bugzilla to allow notifications when kdelibs is built with -arts is used. Mario(the author of the ebuilds) modified the patch further to allow multiple/simultaneous sounds. Search for the bug or get the patch from the genkdesvn repository on berlios.de
Back to top
View user's profile Send private message
edmondo
Tux's lil' helper
Tux's lil' helper


Joined: 22 May 2004
Posts: 110

PostPosted: Fri Sep 23, 2005 11:24 am    Post subject: Reply with quote

Blue Lightning wrote:
kdewebdev seems to have compiled OK here.


Ditto here. Compiled kdewebdev ok here.

Random thought: Try to reemerge libxslt and then kdewebdev. Maybe it helps.
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Fri Sep 23, 2005 11:54 am    Post subject: Reply with quote

arts is broken on my KDE 3.5 beta1. It is unable to play Ogg Vorbis, and play Wav file with difficulty for notifications.
If y try to modify some options in « kcmshell arts », then restart the deamon, I got a X.org freeze. (have to use alt+sys+e)

I will wrote a script to use aplay and ogg123 instead of arts.

Also, kioslave media:/ is not working correctly with hal 0.5. It is unable to mount. (fstab-sync is missing, I think, but it is deprecated).
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
bssteph
l33t
l33t


Joined: 26 Feb 2003
Posts: 651
Location: Wisconsin

PostPosted: Fri Sep 23, 2005 3:02 pm    Post subject: Reply with quote

Is it just me or is akode not building?

Code:
checking for taglib/mpcfile.h... yes
checking for akode-config... no
checking for artsc-config... /usr/kde/3.5/bin/artsc-config
arts includes... -I/usr/kde/3.5/include/artsc -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include
arts libraries... -L/usr/kde/3.5/lib64 -ldl -lartsc -lpthread -lgmodule-2.0 -ldl -lgthread-2.0 -lglib-2.0
checking if admin should be compiled... no
checking if autom4te.cache should be compiled... yes
configure: creating ./config.status
aKode was not found. Without it the aKode aRts-plugin
will not be installed, and aRts will be.
unable to play many music formats.
cd . && /bin/sh ./config.status Makefile
fast creating Makefile
config.pl: fast created 1 file(s).
cd . && /bin/sh /var/tmp/portage/akode-3.5_beta1/work/akode-3.5_beta1/admin/missing --run autoheader
touch ./config.h.in
cd . && /bin/sh ./config.status config.h
config.status: creating config.h
config.status: config.h is unchanged
make  all-recursive
make[1]: Entering directory `/var/tmp/portage/akode-3.5_beta1/work/akode-3.5_beta1'
Making all in autom4te.cache
make[2]: Entering directory `/var/tmp/portage/akode-3.5_beta1/work/akode-3.5_beta1/autom4te.cache'
make[2]: *** No rule to make target `all'.  Stop.
make[2]: Leaving directory `/var/tmp/portage/akode-3.5_beta1/work/akode-3.5_beta1/autom4te.cache'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/akode-3.5_beta1/work/akode-3.5_beta1'
make: *** [all] Error 2


This seems too obvious an error for it to be anything but an oversight on my part. Guesses?
_________________
Website - All sorts of nonsense (some of it actually Linux related)
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Fri Sep 23, 2005 3:09 pm    Post subject: Reply with quote

Try to emerge media-libs/akode
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
bssteph
l33t
l33t


Joined: 26 Feb 2003
Posts: 651
Location: Wisconsin

PostPosted: Fri Sep 23, 2005 3:24 pm    Post subject: Reply with quote

Ah, they made it a separate package due to KDE removing it from the 3.5 branch. Fair enough.

Merging the media-libs/akode ebuild and editing the amarok ebuild to use that version and I'm sailing smoothly again. Thanks Desintegr.

Edit: Had to edit the juk ebuild too. Hopefully this works, I'll see when I get back from class.
_________________
Website - All sorts of nonsense (some of it actually Linux related)
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Fri Sep 23, 2005 3:31 pm    Post subject: Reply with quote

Akode seems to be broken on my system since I upgrade from KDE 3.4.2 to KDE 3.5 beta1.

If I try to launch a Wav file with artsplay, akode plugin will produce no sound.
If I try to launch a Mp3 file, I got a artsd crash (segfault)
And Ogg file produce a weird sound, cutted at the end, with xineplugin.
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
firephoto
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1560
Location: +48° 5' 23.40", -119° 48' 30.00"

PostPosted: Fri Sep 23, 2005 3:37 pm    Post subject: Reply with quote

Same problem here with akode, emerged the media-libs version and it installed but juk doesn't depend on it so if you mask the kde-base version you get mask/depend errors.

Looks like the juk ebuild will need some working over to get it working with the new akode install.


[/code]
_________________
#gentoo-kde on freenode
Back to top
View user's profile Send private message
bssteph
l33t
l33t


Joined: 26 Feb 2003
Posts: 651
Location: Wisconsin

PostPosted: Fri Sep 23, 2005 5:40 pm    Post subject: Reply with quote

akode and juk seem to work for me. I hacked the juk ebuild a bit, will submit to bugzilla and link here.

EDIT: patch (and when was a button for that added? :)
_________________
Website - All sorts of nonsense (some of it actually Linux related)
Back to top
View user's profile Send private message
jteb
n00b
n00b


Joined: 04 Nov 2004
Posts: 39
Location: Netherlands

PostPosted: Fri Sep 23, 2005 7:17 pm    Post subject: Reply with quote

Just out of curiosity, why do the alpha and beta packages of kde only have ~amd64 set and not ~x86
Back to top
View user's profile Send private message
lefou
Apprentice
Apprentice


Joined: 18 Feb 2004
Posts: 197
Location: Germany, Leipzig

PostPosted: Fri Sep 23, 2005 8:03 pm    Post subject: Reply with quote

Does anybody know, how to get the new pmount/hal/dbus integration to work.

With kde 3.4.[012] it work like a charm with fstab-sync, but now with >=hal-0.5, fstab-sync ist gone and you have to use pmount. But now, kde doesn't know how to mount my USB stick or CD/DVD.
Back to top
View user's profile Send private message
Battousai
Developer
Developer


Joined: 05 Jan 2004
Posts: 7

PostPosted: Sat Sep 24, 2005 4:45 am    Post subject: Reply with quote

jteb wrote:
Just out of curiosity, why do the alpha and beta packages of kde only have ~amd64 set and not ~x86

If FlameEyes committed them, it would be because he has amd64 hardware, with no x86 environment to test them on.
Back to top
View user's profile Send private message
icefox13
Tux's lil' helper
Tux's lil' helper


Joined: 19 Apr 2004
Posts: 78
Location: Munich, Germany

PostPosted: Sat Sep 24, 2005 9:43 am    Post subject: Reply with quote

For me, kdepim-3.4.91 failed (monolithic ebuilds):

Code:

Making all in karm
make[4]: Entering directory `/var/tmp/portage/kdepim-3.5_beta1/work/kdepim-3.4.91/kontact/plugins/karm'
KDECONFIG="/usr/kde/3.5/bin/kde-config" ../../../dcopidlng/dcopidlng ../../../karm/karmdcopiface.h > karmdcopiface.kidl || ( rm -f karmdcopiface.kidl ; false )
/usr/qt/3/bin/moc ./karm_plugin.h -o karm_plugin.moc
make[4]: *** No rule to make target `../../../karm/libkarm_shared.la', needed by `libkontact_karm.la'.  Stop.
make[4]: *** Waiting for unfinished jobs....
make[4]: Leaving directory `/var/tmp/portage/kdepim-3.5_beta1/work/kdepim-3.4.91/kontact/plugins/karm'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/kdepim-3.5_beta1/work/kdepim-3.4.91/kontact/plugins'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/kdepim-3.5_beta1/work/kdepim-3.4.91/kontact'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kdepim-3.5_beta1/work/kdepim-3.4.91'
make: *** [all] Error 2

!!! ERROR: kde-base/kdepim-3.5_beta1 failed.
!!! Function kde_src_compile, Line 170, Exitcode 2
!!! died running emake, kde_src_compile:make
!!! If you need support, post the topmost build error, NOT this status message.


Anyone else got the same problem?[/code]
Back to top
View user's profile Send private message
jteb
n00b
n00b


Joined: 04 Nov 2004
Posts: 39
Location: Netherlands

PostPosted: Sat Sep 24, 2005 10:58 am    Post subject: Reply with quote

Battousai wrote:
jteb wrote:
Just out of curiosity, why do the alpha and beta packages of kde only have ~amd64 set and not ~x86

If FlameEyes committed them, it would be because he has amd64 hardware, with no x86 environment to test them on.


Makes sense. Thanks!
Back to top
View user's profile Send private message
vipernicus
Veteran
Veteran


Joined: 17 Jan 2005
Posts: 1462
Location: Your College IT Dept.

PostPosted: Sat Sep 24, 2005 1:00 pm    Post subject: Reply with quote

If any of you have any trouble compiling a package, this is what I did:

MAKEOPTS="-j1" FEATURES="-ccache -sandbox" USE="-kdeenablefinal" emerge package
_________________
Viper-Sources Maintainer || nesl247 Projects || vipernicus.org blog
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum