Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[HOWTO] udev, DBUS, HAL, gnome-volume-manager, c'est quoi ?
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
zdra
Veteran
Veteran


Joined: 30 Nov 2003
Posts: 1693
Location: Bruxelles, Belgique

PostPosted: Mon May 16, 2005 6:21 pm    Post subject: Reply with quote

Oui en effet j'avais completement oublié. Je viens de rapidement corriger, c'est bon mtn ?
Back to top
View user's profile Send private message
ImMorT4L
Tux's lil' helper
Tux's lil' helper


Joined: 13 Feb 2005
Posts: 109
Location: Belgique, à 200m de l'église au feu à droite...

PostPosted: Fri May 20, 2005 9:07 am    Post subject: Reply with quote

Ca marcherait avec un HDD Usb2.0 de 160Go... C'est un fait une très grosse clé USB :lol:

Ou bien je dois installer autre chose ??? Parce que là, pour y accéder, je passe par vsftpd qui se connecte sur un PC Windows à partir duquel j'Upload les fichier du HDD :oops:
Saoulant de devoir lancer le PC Windows pour tranférer des fichiers :(
_________________
Devenu chevalier Pingouin afin de combattre l'infâme Bill Vador...
Lâchement retranché derrière les Windows de son vieux vaisseau intergalactique !!!!
Et qui nous observe depuis son grand écran bleu :D
Back to top
View user's profile Send private message
zdra
Veteran
Veteran


Joined: 30 Nov 2003
Posts: 1693
Location: Bruxelles, Belgique

PostPosted: Fri May 20, 2005 9:11 am    Post subject: Reply with quote

Je sais pas si GVM va le considérer comme un volume à monter automatiquement, mais je crois bien.

De toutes facons avec un "dmesg" juste apres avoir connecté ton USB il te dira le fichier /dev/sd?? créé pour acceder à la périf, donc un mount manuel est toujours possible... sauf si il y a un probleme de matos non supporté... Et si c'est formaté en NTFS ce sera en read only sauf si tu fais marcher avec une émulation de driver windows (projet captive).
Back to top
View user's profile Send private message
ImMorT4L
Tux's lil' helper
Tux's lil' helper


Joined: 13 Feb 2005
Posts: 109
Location: Belgique, à 200m de l'église au feu à droite...

PostPosted: Fri May 20, 2005 9:25 am    Post subject: Reply with quote

Vais essayer bêtement comme ça, sinon je suivrai le TUTO vu que ça me dérange pas de la monter manuellement...

Mais, vu qui a plusieurs partition dessus (3 ou 4 je sais plus...), je dois simplement monter dev/sdaX /mnt/win ??? Et il met les partitions dans des répertoires ??? Ou je dois le faire pour chaque partition Windows ???

Beaucoup de question, mais j'ai pas envie de perdre mes 160Go de donnée en faisant une connerie :oops:

Parce que j'ai aussi ma partition Windows (NTFS) du Dual boot qui est sous /mnt/Win_XP :roll:
_________________
Devenu chevalier Pingouin afin de combattre l'infâme Bill Vador...
Lâchement retranché derrière les Windows de son vieux vaisseau intergalactique !!!!
Et qui nous observe depuis son grand écran bleu :D
Back to top
View user's profile Send private message
yoyo
Bodhisattva
Bodhisattva


Joined: 04 Mar 2003
Posts: 4273
Location: Lyon - France

PostPosted: Fri May 20, 2005 9:39 am    Post subject: Reply with quote

ImMorT4L wrote:
Mais, vu qui a plusieurs partition dessus (3 ou 4 je sais plus...), je dois simplement monter dev/sdaX /mnt/win ??? Et il met les partitions dans des répertoires ??? Ou je dois le faire pour chaque partition Windows ???
Tu dois le faire pour chaque partition. Mais a priori, dbus/hal/gvm te fera tout ça automatiquement. :)

ImMorT4L wrote:
Beaucoup de question, mais j'ai pas envie de perdre mes 160Go de donnée en faisant une connerie :oops:
Tu peux monter tes partitions en lecture seulement (option "ro" de mount). Regarde le man de mount pour plus de détail.
_________________
La connaissance s'accroît quand on la partage.
JCB
Back to top
View user's profile Send private message
ImMorT4L
Tux's lil' helper
Tux's lil' helper


Joined: 13 Feb 2005
Posts: 109
Location: Belgique, à 200m de l'église au feu à droite...

PostPosted: Fri May 20, 2005 6:03 pm    Post subject: Reply with quote

Quand je fais un dmesg après avoir brnché mon HDD 2 1/2" (C'est un 60Go avec 3 Partitions), il me fait ça:

Code:
usb 1-6: new high speed USB device using ehci_hcd and address 4
scsi0 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 4
usb-storage: waiting for device to settle before scanning
  Vendor: USB 2.0   Model: Storage Device    Rev: 0100
  Type:   Direct-Access                      ANSI SCSI revision: 00
Attached scsi generic sg0 at scsi0, channel 0, id 0, lun 0,  type 0
usb-storage: device scan complete


J'ai mis le support dans le Kernel, ca semble fonctionner...

Si je fais mount /dev/sd0 /home/immortal/HDD_USB2.0/
Il me met ça: mount: /dev/sg0 is not a block device

C'est ou ça peut être du à quoi ???
J'aurais intérêt à installer ce qui est de le Tuto (Là, je le faisais 100% manuellement) ???

Alors que si je monte ma partition Dual Dual Boot NTFS, il ne pose aucun problème :oops:
mount /dev/hda1 /home/immortal/HDD_USB2.0/
ls => Ok, j'ai mes fichiers


EDIT:: Je viens de suivre le HOWTO si ce n'est que je n'ai pas fait le emerge --newuse world car je n'ai pas envie de passer ma soirée à ça et ça ne fonctionne pas pour le HDD. Le reste semble fonctionner, mais je n'ai malheureusement plus de clé USB sous la main :(

EDIT2: Ca fonctionne presque parfaitement avec un HDD 8) Le seule problème est que seul le ROOT peut acceder aux partitions NTFS qui sont montées dans /media/<nom-de-la-partition> alors qu'un simple utilisateur sait le faire avec les FAT32 :(
Faut encore que je trouve comment donner accès à l'utilisateur sur les NTFS...
Une Icone apparait sur le Bureau quand je lance le HDD et elle se retire dès que je coupe le HDD... C'est mieux que sous Windows. 8O :lol:
_________________
Devenu chevalier Pingouin afin de combattre l'infâme Bill Vador...
Lâchement retranché derrière les Windows de son vieux vaisseau intergalactique !!!!
Et qui nous observe depuis son grand écran bleu :D
Back to top
View user's profile Send private message
pumpkins
n00b
n00b


Joined: 25 Jun 2004
Posts: 17

PostPosted: Sat Jun 04, 2005 4:03 pm    Post subject: Re: [HOWTO] udev, DBUS, HAL, gnome-volume-manager, c'est quo Reply with quote

zdra wrote:

Note: j'ai récement vu que ubuntu n'ajoute aucune entrée dans fstab et que fstab-sync n'existe pas ! je comprend pas comment ça marche alors...


Ubuntu utilise pmount. Voilà la déscription donnée dans la page man.
pmount ("policy mount") is a wrapper around the standard mount program which permits normal users to mount removable devices without a matching /etc/fstab entry.

En gros, c'est un mount qui ne vérifie pas l'identité de l'utilisateur, mais plutôt les conditions du montage (quel périphérique? présent dans fstab? USB, FIREWIRE? ...)
Back to top
View user's profile Send private message
vishnoo
Tux's lil' helper
Tux's lil' helper


Joined: 05 Jun 2005
Posts: 119
Location: Antony (France)

PostPosted: Mon Jun 06, 2005 9:40 pm    Post subject: Reply with quote

Salut,

Je suis un peu dans le même cas qu'ImMorT4L : j'ai un disque usb avec un partition ntfs de 160Go, et j'utilise HAL&Cie pour me le monter automatiquement.
J'aimerais savoir où configurer les droits etc pour ces périphériques montés.

Pour l'instant, pour mon disque, j'ai viré dans /etc/fstab l'option "managed" et mis un petit umask à la place pour que le disque soit lisible par les utilisateurs.
Evidamment ce n'est pas une bonne solution vu que ce n'est que pour ce disque.

En fait, idéalement, j'aimerais qu'il y ai un groupe qui ai les droits sur les disques montés et ainsi, pour les lires, il suffirait d'ajouter mon utilisateur à ce groupe.

Sinon dois-je tenter d'installer pmount ? c'est apparamenent ce qui est utilisé sous ubuntu où en effet ça marche comme je le veux (avec même le coup du groupe si mes souvenirs sont bons)

Merci pour vos conseils :=)
Back to top
View user's profile Send private message
zdra
Veteran
Veteran


Joined: 30 Nov 2003
Posts: 1693
Location: Bruxelles, Belgique

PostPosted: Tue Jun 07, 2005 7:57 am    Post subject: Reply with quote

Si j'en crois les changelog les derniers ivman utilisent pmount, mais c'est pas encore dans portage il me semble. Je sais pas si on sait faire en sorte que GVM utilise aussi pmount, ubuntu l'a fait mais c'est peut-etre avec un patch fait maison...
Back to top
View user's profile Send private message
CryoGen
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1425
Location: Bamako - Mali - Afrique

PostPosted: Wed Jun 08, 2005 12:48 am    Post subject: Reply with quote

Je voudrais fortememt passé à udev :)
Dans le "Guide udev pour Gentoo" on peut soit mettre un udev avec un /dev static soit utiliser udev "tel qu'il a été voulu par ses développeurs"

Y a-t-il beaucoup de probleme avec un udev total ?
_________________
- CryoGen` on #gentoofr@irc.freenode.net
- ~amd64 / KDE4
- I'm the bone of my sword...
Back to top
View user's profile Send private message
zdra
Veteran
Veteran


Joined: 30 Nov 2003
Posts: 1693
Location: Bruxelles, Belgique

PostPosted: Wed Jun 08, 2005 7:37 am    Post subject: Reply with quote

Pour moi ça marche tres bien en 100% udev:
Code:

gentoo zdra # mount --bind / /mnt/test/
gentoo zdra # ls /mnt/test/dev/
console  null
gentoo zdra # ls /dev/ | wc -w
181
gentoo zdra # mount | grep udev
udev on /dev type tmpfs (rw,nosuid)


J'ai désactivé le tarball et j'ai viré a la main tout les fichiers sur mon disque de /dev. Il faut quand même garder sur ton disque les fichiers console et null qui sont utilisé au boot avant que udev soit lancé... Fin ça marche sans mais alors t'as rien qui s'affiche à l'écran tant que udev est pas starté...

L'avantage de la manip c'est que t'as plus des milliard de fichiers dans /dev mais uniquement un fichier par matos que t'as (déterminé par tes regles udev) et donc par exemple fini les /dev/hda qui vont de 1 à 11 meme si tu n'a qu'une partition... Moi j'ai 4 partitions sur hda:
Code:
zdra@gentoo:~$ ls /dev/hda*
/dev/hda  /dev/hda1  /dev/hda2  /dev/hda3  /dev/hda4
Back to top
View user's profile Send private message
CryoGen
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1425
Location: Bamako - Mali - Afrique

PostPosted: Wed Jun 08, 2005 9:45 am    Post subject: Reply with quote

zdra wrote:

J'ai désactivé le tarball et j'ai viré a la main tout les fichiers sur mon disque de /dev


Donc en fait il faut que je passe en full udev puis j'afface tout (sauf null et console) et je reboot pour peupler le dev correctement ?
_________________
- CryoGen` on #gentoofr@irc.freenode.net
- ~amd64 / KDE4
- I'm the bone of my sword...
Back to top
View user's profile Send private message
vishnoo
Tux's lil' helper
Tux's lil' helper


Joined: 05 Jun 2005
Posts: 119
Location: Antony (France)

PostPosted: Fri Jun 10, 2005 1:34 am    Post subject: Reply with quote

Bonjour tout le monde,

Je fait un peu suite à mon dernier message, car j'ai un peu poussé le problème.
Je ne voulais pas utiliser pmount pour l'instant (ce sera pour mon prochain post :p ), car je veux déjà faire fonctionner les choses en l'état avec fstab-sync.

Au départ, seul root pouvait lire le disque usb donc mon problème était d'allouer le disque à un groupe, ce qui était possible pour mon disque (mais que pour lui) avec dans fstab ceci :
Code:

/dev/sda1               /media/NIOLON           ntfs    exec,user,noauto,gid=plugdev,umask=0117,dmask=0007    0 0

En enlevant "managed" et en créant le dossier NIOLON ...
C'était déjà assez pratique car cela permet d'ajouter simplement des users au groupe plugdev. A noter que les umask et dmask sont ici obligatoires car sinon tout est par défaut illisible.

Correction : tt à l'heure je crois qu'avec ces valeurs ça marchait, mais maintenant plus du tout ???? y'a tout qui devient chaotique je vais aller me coucher...
(enfin je voudrais avoir du rw_rw____ pour le les fichiers et drwxrwx___ pour les dossiers quoi..)


Ensuite pour améliorer ceci, 'man fstab-sync' fut mon ami et j'ai commencé a faire une règle dans /usr/share/hal/fdi/95userpolicy/mystorage-policy.fdi que voilà :
Code:

<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->

<deviceinfo version="0.2">
  <device>
    <match key="block.is_volume" bool="true">
      <match key="volume.fsusage" string="filesystem">
        <match key="@block.storage_device:storage.no_partitions_hint" bool="false">
     <match key="volume.partition.msdos_part_table_type" exists="true">
       <match key="volume.policy.should_mount" exists="true">
          <merge key="volume.policy.mount_option.gid=plugdev" type="bool">true</merge>
          <merge key="volume.policy.mount_option.umask=0117" type="bool">true</merge>
          <merge key="volume.policy.mount_option.dmask=0007" type="bool">true</merge>
          <!--
            <merge key="volume.policy.desired_mount_point" type="string">toto</merge>
            <append key="volume.policy.desired_mount_point" type="copy_property">volume.partition.number</append>
          -->
      </match>
     </match>
   </match>
      </match>
    </match>
  </device>
</deviceinfo>


Au niveau du groupe, c'est parfait, tout marche bien.
Bon au niveau des umask je comprends plus rien maintenant, je verrais ça demain
Mais ce sera déjà une réponse à mon problème je pense.


Comme question subsidiaire, j'aurais ceci :
en utilisant les lignes commentés, mon disque est bien monté dans /media/toto1, mais gnome-volume-manager à l'air de faire des siennes : sur mon bureau gnome, je vois toujours apparaître 'NIOLON' : gvm utilise donc toujours le label. C'est quelque peut perturbant non ?
Back to top
View user's profile Send private message
zdra
Veteran
Veteran


Joined: 30 Nov 2003
Posts: 1693
Location: Bruxelles, Belgique

PostPosted: Fri Jun 10, 2005 6:31 am    Post subject: Reply with quote

J'ai toujour dans mes PM un message de ImMorT4L qui dit ceci:

Quote:

j'ai trouvé pour donner les droits aux partitions NTFS pour les utilisateurs normeaux et pas seulement le root...

il faut aller dans ce fichier:
vim /usr/share/hal/fdi/90defaultpolicy/storage-policy.fdi

Rechercher les paramètre HPFS/NTFS vers la fin du fichirer (+/-80% dans vim) et y ajouter ce qui est en gras:

<!-- HPFS/NTFS -->
<match key="volume.partition.msdos_part_table_type" int="0x07">
<merge key="volume.policy.should_mount" type="bool">true</merge>
<merge key="volume.policy.mount_option.umask=0022" type="bool">true</merge>
<merge key="volume.policy.mount_option.uid=500" type="bool">true</merge>
<merge key="volume.policy.mount_option.gid=500" type="bool">true</merge>
</match>

Ou bien la valeur de son choix selon ce qu'on veut exactement (C'est ce qui sera mis dans le FSTAB en fait).


Il faudrait encore que j'ajoute un ptite paragraphe pour expliquer les configurations de HAL mais j'y connais pas grand chose :oops:
Back to top
View user's profile Send private message
vishnoo
Tux's lil' helper
Tux's lil' helper


Joined: 05 Jun 2005
Posts: 119
Location: Antony (France)

PostPosted: Fri Jun 10, 2005 10:09 am    Post subject: Reply with quote

Bon, alors hier soir j'était completement endormi, et en fait mon reglage de Hal était presque bon.

Voici le fichier final qu'il faut ajouter et l'éxplication :

/usr/share/hal/95userpolicy/msdisks-policy.fdi :
Code:

<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->

<deviceinfo version="0.2">

 <!-- External disks with ms file systems:
        Match volumes from an external USB harddisk enclosure by file system
        If fat or ntfs (see section 'should_mount' in 90defaultpolicy) mount  with
        'plugdev' group rights
       
        vishnoo  -->
 <device>
    <match key="block.is_volume" bool="true">
      <match key="volume.fsusage" string="filesystem">
        <match key="@block.storage_device:storage.no_partitions_hint" bool="false">
          <match key="volume.partition.msdos_part_table_type" exists="true">
            <match key="volume.policy.should_mount" exists="true">
               <merge key="volume.policy.mount_option.dmask=0007" type="bool">true</merge>
               <merge key="volume.policy.mount_option.umask=0117" type="bool">true</merge>
               <merge key="volume.policy.mount_option.gid=plugdev" type="bool">true</merge>
               <merge key="volume.policy.mount_option.defaults" type="bool">true</merge>
               </match>
            </match>
          </match>
       </match>
    </match>
 </device>


</deviceinfo>



et faire un
Code:
# groupadd plugdev

puis modifier /etc/group:
Code:
plugdev:x:NNN:utilisateurs_autorises_ici


voilà :)

Explications super-détaillées (enfin j'espère) :

Attention : ne surtout pas modifier /usr/share/hal/fdi/90defaultpolicy/storage-policy.fdi comme le fedait ImMortal (cf fstab-sync) mais utiliser le répertoire 95userpolicy (ouvert après le précédent) pour ses besoins personnels. Sinon, il faudrait éventuellement proposer aux gens de HAL d'intégrer ce genre de lignes directement :)

Alors en fait je reprends le maching du fichier 90defaultpolicy pour les msdos filesystems, et je rajoute le match sur les should_mount pour ne modifier que les partitions à monter ;p

Ensuite je préfaire ne pas faire comme ImMortal, et faire plutôt à la façon de pmount : ne pas assigner les disques à un utilisateur particulier mais plutôt au groupe 'plugdev' car c'est plus propre de rajouter les utilisateurs à un groupe ad hoc.

Question de droits j'ai mis un umask=0117 et dmask=0007 pour avoir des droits type '_rw_rw____' pour les fichiers et 'drwxrwx___' pour les dossiers afin que user et group puissent faire ce qu'ils veulent et que all puisse rien faire : pour les partitions ntfs, comme elles sont pas lisibles, les w se barent au montage :p avec un petit message de /var/log/messages ou il dit qu'il les monte en lecture seule. L'option 'defaults' est aussi mon amie, sinon il utilise user,exec,noauto.
Sinon j'aime avoir umask et dmask car j'aime pas voir tous les fichiers mis executables (et tous verts dans ls...) dans les partitions dos.


C'est vraiment bien, HAL, on peut faire pas mal de choses, par exemple monter les partitions ntfs avec captive-ntfs etc ...
Je trouve toutefois que ce serait mieux si la config était dans /etc/hal/, ce serait quand même plus clair non ?
Back to top
View user's profile Send private message
Longfield
Guru
Guru


Joined: 17 Mar 2004
Posts: 358
Location: Switzerland, Fribourg (la Glâne, les vrais)

PostPosted: Thu Sep 08, 2005 8:39 am    Post subject: Reply with quote

juste une petite précision : j'ai testé la beta de gnome 2.12 et (gnome-volume-manager 1.5.0) et par la même occasion hal 0.5.4 et dbus 0.3.6

Maintenant fstab-sync n'est plus utilisé pour mettre à jour fstab et monter les disques amovibles, mais c'est pmount qui a pris le relais : c'est bien plus propre comme manière de faire, vu que pmount marche vraiment du côté user et on n'a pas besoin de modifier le fstab !

Pour que vous perdiez moins de temps que moi :wink:, pensez à rajouter votre user dans le group plugdev afin d'avoir les droits d'execution sur pmount ! (en tous cas moi j'ai dû le faire manuellement) !

Sinon, ça marche toujours du tonerre cette famille : hotplug-udev-hal-dbus-pmount-gnome-volume-manager ! Je suis conquis !
_________________
longfield@swissjabber.ch
Cardinal powered !
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3559
Location: Belgium

PostPosted: Thu Sep 08, 2005 2:19 pm    Post subject: Reply with quote

vishnoo wrote:
Je trouve toutefois que ce serait mieux si la config était dans /etc/hal/, ce serait quand même plus clair non ?
On peut parfaitement mettre sa config perso dans /etc/hal, ainsi on n'est pas tenté de toucher aux fichiers par défault ! ;)
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2868
Location: Grenoble, France

PostPosted: Sun Sep 11, 2005 6:13 pm    Post subject: Reply with quote

Longfield wrote:
Pour que vous perdiez moins de temps que moi :wink:, pensez à rajouter votre user dans le group plugdev afin d'avoir les droits d'execution sur pmount ! (en tous cas moi j'ai dû le faire manuellement) !


Hum, étrange, je suis pas dans ce groupe, et pourtant je n'ai pas de problème, et je pense bien utiliser pmount, il s'est installé l'autre jour avec gnome-volume-manager... à moins qu'il faille être dans ce groupe pour l'utiliser, et que sinon, ça garde l'ancienne méthode...
Back to top
View user's profile Send private message
TGL
Bodhisattva
Bodhisattva


Joined: 02 Jun 2002
Posts: 1978
Location: Rennes, France

PostPosted: Sun Sep 11, 2005 6:38 pm    Post subject: Reply with quote

kopp wrote:
Hum, étrange, je suis pas dans ce groupe, et pourtant je n'ai pas de problème, et je pense bien utiliser pmount, il s'est installé l'autre jour avec gnome-volume-manager... à moins qu'il faille être dans ce groupe pour l'utiliser, et que sinon, ça garde l'ancienne méthode...

Ouais, en principe, quand pmount n'est pas utilisable, alors GVM utilise mount. Seulement mount lui ne marchera pour ton utilisateur que si tu as les entrées qui vont bien dans ta fstab bien sûr.
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2868
Location: Grenoble, France

PostPosted: Sun Sep 11, 2005 7:07 pm    Post subject: Reply with quote

Ah oui effectivement, je constaste que ça n'utilise pas pmount...
Par contre, maintenant je me suis rajouter au groupe pmount, et ça ne marche pas pour autant. Y a t il autre chose à faire ?

edit : Ah, tiens, apparemment, il faut mettre une liste des périphérique dont on veut autoriser le montage par pmount, donc ça reste quand meme restrictif, pmount ne marchera donc pas pour tout ? quoi que, a priori, mettre /dev/sdb me permettrait de monter toutes les clés usb/mass storage que je veux ... voir /dev/sd* s'il y en a plusieurs...)

edit2 : j'ai beau mettre /dev/sdb (ou /dev/sdb2) dans /etc/pmount.allow, ça ne fait quand meme rien quand je mets mon ipod...
je regarderais ça plus en détail plus tard, je vous tiens au courant pour l'évolution
Back to top
View user's profile Send private message
UB|K
l33t
l33t


Joined: 27 May 2004
Posts: 786
Location: Villeurbanne, France

PostPosted: Mon Sep 12, 2005 7:54 am    Post subject: Reply with quote

kopp wrote:
j'ai beau mettre /dev/sdb (ou /dev/sdb2) dans /etc/pmount.allow, ça ne fait quand meme rien quand je mets mon ipod...

Ca y est, j'ai réussi à faire marcher pmount pour l'ipod, pour ça, j'ai juste ajouté mon utilisateur au group plugdev et pmount.allow ressemble à:
Code:
sdc2 ipod

et ça marche: il est monté dans /media/ipod
edit: par contre, un truc marche pas: l'eject sur sdc2 a besoin d'être fait en root sinon ça plante
_________________
Reality is that which, when you stop believing in it, doesn't go away.
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2868
Location: Grenoble, France

PostPosted: Mon Sep 12, 2005 10:10 am    Post subject: Reply with quote

UB|K wrote:
kopp wrote:
j'ai beau mettre /dev/sdb (ou /dev/sdb2) dans /etc/pmount.allow, ça ne fait quand meme rien quand je mets mon ipod...

Ca y est, j'ai réussi à faire marcher pmount pour l'ipod, pour ça, j'ai juste ajouté mon utilisateur au group plugdev et pmount.allow ressemble à:
Code:
sdc2 ipod

et ça marche: il est monté dans /media/ipod
edit: par contre, un truc marche pas: l'eject sur sdc2 a besoin d'être fait en root sinon ça plante

Ah ok merci, je n'avais pas bien compris la syntaxe :)
Pour le eject : efefctivement c'est frustrant, mais c'était déjà le cas avant, en tous cas chez moi, malgré l'appartenance au group disk... je ne sais pas comment faire ...
Back to top
View user's profile Send private message
UB|K
l33t
l33t


Joined: 27 May 2004
Posts: 786
Location: Villeurbanne, France

PostPosted: Mon Sep 12, 2005 10:23 am    Post subject: Reply with quote

kopp wrote:
Pour le eject : efefctivement c'est frustrant, mais c'était déjà le cas avant, en tous cas chez moi, malgré l'appartenance au group disk... je ne sais pas comment faire ...

je pense qu'on peut s'en tirer avec sudo mais pour que ça marche il faudrait éditer l'ebuild de gnome-volume-manager pour qu'il ressemble à ça:
Code:
pkg_setup() {
        G2CONF="--with-eject-command=/usr/bin/sudo /usr/bin/eject"
}

ça devrait le faire, j'essayerai à l'occase

edit: ça marche po, pourtant j'y croyais à mort...
_________________
Reality is that which, when you stop believing in it, doesn't go away.
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2868
Location: Grenoble, France

PostPosted: Mon Sep 12, 2005 2:01 pm    Post subject: Reply with quote

je ne crois pas que ce problème ait à voir avec gnome volume manager, il me semble que je ne l'avais pas encore installé au début où j'avais mon ipod, et que ça faisait déjà ça. Je dirais plutot sur les droits de /dev/sdb ou quelque chose du genre, mais je ne vois pas comment changer ça (j'ai un peu de mal avec toutes ces histoires de /dev moi) Peut-être une âme éclairée pour nous illuminer de sa lumière ...
*hint* TGL, dis nous tout!!! *hint*
(C'est vrai quoi, TGL il sait toujours tout ;))
(Non, je ne fais pas de la lèche au modo :roll: )


EDIT : tiens du coup l'option : browse removable media when plugged n'agit plus quand c'est monté avec pmount... moi j'attendai comme un idiot que ça m'ouvre nautilus :)
Sinon, je ne trouve toujours pas pour eject :i l utilise la méthode scsi en root, mais elle ne marche pas en user... je comprends pas
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum