Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Which ~arch to use on Sunblade 100?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
nadmaximus
n00b
n00b


Joined: 30 Jan 2003
Posts: 17

PostPosted: Mon Apr 07, 2003 2:11 pm    Post subject: Which ~arch to use on Sunblade 100? Reply with quote

Well, after an afternoon of wrestling with it, I got my Sunblade 100 booting its own kernel. I set the ARCH keyword to ~sparc and did a sync and a world emerge. Then Saturday afternoon I started it emerging KDE.

Later on I realized I might have chosen the wrong ARCH keyword. It's still chewing away at KDE, but has a long way to go, so I thought I'd ask...

Should I be using ~sparc or ~sparc64? If I do an emerge --deep -upv world with ~sparc64, it wants to downgrade many packages that were upgraded with ~sparc. Uname -m reports sparc64 of course, but I'm not sure which to use.

If anybody has any info on this I'd appreciate it. For now, I'm letting the emerge continue and crossing my fingers, eheh.
Back to top
View user's profile Send private message
xming
Guru
Guru


Joined: 02 Jul 2002
Posts: 434

PostPosted: Mon Apr 07, 2003 2:51 pm    Post subject: Reply with quote

I think is is sparc, because the userland is still 32-bit not 64

xming
Back to top
View user's profile Send private message
nadmaximus
n00b
n00b


Joined: 30 Jan 2003
Posts: 17

PostPosted: Mon Apr 07, 2003 3:15 pm    Post subject: Hopefully... Reply with quote

That is sort of what I was thinking. So far so good - Xfree has completed emerging, and I can fire up twm with no problems. KDE still churning away.

Thanks
Back to top
View user's profile Send private message
mrgalihad
Tux's lil' helper
Tux's lil' helper


Joined: 30 Jan 2003
Posts: 91

PostPosted: Mon Apr 07, 2003 5:49 pm    Post subject: Reply with quote

I use ~sparc for my blade100, and don't have any problems. I get pretty much the latest and greatest of everything.

What resolutions are you running in X on your sunblade 100? Are you using Xfree 4.3? I can't seem to get anything better than 640x480 to work. mind posting your X config file? I ended up downgrading to 4.2.1 to get it working back at 1280x1024 again.
Back to top
View user's profile Send private message
Kumba
Developer
Developer


Joined: 16 Jul 2002
Posts: 373
Location: Sigma 957

PostPosted: Mon Apr 07, 2003 5:57 pm    Post subject: Reply with quote

Yeah, you should be using ~sparc. "sparc64" and "~sparc64" keywords are deprecated until it's decided whether to pursue a 64-bit userland, as they might be used to differentiate between 32-bit userland and 64-bit. So far, I haven't heard very many positive things about going completely to 64-bit userland, so I am unsure whether sparc64 will ever be used as a keyword again. Who knows, time will tell all.

--Kumba
_________________
"The past tempts us, the present confuses us, the future frightens us. And our lives slip away, moment by moment, lost in that vast, terrible in-between."
--Emperor Turhan, Centauri Republic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum