Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X on alpha
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
tunkaflux
Tux's lil' helper
Tux's lil' helper


Joined: 20 Aug 2003
Posts: 76

PostPosted: Wed Aug 31, 2005 6:55 pm    Post subject: X on alpha Reply with quote

Hi all,

When I start X on my Alpha PWS500a, the whole box hangs... The video card is an S3 Trio64+ which will be replaced soon by a G450 :) Are there any known issues with X on alpha hardware?
Back to top
View user's profile Send private message
Ferdy
Retired Dev
Retired Dev


Joined: 04 May 2002
Posts: 483
Location: España

PostPosted: Wed Aug 31, 2005 7:28 pm    Post subject: Reply with quote

Try filing us a bug (don't forget to post your emerge --info). As far as I know, there are no issues.

Cheers,
Ferdy
Back to top
View user's profile Send private message
tunkaflux
Tux's lil' helper
Tux's lil' helper


Joined: 20 Aug 2003
Posts: 76

PostPosted: Thu Sep 01, 2005 5:23 am    Post subject: Reply with quote

Before I post a bug for this, are these settings ok:
Code:
loek ~ # emerge --info
Portage 2.0.51.22-r2 (default-linux/alpha/2005.0, gcc-3.3.2, glibc-2.3.4.20041102-r1, 2.6.11.8 alpha)
=================================================================
System uname: 2.6.11.8 alpha EV56
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5
sys-apps/sandbox:    1.2.11
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.8.1-r4
ACCEPT_KEYWORDS="alpha"
AUTOCLEAN="yes"
CBUILD="alpha-unknown-linux-gnu"
CFLAGS="-mieee -O3 -mcpu=ev56 -pipe"
CHOST="alpha-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-mieee -O3 -mcpu=ev56 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ ftp://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.be.gentoo.org/gentoo-portage"
USE="alpha X arts berkdb bitmap-fonts crypt cups eds encode esd font-server foomaticdb fortran gdbm gif gnome gpm gstreamer gtk gtk2 imlib jpeg kde libg++ libwww mad mikmod motif mp3 mpeg ncurses nls ogg oggvorbis opengl oss pam pdflib perl png python qt quicktime readline sdl spell ssl tcpd tiff truetype truetype-fonts type1-fonts vorbis xml2 xmms xv zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY
Back to top
View user's profile Send private message
Ferdy
Retired Dev
Retired Dev


Joined: 04 May 2002
Posts: 483
Location: España

PostPosted: Thu Sep 01, 2005 8:07 am    Post subject: Reply with quote

Those settings look ok to me. I don't know what's the state of -O3 in alpha I use -O2 myself and I think all alpha devs also use -O2.

Cheers,
Ferdy
Back to top
View user's profile Send private message
tunkaflux
Tux's lil' helper
Tux's lil' helper


Joined: 20 Aug 2003
Posts: 76

PostPosted: Thu Sep 01, 2005 9:25 am    Post subject: Reply with quote

Ferdy wrote:
Those settings look ok to me. I don't know what's the state of -O3 in alpha I use -O2 myself and I think all alpha devs also use -O2.


Just to be sure, I'll re-emerge X with O2 :)
Back to top
View user's profile Send private message
tunkaflux
Tux's lil' helper
Tux's lil' helper


Joined: 20 Aug 2003
Posts: 76

PostPosted: Thu Sep 01, 2005 3:07 pm    Post subject: Reply with quote

X has been re-emerged, same thing :/ I'll post a bug for this.
Back to top
View user's profile Send private message
Trevoke
Advocate
Advocate


Joined: 04 Sep 2004
Posts: 4099
Location: NY, NY

PostPosted: Fri Sep 02, 2005 2:45 pm    Post subject: Reply with quote

This might not work, but try launching X from another tty, not tty1 (so hit Alt+F2, login, and launch X from there).
Do we get ANYTHING that looks like a Xorg.0.log ?
_________________
Votre moment detente
What is the nature of conflict?
Back to top
View user's profile Send private message
tunkaflux
Tux's lil' helper
Tux's lil' helper


Joined: 20 Aug 2003
Posts: 76

PostPosted: Fri Sep 02, 2005 3:37 pm    Post subject: Reply with quote

Trevoke wrote:
This might not work, but try launching X from another tty, not tty1 (so hit Alt+F2, login, and launch X from there).
Do we get ANYTHING that looks like a Xorg.0.log ?


Sorry, forgot to add the bug report: http://bugs.gentoo.org/show_bug.cgi?id=104493 , my Xorg.0.log file is attached there :-)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum