Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How to turn your box into a Xvnc Terminal Server
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 14, 15, 16, 17  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
Uwe
Tux's lil' helper
Tux's lil' helper


Joined: 13 Sep 2004
Posts: 137
Location: Germany

PostPosted: Mon Aug 15, 2005 7:41 pm    Post subject: Reply with quote

I also tried the how-to, with a fresh installes xorg-x11 and gnome/gdm environment. I'm encountering the same issues as many others here... the vncserver process stops immediately after getting started. I can manually start Xvnc anc connect to my X-server, but when i run Xvnc with the -inetd parameter, it just wont start a process at all... It ios not a problem with font-server neither with hosts-allow... march is pentium3 (on a pentium 3 processor ;)). Anybody got a clue?
_________________
registered Linux user #445580
Back to top
View user's profile Send private message
phsdv
Guru
Guru


Joined: 13 Mar 2005
Posts: 372
Location: Europe

PostPosted: Sun Aug 21, 2005 11:25 am    Post subject: Reply with quote

I could not get it working. I followed the howto at http://gentoo-wiki.com/HOWTO_Xvnc_terminal_server. But finnaly I found that when I removed
Code:
securitytypes=none
in the file /etc/xinetd.d/xvncserver every thing works great!

Should this securitytypes=none be removed from the wiki or is there something else I should do to get it working with this option? I have thighvnc 1.3_alpha5 and using only xdm (not gdm nor kde).


Last edited by phsdv on Sun Aug 21, 2005 2:43 pm; edited 1 time in total
Back to top
View user's profile Send private message
Uwe
Tux's lil' helper
Tux's lil' helper


Joined: 13 Sep 2004
Posts: 137
Location: Germany

PostPosted: Sun Aug 21, 2005 12:04 pm    Post subject: Reply with quote

That did the trick, thank you very much!!!
_________________
registered Linux user #445580
Back to top
View user's profile Send private message
newtonian
Guru
Guru


Joined: 19 Jan 2005
Posts: 454
Location: Hokkaido Japan

PostPosted: Sun Aug 21, 2005 3:19 pm    Post subject: vnc server 4.0.5 or better Reply with quote

Hi-

I want to get a vnc terminal server working with vncserver 4.0.5 or better.



I've got about 5 users using my vnc terminal server that I set up with this tutorial.
Originally, I used tightvnc 1.3 alpha5 but that crashed when we used Eclipse.
There is a known bug when you select incorrect code in Eclipse(red wiggly line).
The realvnc vncserver in portage has the same problem.

I tried xf4vnc server in portage. xf4vnc doesn't crash Eclipse but it gives the same
key codes for semi-colon and colon with a Japanese 106 keyboard. Parenthesis and
brackets also have key codes that overlap with other keys, so it's not anything I can
fix with xmodemap.

I asked the users if they would rather have the stability of xf4vnc with
US keyboard mappings or the instability of pre 4.0 vncserver with Japanese key mappings.
They all chose the unstable(with Eclipse) vncserver 3.X series vncserver because they didn't
want to give up their Japanese keyboards. Now my users
are crashing an average of every 30 minutes. The crashing introduces a whole new slew
of problems with locks, unsaved files and runaway processes.

I'd like to give realvnc server version 4.0.5 or newer a try or even something comparable
with tightvnc. Is there an ebuild out there? I've seen some people in the forum post about
the vncserver 4.0.X ebuild, but I haven't found it on bugzilla. I also read that the ebuild
had been pulled. I tried downloading the 4.X vncserver binary from realvnc but my clients
couldn't connect. Anyone have any advice on where I can find the vncserver 4.X ebuild?
Has anyone had any success getting 4.X to work with the terminal server?


Cheers,


Last edited by newtonian on Tue Aug 23, 2005 12:39 pm; edited 1 time in total
Back to top
View user's profile Send private message
branana
n00b
n00b


Joined: 03 Sep 2004
Posts: 29

PostPosted: Tue Aug 23, 2005 8:59 am    Post subject: Reply with quote

I'm having problems getting vnc server running at all, on amd64

is this /usr/bin/Xvnc beast supposed to be symbolic link to something funny?

Mine says

fragbot bran # vncviewer localhost:71
Not a valid VNC server
Back to top
View user's profile Send private message
newtonian
Guru
Guru


Joined: 19 Jan 2005
Posts: 454
Location: Hokkaido Japan

PostPosted: Tue Aug 23, 2005 3:43 pm    Post subject: Re: vnc server 4.0.5 or better Reply with quote

newtonian wrote:
Hi-

I want to get a vnc terminal server working with vncserver 4.0.5 or better.

Cheers,


Ok, I figured out how to get vnc-4.0-r1.ebuild working with this howto.

vim /etc/make.conf

Add the word server to the USE="xxx" line. AKA USE variables. :wink:


I did locate vnc | grep ebuild to find the latest vnc ebuild on my system which was vnc-4.0-r1.
Code:

mammoth david # locate vnc | grep ebuild
/usr/portage/app-vim/svncommand/svncommand-0.2.ebuild
/usr/portage/app-vim/svncommand/svncommand-1.67.3.ebuild
/usr/portage/net-libs/libvncserver/libvncserver-0.7.ebuild
/usr/portage/net-libs/libvncserver/libvncserver-0.7.1.ebuild
/usr/portage/net-misc/directvnc/directvnc-0.7.5.ebuild
/usr/portage/net-misc/tightvnc/tightvnc-1.3_alpha5.ebuild
/usr/portage/net-misc/tightvnc/tightvnc-1.2.8.ebuild
/usr/portage/net-misc/tightvnc/tightvnc-1.2.9-r1.ebuild
/usr/portage/net-misc/tightvnc/tightvnc-1.3_alpha7.ebuild
/usr/portage/net-misc/vnc/vnc-3.3.7.ebuild
/usr/portage/net-misc/vnc/vnc-4.0.ebuild
/usr/portage/net-misc/vnc/vnc-4.0-r1.ebuild
/usr/portage/net-misc/vncrec/vncrec-0.2.ebuild
/usr/portage/net-misc/vncsnapshot/vncsnapshot-1.1.ebuild
/usr/portage/net-misc/vncsnapshot/vncsnapshot-1.2a.ebuild
/usr/portage/net-misc/xf4vnc/xf4vnc-4.3.0.103.ebuild
/usr/portage/net-misc/xf4vnc/xf4vnc-4.3.0.104.ebuild
/usr/portage/x11-misc/vnc2swf/vnc2swf-0.3.ebuild
/usr/portage/x11-misc/vnc2swf/vnc2swf-0.4.2-r1.ebuild
/usr/portage/x11-misc/x2vnc/x2vnc-1.6.1.ebuild
/usr/portage/x11-misc/x11vnc/x11vnc-0.7.2.ebuild
/usr/portage/x11-misc/x11vnc/x11vnc-0.7.1-r1.ebuild
/usr/portage/x11-misc/x11vnc/x11vnc-0.7-r1.ebuild
/var/db/pkg/net-misc/vnc-3.3.7/vnc-3.3.7.ebuild


get rid of the current vnc if you are using it.
Code:

emerge unmerge vnc

next cd to the ebuild directory and and emerge the ebuild:
Code:

cd /usr/portage/net-misc/vnc/
emerge vnc-4.0-r1.ebuild


It might take a while to compile.

After it's done compiling, you need to fix your /etc/xinetd.d/xvncserver (add -SecurityTypes None) to the server_args line.

Code:

service vnc-640x480x8
{
protocol = tcp
socket_type = stream
wait = no
user = nobody
server = /usr/bin/Xvnc
server_args = -inetd -SecurityTypes None   -query localhost -once -geometry 640x480 -depth 8
}

service vnc-800x600x8
{
protocol = tcp
socket_type = stream
wait = no
user = nobody
server = /usr/bin/Xvnc
server_args = -inetd -SecurityTypes None   -query localhost -once -geometry 800x600 -depth 8
}

service vnc-1024x768x8
{
protocol = tcp
socket_type = stream
wait = no
user = nobody
server = /usr/bin/Xvnc
server_args = -inetd -SecurityTypes None   -query localhost -once -geometry 1024x768 -depth 8
}

service vnc-1280x1024x8
{
protocol = tcp
socket_type = stream
wait = no
user = nobody
server = /usr/bin/Xvnc
server_args = -inetd -SecurityTypes None   -query localhost -once -geometry 1280x1024 -depth 8
}

service vnc-1600x1200x8
{
protocol = tcp
socket_type = stream
wait = no
user = nobody
server = /usr/bin/Xvnc
server_args = -inetd -SecurityTypes None   -query localhost -once -geometry 1600x1200 -depth 8
}

service vnc-640x480x16
{
protocol = tcp
socket_type = stream
wait = no
user = nobody
server = /usr/bin/Xvnc
server_args = -inetd -SecurityTypes None   -query localhost -once -geometry 640x480 -depth 16
}
service vnc-800x600x16
{
protocol = tcp
socket_type = stream
wait = no
user = nobody
server = /usr/bin/Xvnc
server_args = -inetd -SecurityTypes None   -query localhost -once -geometry 800x600 -depth 16
}

service vnc-1024x768x16
{
protocol = tcp
socket_type = stream
wait = no
user = nobody
server = /usr/bin/Xvnc
server_args = -inetd -SecurityTypes None  -query localhost -once -geometry 1024x768 -depth 16
}

service vnc-1280x1024x16
{
protocol = tcp
socket_type = stream
wait = no
user = nobody
server = /usr/bin/Xvnc
server_args = -inetd -SecurityTypes None   -query localhost -once -geometry 1280x1024 -depth 16
}

service vnc-1600x1200x16
{
protocol = tcp
socket_type = stream
wait = no
user = nobody
server = /usr/bin/Xvnc
server_args = -inetd -SecurityTypes None   -query localhost -once -geometry 1600x1200 -depth 16
}

service vnc-640x480x24
{
protocol = tcp
socket_type = stream
wait = no
user = nobody
server = /usr/bin/Xvnc
server_args = -inetd -SecurityTypes None   -query localhost -once -geometry 640x480 -depth 24
}

service vnc-800x600x24
{
protocol = tcp
socket_type = stream
wait = no
user = nobody
server = /usr/bin/Xvnc
server_args = -inetd -SecurityTypes None   -query localhost -once -geometry 800x600 -depth 24
}
service vnc-1024x768x24
{
protocol = tcp
socket_type = stream
wait = no
user = nobody
server = /usr/bin/Xvnc
server_args = -inetd -SecurityTypes None   -query localhost -once -geometry 1024x768 -depth 24
}

service vnc-1280x1024x24
{
protocol = tcp
socket_type = stream
wait = no
user = nobody
server = /usr/bin/Xvnc
server_args = -inetd -SecurityTypes None   -query localhost -once -geometry 1280x1024 -depth 24
# port = 5973
}

service vnc-1600x1200x24
{
protocol = tcp
socket_type = stream
wait = no
user = nobody
server = /usr/bin/Xvnc
server_args = -inetd -SecurityTypes None   -query localhost -once -geometry 1600x1200 -depth 24
}

service vnc-640x480x32
{
protocol = tcp
socket_type = stream
wait = no
user = nobody
server = /usr/bin/Xvnc
server_args = -inetd -SecurityTypes None   -query localhost -once -geometry 640x480 -depth 32
}

service vnc-800x600x32
{
protocol = tcp
socket_type = stream
wait = no
user = nobody
server = /usr/bin/Xvnc
server_args = -inetd -SecurityTypes None   -query localhost -once -geometry 800x600 -depth 32
}

service vnc-1024x768x32
{
protocol = tcp
socket_type = stream
wait = no
user = nobody
server = /usr/bin/Xvnc
server_args = -inetd -SecurityTypes None   -query localhost -once -geometry 1024x768 -depth 32
}
service vnc-1280x1024x32
{
protocol = tcp
socket_type = stream
wait = no
user = nobody
server = /usr/bin/Xvnc
server_args = -inetd -SecurityTypes None   -query localhost -once -geometry 1280x1024 -depth 32
}

service vnc-1600x1200x32
{
protocol = tcp
socket_type = stream
wait = no
user = nobody
server = /usr/bin/Xvnc
server_args = -inetd -SecurityTypes None   -query localhost -once -geometry 1600x1200 -depth 32
}


Then reboot. It worked for me on my x86 machine.

Cheers,
Back to top
View user's profile Send private message
newtonian
Guru
Guru


Joined: 19 Jan 2005
Posts: 454
Location: Hokkaido Japan

PostPosted: Tue Aug 23, 2005 3:57 pm    Post subject: Eclipse bug in vnc-4.0-r1.ebuild Reply with quote

Hi-

I tested the vnc-4.0-r1.ebuild to see if it crashes with Eclipse like version vnc 3 does.
vnc-4.0-r1.ebuild failed the Eclipse bug test and crashed like version 3.

In contrast to xf4vnc(which doesn't contain the Eclipse bug), the keyboard mappings work
fine with Japanese 106 keyboards.

Anybody have any luck with getting vnc 4.1 running?

Cheers,
Back to top
View user's profile Send private message
PraetorZero
Apprentice
Apprentice


Joined: 11 Dec 2004
Posts: 239
Location: /home

PostPosted: Wed Aug 24, 2005 1:49 am    Post subject: Reply with quote

phsdv wrote:
I could not get it working. I followed the howto at http://gentoo-wiki.com/HOWTO_Xvnc_terminal_server. But finnaly I found that when I removed
Code:
securitytypes=none
in the file /etc/xinetd.d/xvncserver every thing works great!

Should this securitytypes=none be removed from the wiki or is there something else I should do to get it working with this option? I have thighvnc 1.3_alpha5 and using only xdm (not gdm nor kde).


Y'know, I removed that line and was finally able to connect to the box, but now I can't logout of the session normally. I have to close the VNC window or force-quit X when I'm logged on normally.
Back to top
View user's profile Send private message
mog
Apprentice
Apprentice


Joined: 05 Jul 2003
Posts: 253
Location: Auckland [NZ]

PostPosted: Thu Sep 01, 2005 11:31 pm    Post subject: Reply with quote

Is there a terminal service alternative to VNC and X11 over SSH on linux? I have setup tightvnc TS as per instructions in this guide, but unfortunately, the performance is not ... lets say ... astonishing :(. So, I was wondering if there is any alternative that comes closer to Microsoft's RDP performance wise?
_________________
To thine own self be true.
Back to top
View user's profile Send private message
philidias
n00b
n00b


Joined: 02 Sep 2005
Posts: 6

PostPosted: Fri Sep 02, 2005 11:21 pm    Post subject: thxs Reply with quote

Uwe wrote:
I also tried the how-to, with a fresh installes xorg-x11 and gnome/gdm environment. I'm encountering the same issues as many others here... the vncserver process stops immediately after getting started. I can manually start Xvnc anc connect to my X-server, but when i run Xvnc with the -inetd parameter, it just wont start a process at all... It ios not a problem with font-server neither with hosts-allow... march is pentium3 (on a pentium 3 processor ;)). Anybody got a clue?


thanks, its working
Back to top
View user's profile Send private message
hokie99cpe
n00b
n00b


Joined: 03 Sep 2005
Posts: 4

PostPosted: Sat Sep 03, 2005 8:09 pm    Post subject: Reply with quote

I followed the tutorial and got it sorta working when I removed the securitytypes flag from /etc/xinet.d/xvncserver. Now, when I connect, I get KDM. When I login, the connection dies off with this error message showing up in /var/log/messages:

Code:
Sep  3 16:03:34 localhost kdm: localhost:2[6783]: Cannot execute startup script "/usr/kde/3.4/share/config/kdm/Xstartup"


Xstartup has just this line for my wheelmouse:

Code:
exec /usr/bin/xmodmap -e "pointer = 1 2 3 6 5 4"


I commented out that line and was able to connect via VNC. Anyone have a clean method around this, or will I need to write some logic to detect VNC vs console?

--------------------------------------

I fixed this shortly after posting. I just compared the environment variables when using VNC versus via the console... on the console, DISPLAY = :0. A quick if then fi and I was in business.

Now that that's taken care of, is it possible to use this framework to connect to the console session independent of the user logged on? Or will that user need to enable Xvnc when they login?

-dan
Back to top
View user's profile Send private message
micah_death
n00b
n00b


Joined: 16 Sep 2004
Posts: 73

PostPosted: Tue Sep 13, 2005 3:19 am    Post subject: Reply with quote

Is this supposed to allow you to connect, disconnect and reconnect to the same session? Mine initializes a new instance and I'd lilke to connect to my previous instance... (so I can leave stuff open and come back to it at a later date/time)

Right now it closes everything and cleans up =(
(I am the only user of this PC too if that helps)
Back to top
View user's profile Send private message
lassic
n00b
n00b


Joined: 10 Aug 2005
Posts: 12

PostPosted: Tue Sep 27, 2005 12:06 am    Post subject: Reply with quote

I was also able to get this working only after I removed the following:

securitytypes=none

from /etc/xinetd.d/xvncserver

Should I be concerned about this?
Back to top
View user's profile Send private message
forbjok
Apprentice
Apprentice


Joined: 21 May 2004
Posts: 207
Location: Hordaland, Norge

PostPosted: Sat Nov 05, 2005 12:28 pm    Post subject: Reply with quote

I've tried to get this working. When I log in using vncviewer from another computer, I just get the so-called grey screen and the X cursor, and no login window, or anything else for that matter. It also seems to disconnect automatically after a while (I haven't timed it, but I'm guessing a few minutes)
I've checked the configs several times, and had to add "-SecurityTypes None" in order to even be able to log in using VNC.

This is running on a server, which isn't really supposed to run X on the local console at all, but it did seem to work before I disabled it. (displayed the login window)

I noticed that many others have posted about similar issues, and some have gotten it working, but I can't seem to find any solution to this. I also noticed that this tutorial is rather old, so maybe there is something more that needs to be done for it to work on an updated system?

Anyone have any ideas what could cause this problem?


Thanks in advance.

EDIT:

After doing some more testing on this, I have found that everything seems to be configured correctly, but for some reason, XDMCP is using an incorrect IP address. (don't ask me why, or what for)
When running
Code:
X -query localhost

locally on the server, I got the exact same thing: A useless X session with no login box. Then after a few minutes of idleing, it drops out with the error message:
Code:
XDMCP fatal error: Session failed Session 207248002 failed for display 192.168.1.1:0: Cannot open display

Upon seeing that, I was thinking "192.168.1.1? where the h* is it getting that from"... so I check ifconfig, and indeed that IP has been set on eth2.
Well, eth2 isn't used for anything, so I disable the interface and try to connect again, and BEHOLD... the login box reveals itself.
Then I re-enable eth2, and it immediately goes back to not working.

So, the question is, where on earth is XDMCP getting that IP address from? :?
That interface isn't even used for anything at the moment, and neither is the 192.168.1.1 address - and it most certainly isn't specified anywhere in the XDM configuration. (yes, i tried "grep -r" for it in /etc/xdm)

Does anyone know the reason for this, and/or a way to avoid this problem? (it really should only be using 127.0.0.1, if it needs to use an IP address at all)
At the moment, simply disabling the eth2 interface isn't a problem, but it might be if some day I need to use it for anything...
Back to top
View user's profile Send private message
linuxgeek
n00b
n00b


Joined: 02 Aug 2003
Posts: 46

PostPosted: Sun Nov 20, 2005 9:40 pm    Post subject: Reply with quote

Anyone seen a difference with KDE 3.4.2-r1 and 3.4.3-r1 and Xvnc via Xinetd not working.?

I following with Wiki for Howto Xvnc Terminal server.. on 2 servers.. One works just fine {3.4.2-r1} and
the other does not {3.4.3-r1}

Is there some other security added with

I have tried both settings with and without securitytypes=none

I cannot connect at all.. I can run vncserver and connect to the one it creates remotely.

$ vncviewer serverA:50
Connected to RFB server, using protocol version 3.7
No authentication needed
vncviewer: read: Connection reset by peer

Any ideas?
_________________
Where there is a will there is a way!
Seek enlightenment!!!
Back to top
View user's profile Send private message
linuxgeek
n00b
n00b


Joined: 02 Aug 2003
Posts: 46

PostPosted: Sun Nov 20, 2005 10:21 pm    Post subject: Reply with quote

Nvm I found it...

I had 192.168.25.* for Xaccess changed this * and it worked.

Did a find for Xaccess and found 2 files. I modified both.
_________________
Where there is a will there is a way!
Seek enlightenment!!!
Back to top
View user's profile Send private message
valkyrite
Apprentice
Apprentice


Joined: 19 Sep 2002
Posts: 241

PostPosted: Sat Dec 24, 2005 5:53 am    Post subject: Reply with quote

Thanks for the excellent guide.

I tried everything.

I edited the kdmrc file in /usr/kde/3.4/share/config/kdm/kdmrc. Here is the relevant portion

Quote:

[Xdmcp]
# Whether KDM should listen to incoming XDMCP requests.
# Default is true
Enable=true
# The UDP port on which KDM should listen for XDMCP requests. Do not change.
# Default is 177
Port=177
# File with the private keys of X-terminals. Required for XDM authentication.
# Default is ""
#KeyFile=/usr/kde/3.4/share/config/kdm/kdmkeys


Here is the output of nmap
Quote:

Starting nmap 3.83.DC13 ( http://www.insecure.org/nmap/ ) at 2005-12-23 19:49 EST
Interesting ports on localhost (127.0.0.1):
(The 1664 ports scanned but not shown below are in state: closed)
PORT STATE SERVICE
21/tcp open ftp
22/tcp open ssh
80/tcp open http

Nmap finished: 1 IP address (1 host up) scanned in 0.145 seconds


When I try vncviewer localhost:71

Here is what I get
Quote:

vncviewer: ConnectToTcpAddr: connect: Connection refused
Unable to connect to VNC server


I am guessing the server has not yet started. Here is the output of rc-status
Quote:

Runlevel: default
xdm [ started ]
sshd [ started ]
local [ started ]
vixie-cron [ started ]
syslog-ng [ started ]
coldplug [ started ]
net.eth0 [ started ]
netmount [ started ]
xinetd [ started ]
apache2 [ started ]
hotplug [ started ]
proftpd [ started ]


Any idea what may be wrong. I am using kdm
What should I do?
Back to top
View user's profile Send private message
valkyrite
Apprentice
Apprentice


Joined: 19 Sep 2002
Posts: 241

PostPosted: Sat Dec 24, 2005 6:27 pm    Post subject: Reply with quote

OK figured out the problem:

In the file /etc/xinetd.d/xvncserver,
I had to change the following to as follows:

Instead of
Quote:

server = /usr/bin/Xvnc


change to
Quote:

server = /usr/bin/vncserver



I did not had any Xvnc in /usr/bin or elewhere.

Thanks all of you for an excellent guide.
Back to top
View user's profile Send private message
snizfast
n00b
n00b


Joined: 22 Sep 2004
Posts: 43

PostPosted: Sun Dec 25, 2005 6:18 am    Post subject: Reply with quote

Chances are you are using something other than the tightvnc that the author indicates. I have /usr/bin/Xvnc on my system. The VNC packages are almost drop in replacements for another but they all seem to have their quarks.
_________________
Talk is cheap, supply exceeds demand
alias nocomment='sed -e '\''s/#.*//;/^\s*$/d'\'' '
Back to top
View user's profile Send private message
valkyrite
Apprentice
Apprentice


Joined: 19 Sep 2002
Posts: 241

PostPosted: Sun Dec 25, 2005 6:36 am    Post subject: Reply with quote

I do not know the cause of the problem but I am using tightvnc

Quote:

Searching...
[ Results for search key : tightvnc ]
[ Applications found : 1 ]

* net-misc/tightvnc
Latest version available: 1.2.9-r1
Latest version installed: 1.2.9-r1
Size of downloaded files: 1,697 kB
Homepage: http://www.tightvnc.com/
Description: A great client/server software package allowing remote network access to graphical desktops.
License: GPL-2


I do not have anything by the name Xvnc, but I do have vncserver.

I do not know the reason for it, but now XDMCP works so I am happy. :)
Back to top
View user's profile Send private message
valkyrite
Apprentice
Apprentice


Joined: 19 Sep 2002
Posts: 241

PostPosted: Tue Dec 27, 2005 11:50 pm    Post subject: Reply with quote

Is it possible to operate the machine directly from a browser?

Tightvnc supports it if a session is started.

I want it via XDMCP so that if I write the url with a particular port, it starts a session for me which I can operate from the browser.

Any pointers would be helpful.
Back to top
View user's profile Send private message
SpikeXtrem
Apprentice
Apprentice


Joined: 08 Nov 2004
Posts: 284
Location: Quebec, Canada

PostPosted: Mon Jan 16, 2006 7:00 pm    Post subject: Reply with quote

hi!

I haven't gone trough all the 15 pages, but I read a couple. When I connect to my server, it opens a basing windows like the first time you connect locally on your pc using startx. I need to know how to connect to gnome using this remote desktop.

thx!
_________________
Gentoo'ing Since 11/2004
Intel E6750, 4 Go ram DDR2 800mhz, Leadtek GeForce 8800 GTS 320 megs
kernel 2.6.24-r3
Back to top
View user's profile Send private message
valkyrite
Apprentice
Apprentice


Joined: 19 Sep 2002
Posts: 241

PostPosted: Mon Jan 16, 2006 8:55 pm    Post subject: Reply with quote

Do you have gnome in /etc/rc.conf.

What is the value of environment variable XSESSION
Back to top
View user's profile Send private message
SpikeXtrem
Apprentice
Apprentice


Joined: 08 Nov 2004
Posts: 284
Location: Quebec, Canada

PostPosted: Wed Jan 25, 2006 1:10 am    Post subject: Reply with quote

Code:


# /etc/rc.conf: Global startup script configuration settings

# UNICODE specifies whether you want to have UNICODE support in the console.
# If you set to yes, please make sure to set a UNICODE aware CONSOLEFONT and
# KEYMAP in the /etc/conf.d/consolefont and /etc/conf.d/keymaps config files.

UNICODE="no"

# Set EDITOR to your preferred editor.
# You may use something other than what is listed here.

EDITOR="/bin/nano"
#EDITOR="/usr/bin/vim"
#EDITOR="/usr/bin/emacs"

# What display manager do you use ?  [ xdm | gdm | kdm | entrance ]
DISPLAYMANAGER="gdm"

# XSESSION is a new variable to control what window manager to start
# default with X if run with xdm, startx or xinit.  The default behavior
# is to look in /etc/X11/Sessions/ and run the script in matching the
# value that XSESSION is set to.  The support scripts are smart enough to
# look in all bin directories if it cant find a match in /etc/X11/Sessions/,
# so setting it to "enlightenment" can also work.  This is basically used
# as a way for the system admin to configure a default system wide WM,
# allthough it will work if the user export XSESSION in his .bash_profile, etc.
#
# NOTE:  1) this behaviour is overridden when a ~/.xinitrc exists, and startx
#           is called.
#        2) even if ~/.xsession exists, if XSESSION can be resolved, it will
#           be executed rather than ~/.xsession, else KDM breaks ...
#
# Defaults depending on what you install currently include:
#
# Gnome - will start gnome-session
# kde-<version> - will start startkde (ex: kde-3.0.2)
# Xsession - will start a terminal and a few other nice apps

#XSESSION="Gnome"




I guess I have to uncomment the XSESSION line... I'll try it. But anyone can tell me if it is possible to start a remote session if gnome is'nt started on the local server? Like on the server you would see only the basic command line interface without gnome or kde started, but the remote would enter gnome when they connect vnc?

And I would like a confirmation that the session that is opened trough VNC remains active when you disconnect the server and come back later.

And the vncserver is not active until I type vncserver on the server via ssh.... which is not what I want! How can the vnc server start when the computer boots?

Thank you for answering my questions!
_________________
Gentoo'ing Since 11/2004
Intel E6750, 4 Go ram DDR2 800mhz, Leadtek GeForce 8800 GTS 320 megs
kernel 2.6.24-r3
Back to top
View user's profile Send private message
SpikeXtrem
Apprentice
Apprentice


Joined: 08 Nov 2004
Posts: 284
Location: Quebec, Canada

PostPosted: Wed Jan 25, 2006 2:15 am    Post subject: Reply with quote

I tried to reboot and see. I still have the same xterm session or whatever it's called. :(
_________________
Gentoo'ing Since 11/2004
Intel E6750, 4 Go ram DDR2 800mhz, Leadtek GeForce 8800 GTS 320 megs
kernel 2.6.24-r3
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 14, 15, 16, 17  Next
Page 15 of 17

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum