Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Få Gentoo på norsk/dansk/svenska
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
keno8
n00b
n00b


Joined: 17 Apr 2004
Posts: 6
Location: Stockholm

PostPosted: Sat Aug 21, 2004 8:56 pm    Post subject: Reply with quote

Hej kanse inte hör hema här man jag postar den en då
Mozilla, Firefox, Thunderbird på svenska
Kan va krongligt att instaler man det går med lite envis het och förbrilt trukende på musen :)
_________________
Jag är söt
Back to top
View user's profile Send private message
QuizMasta
n00b
n00b


Joined: 07 Mar 2004
Posts: 10

PostPosted: Tue Sep 14, 2004 9:03 am    Post subject: Reply with quote

Under opstart får jeg:
Code:
Setting user font
  Cannot open font file latin0-16
  Cannot open font file latin0-16
  Cannot open font file latin0-16
  Cannot open font file latin0-16
  Cannot open font file latin0-16
  Cannot open font file latin0-16
  Cannot open font file latin0-16
  Cannot open font file latin0-16
  Cannot open font file latin0-16
  Cannot open font file latin0-16
  Cannot open font file latin0-16
     Failed to set user font


gentoo-dev-sources 2.6.8-r3

Jeg tror jeg mangler en font-fil :) men hvordan får jeg den igen?
_________________
Dr. Frankenstein: Damn your eyes!!
Igor: Too late!
Back to top
View user's profile Send private message
chop
n00b
n00b


Joined: 28 Sep 2004
Posts: 1

PostPosted: Tue Sep 28, 2004 5:27 pm    Post subject: Reply with quote

Hmm, har litt problemer.
Æøå fungerer i konsollet, men jeg ikke i Eterm/Aterm/Xterm @ Xorg.
Back to top
View user's profile Send private message
gau
n00b
n00b


Joined: 05 Nov 2004
Posts: 14
Location: noway - nowar - NORWAY!

PostPosted: Fri Nov 05, 2004 12:56 am    Post subject: Reply with quote

Tips:

Vil du, som meg, ha gaim på engelsk, men med norsk stavekontroll så kan du starte gaim med:

Code:
LANG="no_NB" gaim


For å få dette til å virke i en gnome snarvei må du lage et skript (kjørbar fil) med denne linja i og peke snarveien til skriptet.
Back to top
View user's profile Send private message
agne
n00b
n00b


Joined: 03 Nov 2004
Posts: 61

PostPosted: Wed Nov 24, 2004 2:34 pm    Post subject: Reply with quote

hur får man åäö, att synas som åäö i Eterm/Aterm/Xterm @ Xorg och inte istället för skumma krummelurer..
Back to top
View user's profile Send private message
Freso
n00b
n00b


Joined: 30 Oct 2004
Posts: 23
Location: Copenhagen, Denmark

PostPosted: Wed Jan 12, 2005 6:50 pm    Post subject: Re: HOWTO: Få Gentoo på norsk/dansk/svenska Reply with quote

Cossins wrote:
DANSKE FILSPEJLE
Jeg kender ingen danske filspejle (der er sikkert et på sunsite.dk) - hvis nogen kender et, sig til...
DKUUG og en anden (sunsite muligvis) har i hvert fald. Skriver dem lige ned når jeg booter ind i min Linux om lidt for at få lidt mere til at virke på den. :)
(Har f.eks. stadig ikke netadgang derinde fra - vil bl.a. emerge'e pcmcia-cs og se om det mon ikke skulle hjælpe ;))

Edit: Det var så UNI-C jeg tænkte på, og altså ikke sunsite. Men, UNI-C og DIKU har tilsyneladende begge sat Gentoo-spejle op.
Back to top
View user's profile Send private message
Fanatic
Apprentice
Apprentice


Joined: 02 May 2004
Posts: 173
Location: Stocktown

PostPosted: Thu Jan 13, 2005 4:51 am    Post subject: Reply with quote

dyfofu wrote:
hur får man åäö, att synas som åäö i Eterm/Aterm/Xterm @ Xorg och inte istället för skumma krummelurer..


vim /etc/env.d/02locale där du skriver in

Code:

LC_CTYPE=sv_SE
LANG=C


och sedan env-update && source /etc/profile


Last edited by Fanatic on Thu Jun 23, 2005 1:17 am; edited 1 time in total
Back to top
View user's profile Send private message
nightfrost
Apprentice
Apprentice


Joined: 07 Dec 2004
Posts: 293
Location: Sweden

PostPosted: Tue Jan 18, 2005 2:12 pm    Post subject: Reply with quote

Hej!

I min gamla installation av gentoo (som var en stage3-installation), hade jag lyckats få allt (utanför DE/WM-världen alltså) på svenska. Om jag körde nano t ex, så stod allting på svenska. Nu har jag gjort en stage1-installation och kan inte längre programmen att svara på svenska.

kör jag locale får jag:

Code:
LANG=
LC_CTYPE="sv_SE"
LC_NUMERIC="sv_SE"
LC_TIME="sv_SE"
LC_COLLATE="sv_SE"
LC_MONETARY="sv_SE"
LC_MESSAGES="sv_SE"
LC_PAPER="sv_SE"
LC_NAME="sv_SE"
LC_ADDRESS="sv_SE"
LC_TELEPHONE="sv_SE"
LC_MEASUREMENT="sv_SE"
LC_IDENTIFICATION="sv_SE"
LC_ALL=sv_SE


LANG verkar inte fixa sig. Skriver jag in export LANG="sv_SE", står LANG som sv_SE nästa gång jag kör locale.

locale -a ger mig följande:

Code:
C
en_US
en_US.iso885915
POSIX
sv_SE
sv_SE.iso885915


Fattas jag någonting som jag måste emergea? I så fall vad?

Tack för hjälpen.
Back to top
View user's profile Send private message
nightfrost
Apprentice
Apprentice


Joined: 07 Dec 2004
Posts: 293
Location: Sweden

PostPosted: Tue Jan 18, 2005 2:13 pm    Post subject: output på svenska försvann efter stage1 installation Reply with quote

Hej!

I min gamla installation av gentoo (som var en stage3-installation), hade jag lyckats få allt (utanför DE/WM-världen alltså) på svenska. Om jag körde nano t ex, så stod allting på svenska. Nu har jag gjort en stage1-installation och kan inte längre programmen att svara på svenska.

kör jag locale får jag:

Code:
LANG=
LC_CTYPE="sv_SE"
LC_NUMERIC="sv_SE"
LC_TIME="sv_SE"
LC_COLLATE="sv_SE"
LC_MONETARY="sv_SE"
LC_MESSAGES="sv_SE"
LC_PAPER="sv_SE"
LC_NAME="sv_SE"
LC_ADDRESS="sv_SE"
LC_TELEPHONE="sv_SE"
LC_MEASUREMENT="sv_SE"
LC_IDENTIFICATION="sv_SE"
LC_ALL=sv_SE


LANG verkar inte fixa sig. Skriver jag in export LANG="sv_SE", står LANG som sv_SE nästa gång jag kör locale.

locale -a ger mig följande:

Code:
C
en_US
en_US.iso885915
POSIX
sv_SE
sv_SE.iso885915


Fattas jag någonting som jag måste emergea? I så fall vad?

Tack för hjälpen.
Back to top
View user's profile Send private message
Freso
n00b
n00b


Joined: 30 Oct 2004
Posts: 23
Location: Copenhagen, Denmark

PostPosted: Wed Jan 19, 2005 5:48 am    Post subject: Reply with quote

Har du Unicode/ISO10646 (UTF-8) på dit system? Det kan være du mangler sv_SE.utf8... og prøv at redigere i /etc/env.d/02locale og sætte LANG, LANGUAGE og LC_ALL ="sv_SE[.[utf-8|iso-8859-15]|@euro]".
_________________
Frederik 'Freso' S. Olesen
Back to top
View user's profile Send private message
nightfrost
Apprentice
Apprentice


Joined: 07 Dec 2004
Posts: 293
Location: Sweden

PostPosted: Wed Jan 19, 2005 12:18 pm    Post subject: Reply with quote

Freso wrote:
Har du Unicode/ISO10646 (UTF-8) på dit system? Det kan være du mangler sv_SE.utf8... og prøv at redigere i /etc/env.d/02locale og sætte LANG, LANGUAGE og LC_ALL ="sv_SE[.[utf-8|iso-8859-15]|@euro]".


konstigt börjar det sakta men säkert dyka upp meddelanden på svenska (jag har inte ändrat något än); först fick jag några felmeddelanden på svenska (från mount /umount), och sen visade dig sig (c)fdisk blev svensk. Men nano är t ex fortfarande på engelska (jag har som sagt haft den på svenska tidigare). Jag ska emergea den igen för att kolla om det funkar (den är redan emergead med +nls). Men det hela är mycket mystiskt...
Back to top
View user's profile Send private message
jonasmattsson
n00b
n00b


Joined: 20 May 2004
Posts: 71
Location: Gothenburg, Sweden

PostPosted: Sun Jan 23, 2005 11:09 pm    Post subject: Reply with quote

Jag har jättekonstiga med mina åäö både som root och som användare. det konstigaste är att det inte är konsekvent. om jag tex vill starta xmms från gnome-menyn så blir åäö helt ur-k**ade medans om jag startar xmms från gnome-terminal:en så blir allting bra (allting? mjae) förutom filnamn, dom blir inte bra i xmms, filnamn blr däremot bra i terminalen, samma problem får jag med gnome-commander bara att där blir ingenting bättre för att jag startar den ifrån terminalen. gabber och ayttm beter sig likadant som xmms men många andra program verkar inte ha några problem. är det någon som kan hjälpa/tipsa?

jag antar att det är ett sjuttiotal miljövariabler som måste balanseras j***igt väl, men vilka? om det nu är så.

lite output som andra verkar tycka är viktig
Code:
 ~ $ locale
LANG=sv_SE
LC_CTYPE="sv_SE"
LC_NUMERIC="sv_SE"
LC_TIME="sv_SE"
LC_COLLATE="sv_SE"
LC_MONETARY="sv_SE"
LC_MESSAGES="sv_SE"
LC_PAPER="sv_SE"
LC_NAME="sv_SE"
LC_ADDRESS="sv_SE"
LC_TELEPHONE="sv_SE"
LC_MEASUREMENT="sv_SE"
LC_IDENTIFICATION="sv_SE"
LC_ALL=sv_SE
~ $ locale charmap
ISO-8859-1
~ $ grep CONSOLE /etc/rc.conf
CONSOLEFONT="iso01.14"
CONSOLETRANSLATION="8859-1_to_uni"
~ $ grep KEY /etc/rc.conf
KEYMAP="sv-latin1"
SET_WINDOWKEYS="yes"
EXTENDED_KEYMAPS="backspace keypad euro"

detta känns väldigt störande, det är nästan så att man funderar på att byta förstaspråk. Ett stort tack utlovas till den som kan reda ut denna härva med Miljövariabler åt höger å vänster och massa olika konfigurationsfiler åt mig.
_________________
when he was six he believed that the moon overhead followed him
by nine he had deciphered the illusion, trading magic for fact
no tradebacks.
so this is what it's like to be an adult
if he only knew now what he knew then.
Back to top
View user's profile Send private message
nightfrost
Apprentice
Apprentice


Joined: 07 Dec 2004
Posts: 293
Location: Sweden

PostPosted: Mon Jan 24, 2005 11:07 am    Post subject: Reply with quote

charmap måste i alla fall vara 8859-15, annars försvinner öäå. Jag gissar på att det är det enda du behöver fixa egentligen, alltså byta alla referenser till 8859-1 till 8859-15 :)
Back to top
View user's profile Send private message
Caesar
n00b
n00b


Joined: 03 Aug 2004
Posts: 21
Location: Huddinge, Stockholm, Sweden

PostPosted: Tue Jan 25, 2005 6:46 pm    Post subject: Reply with quote

nightfrost wrote:
byta alla referenser till 8859-1 till 8859-15 :)

Enda skillnaden mellan de två teckenmappningarna är väl eurotecknet €?
_________________
A noble spirit embiggens the smallest man.
Back to top
View user's profile Send private message
jonasmattsson
n00b
n00b


Joined: 20 May 2004
Posts: 71
Location: Gothenburg, Sweden

PostPosted: Wed Jan 26, 2005 8:20 pm    Post subject: Reply with quote

mitt problem verkar vara att miljövariablerna är olika inuti gnome än i terminalen, vad beträffar gnome-commander så tar den antagligen variaberna ifrån gnome oavsett varifrån den startar.
Terminalens miljö sätts upp enligt alla guider somjag har läst, hen hur ändrar man miljövariabler i själva GNOME??? hittar inget smidigt verktyg eller config-fil. dessutom skulle det vara trevligt om terminalen kunde ärva hela sin miljö ifrån gnome istället för att ändra den utifrån andra filer.
Om någon vet hur man löser detta, så känn er välkomna att tala om det för mig.
tack på förhand

/Jonas
_________________
when he was six he believed that the moon overhead followed him
by nine he had deciphered the illusion, trading magic for fact
no tradebacks.
so this is what it's like to be an adult
if he only knew now what he knew then.
Back to top
View user's profile Send private message
MagnusBerg
Guru
Guru


Joined: 07 Oct 2003
Posts: 370
Location: Burgsvik, Gotland, Sweden

PostPosted: Wed Apr 13, 2005 6:46 am    Post subject: Reply with quote

Är det ingen som kan det här med språkinställningar och teckenuppsättningar som kan skriva en komplett how-to med beskrivningar och exempel på vilka filer som ska ändras och vad man lämpligen ska skriva i dem och varför???
Hade jag kunskapen skulle jag göra det själv. Sen kan man ersätta den här nu ganska långa och faktamässigt uttunnade tråden med en ny.

Jag har precis klurat ut hur jag ska få OpenOffice-Ximian att kompilera på svenska, i går blev det engelska. :-(
/etc/env.d/locale och lägg till
Code:
LINGUAS="sv"
Den lösningen bygger inte på någon kunskap utan på att jag testade mig fram. ;-)
Back to top
View user's profile Send private message
nightfrost
Apprentice
Apprentice


Joined: 07 Dec 2004
Posts: 293
Location: Sweden

PostPosted: Wed Apr 13, 2005 7:43 am    Post subject: Reply with quote

Det låter som en bra idé. Men det behövs egentligen inte mer tillägg till den första posten i tråden än 1) LINGUAS="sv"-inställningen (som man kan ha i /etc/make.conf istället om man vill; det är där jag har den :)) och 2) kompileringsinställningar för glibc.

Jag är lite upptagen just nu, och dessvärre lite datorlös :cry:, men om ingen har satt ihop en howto till dess att jag har fått min dator och lite tid på händerna, så kan jag tänka mig att skriva ihop något...
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4836
Location: Gothenburg, Sweden

PostPosted: Wed Apr 13, 2005 8:21 am    Post subject: Reply with quote

På engelska och med tyska som exempel finns http://www.gentoo.org/doc/en/guide-localization.xml Martin Skjöldebrand håller på att översätta diverse dokumentation till svenska och skulle uppskatta lite hjälp.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
forsen
n00b
n00b


Joined: 01 Nov 2003
Posts: 23
Location: Oslo, Norway

PostPosted: Wed Apr 13, 2005 2:15 pm    Post subject: Reply with quote

Sliter litt med å få norske tegn i tetex. Bruker kile som editor, og kdvi som dviviewer. skriver jeg norske tegn i teksten, så oppstår de som mellomrom i kdvi. noen som vet hvordan jeg kan få fikset det?
Back to top
View user's profile Send private message
MagnusBerg
Guru
Guru


Joined: 07 Oct 2003
Posts: 370
Location: Burgsvik, Gotland, Sweden

PostPosted: Thu Apr 14, 2005 1:17 pm    Post subject: Reply with quote

kallamej wrote:
På engelska och med tyska som exempel finns http://www.gentoo.org/doc/en/guide-localization.xml Martin Skjöldebrand håller på att översätta diverse dokumentation till svenska och skulle uppskatta lite hjälp.


Åhhh, fan! Det händer mycket på dokumentfronten som jag inte har koll på. När jag började med Gentoo fanns det inte mycket och sen dess har jag inte kollat så noga vad som tillkommit utan gnäller bara helt omotiverat. :-) Personligen är jag nöjd med den engelska versionen även om jag välkomnar en svensk.
Back to top
View user's profile Send private message
leifbk
Apprentice
Apprentice


Joined: 05 Jan 2004
Posts: 286
Location: Bærum, Norway

PostPosted: Sat Jul 02, 2005 11:47 am    Post subject: Reply with quote

For å kompilere kde-i18n i KDE 3.4.1 for norsk bokmål måtte jeg legge inn følgende:

Code:

/etc/make.conf:
LINGUAS="nb"

/etc/profile:
LINGUAS="no nb"
export LINGUAS


og så kjøre en
Code:
source /etc/profile
etterpå.

Dette er svakt dokumentert.

mvh Leif
_________________
The Yggdrasil Genealogy Project
Back to top
View user's profile Send private message
Bent Ove
n00b
n00b


Joined: 30 Jul 2005
Posts: 1

PostPosted: Sat Jul 30, 2005 5:14 pm    Post subject: Reply with quote

Hei jeg lurte på om noen kan helpe litt jeg er nye med linux:oops:
jeg prøvde å installere gentoo med så kom jeg til livecd@root hva skal jeg gjøre da hva skal jeg skrive for å fortsette???:oops:
Back to top
View user's profile Send private message
drzap
n00b
n00b


Joined: 20 Sep 2004
Posts: 23

PostPosted: Wed Aug 10, 2005 12:27 pm    Post subject: Reply with quote

Noken burde forandre howtoen for det norske oppsettet, det bruker dei gamle filene. No skal vel /etc/env.d/02locale brukast, og ikkje /etc/profile

Og er nn_NO det som skal brukast for norsk, nynorsk? eller nno_NO? nn@nynorsk?
Back to top
View user's profile Send private message
netshade
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2004
Posts: 82
Location: Sweden

PostPosted: Mon Aug 22, 2005 4:26 pm    Post subject: Reply with quote

Hmm, jag får inte till svenska tecken i xorg utan att köra en egen .Xmodmap fil... Hur gör jag / vilken setxkbmap-rad behövs? (Har provat dom som KDE spottar fram när man leker med inställningarna i terminal, men då får jag bara svaret att den inte kan ladda keymap...)

Code:
setxkbmap -model microsoftpro -layout us,se -variant ,nodeadkeys

resulterar i:
Code:
Error loading new keyboard description


Har testat diverse varianter utan några som helst lyckliga resultat...
Hjälp?
(Och lösningen för att få åäö att fungera i aTerm hjälpte inte heller, får \ och några siffror nu istället för tidigare grekiska tecken... )
_________________
From where the shadows turn into nightmare, netshade greets you...
Back to top
View user's profile Send private message
d4n1el
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jun 2004
Posts: 76

PostPosted: Mon Oct 17, 2005 1:58 pm    Post subject: Reply with quote

maxmc wrote:
Gentoo på Svenska

Code:
nano -w 02locale

Lägg in:
Code:
LC_ALL=sv_SE
LC_TELEPHONE=sv_SE
LANG=sv_SE
LC_CTYPE=sv_SE
LC_NUMERIC=sv_SE
LC_TIME=sv_SE
LC_MONETARY=sv_SE
LC_ADDRESS=sv_SE
LC_COLLATE=sv_SE
LC_NAME=sv_SE
LC_PAPER=sv_SE
LC_NUMERIC=sv_SE
SYSFONT=lat0-16
LC_MEASUREMENT=sv_SE
LC_MESSAGES=sv_SE
LC_IDENTIFICATION=sv_SE




hej!
foljer denna posten for att fa gentoo pa svenska. men far det itne att fungera.. fortfarande engelskt tangentbord, och nar jag komplierar prog. sa klagar den pa det jag har i 02locale
den sager att jag ska kolla om
Code:
LC_ALL=sv_SE
LC_TELEPHONE=sv_SE
LANG=sv_SE
LC_CTYPE=sv_SE
LC_NUMERIC=sv_SE
LC_TIME=sv_SE
LC_MONETARY=sv_SE
LC_ADDRESS=sv_SE
LC_COLLATE=sv_SE
LC_NAME=sv_SE
LC_PAPER=sv_SE
LC_NUMERIC=sv_SE
SYSFONT=lat0-16
LC_MEASUREMENT=sv_SE
LC_MESSAGES=sv_SE
LC_IDENTIFICATION=sv_SE

ar installerar pa systemet, elelr nagot sadant..

vet nan om detta har forandrats i nagon uppdatering eller vad felet ar!

sen kan jag meddela att den behovs uppdateras, for man ska nu inte skriva in keymap och consolefont i /etc/rc.conf utan i /etc/conf.d/consolefont och /etc/conf.d/keymaps
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum