Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GStreamer Pipeline Problems (with alsasink)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
djnauk
Apprentice
Apprentice


Joined: 11 Feb 2003
Posts: 183
Location: Caerphilly, Wales, UK

PostPosted: Thu Mar 03, 2005 1:40 pm    Post subject: GStreamer Pipeline Problems (with alsasink) Reply with quote

I can play music and sounds on my system fine. Beep-media-player doesn't have a problem with playing music. However, I'm trying to get Muine up and running and I'm getting problems with GStreamer. Running gstreamer-properties, setting to ALSA and clicking test gives:

"Failed to construct test pipeline for 'ALSA - Advanced Linux Sound Architecture'"

Selected custom and entering ossink or alsasink does the same thing. The same message comes up with all tests, input and output, video or audio. I've tried a few times to rebuild gstreamer, in fact I've just rebuilt gst-plugings-alsa and I've not lost the ASLA option in the dropdowns! :/

Looking at the logs I get:

Code:
Added plugin vorbis with 4 features.
Added plugin ogg with 2 features.
Added plugin alsa with 3 features.
Added plugin ximagesink with 1 feature.


Among many others. Running gstreamer-properties gives me the following errors:

Quote:
jonathan root # gstreamer-properties

** (gstreamer-properties:32647): CRITICAL **: how to remove plugins?

(gstreamer-properties:32647): GStreamer-CRITICAL **: Factory for `alsasink' has no type. This probably means the plugin wasn't found because the registry is broken. The plugin GStreamer was looking for is named 'alsa' and is expected in file '/usr/lib/gstreamer-0.8/libgstalsa.so'. The registry for this plugin is located at '/var/lib/cache/gstreamer-0.8/registry.xml'

** (gstreamer-properties:32647): CRITICAL **: how to remove plugins?

(gstreamer-properties:32647): GStreamer-CRITICAL **: Factory for `ximagesink' has no type. This probably means the plugin wasn't found because the registry is broken. The plugin GStreamer was looking for is named 'ximagesink' and is expected in file '/usr/lib/gstreamer-0.8/libgstximagesink.so'. The registry for this plugin is located at '/var/lib/cache/gstreamer-0.8/registry.xml'

** (gstreamer-properties:32647): CRITICAL **: how to remove plugins?

(gstreamer-properties:32647): GStreamer-CRITICAL **: Factory for `alsasrc' has no type. This probably means the plugin wasn't found because the registry is broken. The plugin GStreamer was looking for is named 'alsa' and is expected in file '/usr/lib/gstreamer-0.8/libgstalsa.so'. The registry for this plugin is located at '/var/lib/cache/gstreamer-0.8/registry.xml'


Then selected Custom (not the only option), entering 'alsasink' and then clicking test gives:

Quote:
** (gstreamer-properties:32647): CRITICAL **: how to remove plugins?

(gstreamer-properties:32647): GStreamer-CRITICAL **: Factory for `audioconvert' has no type. This probably means the plugin wasn't found because the registry is broken. The plugin GStreamer was looking for is named 'gstaudioconvert' and is expected in file '/usr/lib/gstreamer-0.8/libgstaudioconvert.so'. The registry for this plugin is located at '/var/lib/cache/gstreamer-0.8/registry.xml'

** (gstreamer-properties:32647): CRITICAL **: how to remove plugins?

(gstreamer-properties:32647): GStreamer-CRITICAL **: Factory for `alsasink' has no type. This probably means the plugin wasn't found because the registry is broken. The plugin GStreamer was looking for is named 'alsa' and is expected in file '/usr/lib/gstreamer-0.8/libgstalsa.so'. The registry for this plugin is located at '/var/lib/cache/gstreamer-0.8/registry.xml'


Any ideas?
_________________
Jonathan Wright (Technical Director, JAB Web Solutions)

UK Hosting & Reseller Hosting from JAB Web Solutions
Back to top
View user's profile Send private message
Spoony
Tux's lil' helper
Tux's lil' helper


Joined: 18 Feb 2004
Posts: 99
Location: Washington DC

PostPosted: Mon Mar 21, 2005 6:15 pm    Post subject: Reply with quote

I'm having the same exact problems after I upgraded to gnome 2.10.

I still have sound...but I can't adjust the sound with the gnome-volume-control

Have you solved the problem...or has anyone else??
_________________
Regards,
Mike Sponsler
msponsler at gmail.com
Back to top
View user's profile Send private message
djnauk
Apprentice
Apprentice


Joined: 11 Feb 2003
Posts: 183
Location: Caerphilly, Wales, UK

PostPosted: Mon Mar 21, 2005 8:16 pm    Post subject: Reply with quote

Spoony wrote:
I'm having the same exact problems after I upgraded to gnome 2.10.

I still have sound...but I can't adjust the sound with the gnome-volume-control

Have you solved the problem...or has anyone else??


I haven't solved it, although I'm only running Gnome 2.8.2. I've tried upgrading to the most (~x86) version of GStreamer, and gst-plugins then deleting the registry.xml file and re-running gst-register. Same problems.

Although I did notice that if I deleted the registry.xml, ALSA re-appeared as an option for gstreamer-properties, but the program crashed when you click test (segmentation fault! :)) Also, I've got no problems with my volume buttons - the little gnome window appears in the lower-middle of the screen for me to change volume, while alsamixer and gnome-alsamixer report the soundcard file :/

I've also upgraded to the latest gentoo-sources (2.6.11-r4), no change. I'm going to try and see about removing all the alsa/gstreamer stuff and re-installing. Maybe that'll help?
_________________
Jonathan Wright (Technical Director, JAB Web Solutions)

UK Hosting & Reseller Hosting from JAB Web Solutions
Back to top
View user's profile Send private message
CoolAJ86
n00b
n00b


Joined: 24 May 2004
Posts: 61
Location: Shelburne, VT

PostPosted: Sun May 08, 2005 12:39 pm    Post subject: Reply with quote

How there been any resolution to the gstreamer issue?

Is anyone who has this issue using gcc-3.3.4? Or are we all using gcc-3.4.3?

I was running gnome-2.10 a few weeks ago just fine, but since then I've reinstalled my system with gcc-3.4.3, ntpl, prelink, GNU/Linux 2.6 and all that other elegant jazz that makes your system better (but using safe CFLAGS).

When I emerge gnome-2.10 on this new system it hangs while starting up, so I removed everything from /etc/portage/packages.unmask and /etc/portage/packages.keywords that I had to add for gnome-2.10 and emerged gnome-2.8, but gstreamer isn't working.
_________________
"May the source be with you."

Laterz-
~CoolAJ86
http://CoolAJ86.Havenite.net
http://www.uvm.org/vague - LUG VT
Back to top
View user's profile Send private message
djnauk
Apprentice
Apprentice


Joined: 11 Feb 2003
Posts: 183
Location: Caerphilly, Wales, UK

PostPosted: Sun May 08, 2005 2:17 pm    Post subject: Reply with quote

I managed to get gstreamer working again by clearing all LDFLAGS (note the space in the LDFLAGS option below) and CFLAGS options:

Code:
LDFLAGS=" " CLFAGS="-O2" emerge gstreamer etc..


Works like a charm now! :)
_________________
Jonathan Wright (Technical Director, JAB Web Solutions)

UK Hosting & Reseller Hosting from JAB Web Solutions
Back to top
View user's profile Send private message
CoolAJ86
n00b
n00b


Joined: 24 May 2004
Posts: 61
Location: Shelburne, VT

PostPosted: Tue May 10, 2005 2:40 am    Post subject: Reply with quote

This is how I remerged gstreamer and all of the gstreamer plugins.

# gcc-config -l | grep "*"
> [5] i686-pc-linux-gnu-3.4.3-20050110 *
# emerge -C gstreamer; LDFLAGS=" " emerge gstreamer
# cd /usr/portage/; ls -1d media-plugins/gst-plugins-* | while read PLUGIN; do ls -1 /usr/portage/packages/${PLUGIN}* >&/dev/null && emerge -C ${PLUGIN} && LDFLAGS=" " emerge ${PLUGIN}; done;
# emerge -C gstreamer; LDFLAGS=" " emerge gstreamer;
# rm .gstreamer-0.8/ -rf
# gst-register
# gstreamer-properties

Same error.
Ugh... http://bugs.gentoo.org/show_bug.cgi?id=91880

Apparently I just haven't been around before when this message comes on the screen:

Gstreamer has known problems with prelinking, as a workaround
* this ebuild adds the gstreamer plugins to the prelink mask
* path to stop them from being prelinked. It is imperative
* that you undo & redo prelinking after building this pack for
* this to take effect. Make sure the gstreamer lib path is indeed
* added to the PRELINK_PATH_MASK environment variable.
* For more information see http://bugs.gentoo.org/show_bug.cgi?id=81512

Someone seriously needs to make the searching of the bugs database include the body and comments of the bug, not just the title. I could have had this fixed hours ago...

Code:
/etc/env.d/60prelink
PRELINK_PATH_MASK=/usr/lib/wine:/usr/lib/valgrind:/usr/lib/gstreamer-0.8
PRELINK_PATH=""

_________________
"May the source be with you."

Laterz-
~CoolAJ86
http://CoolAJ86.Havenite.net
http://www.uvm.org/vague - LUG VT
Back to top
View user's profile Send private message
CoolAJ86
n00b
n00b


Joined: 24 May 2004
Posts: 61
Location: Shelburne, VT

PostPosted: Wed May 11, 2005 9:48 pm    Post subject: Still Need Help!! Reply with quote

I was pretty sure after checking out that bug report that it would solve my problem... NOPE!!

gstreamer-properties still won't work!

I switched my gcc profile to 3.3.5 and correced a few CFLAGS in /etc/make.conf to correct that
Code:
gcc-config i686-pc-linux-gnu-3.3.5-20050130
env-update
source /etc/profile


I commented the LDFLAGS out of /etc/make.conf

I got rid of prelink entirely
Code:
emerge -C prelink


I got rid of every binary I could find related to gstreamer (and reinstalled)
Code:
emerge -C gstreamer gst-plugins gst-plugins-alsa gst-plugins-oss gst-plugins-xvideo gst-plugins-mad gst-plugins-gnomevfs gst-plugins-vorbis gst-plugins-flac gst-plugins-ogg gst-plugins-ffmpeg gst-plugins-cdparanoia gst-plugins-faad gst-plugins-lame


I even REBOOTED and it still doesn't work!!!!

Code:
** (gstreamer-properties:22117): CRITICAL **: how to remove plugins?

(gstreamer-properties:22117): GStreamer-CRITICAL **: Factory for `alsasink' has no type. This probably means the plugin wasn't found because the registry is broken. The plugin GStreamer was looking for is named 'alsa' and is expected in file '/usr/lib/gstreamer-0.8/libgstalsa.so'. The registry for this plugin is located at '/var/lib/cache/gstreamer-0.8/registry.xml'


After all of that I resorted to prepackaged binaries from http://chinstrap.alternating.net/files/2005.0/grp/i686/
and still no luck whatsoever!!!

I've tried running it as root, and gst-register
I've checked that all of my sound devices exist with good permissions
Code:
ls /dev/sound/ -la
total 0
drwxr-xr-x   2 root root       0 May 11 17:43 .
drwxr-xr-x  26 root root       0 May 11 17:43 ..
crw-rw----   1 root audio 14, 12 May 11 17:43 adsp
crw-rw----   1 root audio 14,  4 May 11 17:43 audio
crw-rw----   1 root audio 14,  3 May 11 17:43 dsp
crw-rw----   1 root audio 14,  0 May 11 17:43 mixer
crw-rw----   1 root audio 14,  1 May 11 17:43 sequencer
crw-rw----   1 root audio 14,  8 May 11 17:43 sequencer2


alsa/alsasound is loaded at boot, correctly configured for my 'creative sblive value' emu10k1

I have no idea what could possibly at all be wrong. Any additional troubleshooting tips would be Xtremely helpful!!!
_________________
"May the source be with you."

Laterz-
~CoolAJ86
http://CoolAJ86.Havenite.net
http://www.uvm.org/vague - LUG VT
Back to top
View user's profile Send private message
djnauk
Apprentice
Apprentice


Joined: 11 Feb 2003
Posts: 183
Location: Caerphilly, Wales, UK

PostPosted: Thu May 12, 2005 8:01 am    Post subject: Re: Still Need Help!! Reply with quote

CoolAJ86 wrote:
I commented the LDFLAGS out of /etc/make.conf


I don't have LDFLAGS set in my make.conf, yet they still seam to cause a problem. Try setting LDFLAGS=" " (note the space) on the command problem before emerge (i.e. LDFLAGS=" " emerge gstreamer) and see if that works.

As for versions - i'm running 0.8.9-r3 of gstreamer and 0.8.8 of gst-plugins, 3.4.3.20050110-0 of gcc and 2.3.4.20041102-r1 of glibc.
_________________
Jonathan Wright (Technical Director, JAB Web Solutions)

UK Hosting & Reseller Hosting from JAB Web Solutions
Back to top
View user's profile Send private message
CoolAJ86
n00b
n00b


Joined: 24 May 2004
Posts: 61
Location: Shelburne, VT

PostPosted: Mon May 16, 2005 3:05 pm    Post subject: Reply with quote

I tried putting the space in LDFLAGS=" ", but I still had the same problem. I had even tried using I'm utterly clueless. The system I'm setting up now will be a desktop system though, so I need to have it. I did an `emerge -e world` after removing prelink and LDFLAGS, but then everything went to crap. I'm recompiling from a stage1 without prelink or LDFLAGS, perhaps this time it will work as expected.
_________________
"May the source be with you."

Laterz-
~CoolAJ86
http://CoolAJ86.Havenite.net
http://www.uvm.org/vague - LUG VT
Back to top
View user's profile Send private message
CoolAJ86
n00b
n00b


Joined: 24 May 2004
Posts: 61
Location: Shelburne, VT

PostPosted: Thu May 19, 2005 3:09 pm    Post subject: A MIRACLE!!! Reply with quote

http://bugs.gentoo.org/show_bug.cgi?id=70631

Found it. I haven't actually gone home to make sure I can hear sound, however, I used ssh with X forwarding enabled and I could open gstreamer-properties without any error messages.

The issue I'm having was that I was compiling with the hardened version of gcc 3.3.5 and 3.4.3
to switch profiles, do this:

Code:
gcc-config -l
gcc-config ${VANILLA}


and then recompile gst-plugins. That's it. Switch back to your hardened profile if you like.

Too bad that didn't work for my OOo problem...
_________________
"May the source be with you."

Laterz-
~CoolAJ86
http://CoolAJ86.Havenite.net
http://www.uvm.org/vague - LUG VT
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum