Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome: Stopping it from restoring sessions?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Fenster
Apprentice
Apprentice


Joined: 26 Oct 2004
Posts: 172
Location: Purgatory

PostPosted: Fri Apr 15, 2005 8:54 pm    Post subject: Gnome: Stopping it from restoring sessions? Reply with quote

I unchecked auto_save_session under apps-> gnome-session-> options through the GConf Editor. However, it still insists on resoring sessions. What other steps can I take to stop it doing this?
Back to top
View user's profile Send private message
idl
Retired Dev
Retired Dev


Joined: 24 Dec 2002
Posts: 1728
Location: Nottingham, UK

PostPosted: Fri Apr 15, 2005 9:02 pm    Post subject: Reply with quote

Is it just applications that continue to load? If so, goto Applications -> Desktop Preferences -> Avanced -> Sessions, then check the Starup Programs tab.
_________________
a.k.a port001
Found a bug? Please report it: Gentoo Bugzilla
Back to top
View user's profile Send private message
Fenster
Apprentice
Apprentice


Joined: 26 Oct 2004
Posts: 172
Location: Purgatory

PostPosted: Fri Apr 15, 2005 9:14 pm    Post subject: Reply with quote

I checked that, I've gaim added, but nothing else. When I log into gnome (via gdm), it loads gaim, the rox windows I had open, the gconf editor and my /home folder in nautilus. Its annoyance, having to close them all everytime.
Back to top
View user's profile Send private message
RuiP
l33t
l33t


Joined: 15 Jan 2005
Posts: 643

PostPosted: Fri Apr 15, 2005 9:22 pm    Post subject: Reply with quote

I recently had something like that...
Gnome saved a file from one of my users after close as .gconfd/saved_state not as empty file but a HUGE file, 1,5 G!!

Every time the user started a session (with the option of NOT to restoring sessions) Gnome tryied to load that THING, hanging and make my poor system terrible slow! I have 1Gb of RAM, less then the size of file.
And even when the user close her gnome session the thing continued aliving at background, eating memory and cpu. I just deleted... and next time user login things go normally again.

It seems that gnome forget to clean that and when in a restart, the fact that this file was not 0 size make gnome restoring the session (I don't know why it was so big)
Back to top
View user's profile Send private message
Fenster
Apprentice
Apprentice


Joined: 26 Oct 2004
Posts: 172
Location: Purgatory

PostPosted: Fri Apr 15, 2005 9:42 pm    Post subject: Reply with quote

du -h showed it to be a little over 20m mb, I removed it, relogged and everything still loaded: GConf Editor, gaim (twice), gnome-terminal and rox and nautilus on my /home folder
Back to top
View user's profile Send private message
bet1m
l33t
l33t


Joined: 04 Dec 2004
Posts: 631
Location: Kosova/Prishtine

PostPosted: Fri Apr 15, 2005 9:46 pm    Post subject: Reply with quote

Preferences --> Sessions
and remove tick on automaticaly save changes to session
or tick the ask on logout then there select not to save ;)
_________________
#370559
Back to top
View user's profile Send private message
Fenster
Apprentice
Apprentice


Joined: 26 Oct 2004
Posts: 172
Location: Purgatory

PostPosted: Fri Apr 15, 2005 9:58 pm    Post subject: Reply with quote

Hrm, both are unchecked.
Back to top
View user's profile Send private message
smitten
n00b
n00b


Joined: 19 Sep 2004
Posts: 51

PostPosted: Fri Apr 15, 2005 10:03 pm    Post subject: Reply with quote

I've seen the large ~/.gconfd/saved_state thing.. I'm hacking a bit on gconf, and I think I
introduced a bug into the program, which caused it to segfault. Since gnome-session
(I think) respawns gconfd-2 when it dies, it keeps respawning in an endless loop.
I think this is probably the reason that ~/.gconfd/saved_state gets extremely
large, although I'm unsure as to what the fix is... maybe putting a time limit on how fast
programs can respawn in gnome-session?
Back to top
View user's profile Send private message
RuiP
l33t
l33t


Joined: 15 Jan 2005
Posts: 643

PostPosted: Fri Apr 15, 2005 10:14 pm    Post subject: Reply with quote

Well in my case saved_state usually goes to zero size when session closes... I suposse that din't happen for that time because something make it grow far behind the easily managed. I'm just a little woried that eventually that happen again. Hope not!
(btw, i deleted from a console not with the user login... just saying for the case it was not clear... in fact, i don't know if that matters)

@Fenster
You can always try to move your .gconf* and .gnome* files out of ~/ and then start the session. That should start a a fresh gnome configuration with the only down point that you'll lost your actual personalizations (if that fails you can move it back again).
Back to top
View user's profile Send private message
Fenster
Apprentice
Apprentice


Joined: 26 Oct 2004
Posts: 172
Location: Purgatory

PostPosted: Fri Apr 15, 2005 10:19 pm    Post subject: Reply with quote

RuiP wrote:
@Fenster
You can always try to move your .gconf* and .gnome* files out of ~/ and then start the session. That should start a a fresh gnome configuration with the only down point that you'll lost your actual personalizations (if that fails you can move it back again).


Just did that, it still spawned its usual lot. Ah well, if nothing else, it probably narrowed down things some.
Back to top
View user's profile Send private message
c0bblers
Guru
Guru


Joined: 28 Mar 2003
Posts: 403

PostPosted: Fri Apr 15, 2005 10:29 pm    Post subject: Reply with quote

Hi,

Ok try this:

- Get your gnome session into the state you want it to be in when you log in (IE close down everything you don't want to load, also you can edit the session using the Session manager in Preferences)
- In the Session Options tab in the Session Manager tick "ask on logout"
- Now logout and tick "save current setup"

When you log back in the session you saved at logout should be restored.

Cheers,
James
Back to top
View user's profile Send private message
Fenster
Apprentice
Apprentice


Joined: 26 Oct 2004
Posts: 172
Location: Purgatory

PostPosted: Fri Apr 15, 2005 10:54 pm    Post subject: Reply with quote

c0bblers wrote:
Hi,

Ok try this:

- Get your gnome session into the state you want it to be in when you log in (IE close down everything you don't want to load, also you can edit the session using the Session manager in Preferences)
- In the Session Options tab in the Session Manager tick "ask on logout"
- Now logout and tick "save current setup"

When you log back in the session you saved at logout should be restored.

Cheers,
James


Cheers, that worked. However, I don't *want* to save a session, which is my problem with Gnome. If I want to load something when I log in, I will. If I save a blank session and then stop saving, it will load all that crap again. Ah well, I guess I'll stick with Flux, crappy fonts or not.
Back to top
View user's profile Send private message
c0bblers
Guru
Guru


Joined: 28 Mar 2003
Posts: 403

PostPosted: Fri Apr 15, 2005 11:02 pm    Post subject: Reply with quote

Fenster wrote:
c0bblers wrote:
Hi,

Ok try this:

- Get your gnome session into the state you want it to be in when you log in (IE close down everything you don't want to load, also you can edit the session using the Session manager in Preferences)
- In the Session Options tab in the Session Manager tick "ask on logout"
- Now logout and tick "save current setup"

When you log back in the session you saved at logout should be restored.

Cheers,
James


Cheers, that worked. However, I don't *want* to save a session, which is my problem with Gnome. If I want to load something when I log in, I will. If I save a blank session and then stop saving, it will load all that crap again. Ah well, I guess I'll stick with Flux, crappy fonts or not.


If you dont tick save session on the logout dialog you'll load the session you saved last.

Cheers,
James
Back to top
View user's profile Send private message
Fenster
Apprentice
Apprentice


Joined: 26 Oct 2004
Posts: 172
Location: Purgatory

PostPosted: Fri Apr 15, 2005 11:03 pm    Post subject: Reply with quote

c0bblers wrote:
Fenster wrote:
c0bblers wrote:
Hi,

Ok try this:

- Get your gnome session into the state you want it to be in when you log in (IE close down everything you don't want to load, also you can edit the session using the Session manager in Preferences)
- In the Session Options tab in the Session Manager tick "ask on logout"
- Now logout and tick "save current setup"

When you log back in the session you saved at logout should be restored.

Cheers,
James


Cheers, that worked. However, I don't *want* to save a session, which is my problem with Gnome. If I want to load something when I log in, I will. If I save a blank session and then stop saving, it will load all that crap again. Ah well, I guess I'll stick with Flux, crappy fonts or not.


If you dont tick save session on the logout dialog you'll load the session you saved last.

Cheers,
James


No, its loading the last session and what it was loading anyways. :(
Back to top
View user's profile Send private message
RuiP
l33t
l33t


Joined: 15 Jan 2005
Posts: 643

PostPosted: Fri Apr 15, 2005 11:06 pm    Post subject: Reply with quote

Now that works you can turn "save current setup" off (untick on exit). :)

Fenster wrote:
.... Ah well, I guess I'll stick with Flux, crappy fonts or not.


May i suggest you try Xfce4. It's great in all aspects, lighter then gnome and config files are just files that can be edit normally, not deephidden stuff or registry type of things like gconf
Back to top
View user's profile Send private message
Fenster
Apprentice
Apprentice


Joined: 26 Oct 2004
Posts: 172
Location: Purgatory

PostPosted: Fri Apr 15, 2005 11:16 pm    Post subject: Reply with quote

RuiP wrote:
Now that works you can turn "save current setup" off (untick on exit). :)

Fenster wrote:
.... Ah well, I guess I'll stick with Flux, crappy fonts or not.


May i suggest you try Xfce4. It's great in all aspects, lighter then gnome and config files are just files that can be edit normally, not deephidden stuff or registry type of things like gconf


Emerging it now. I-love-Flux, but the crappy fonts on Gentoo have put me off using it on my laptop.
Back to top
View user's profile Send private message
RuiP
l33t
l33t


Joined: 15 Jan 2005
Posts: 643

PostPosted: Fri Apr 15, 2005 11:30 pm    Post subject: Reply with quote

Hope you like it.

Mean while you can try another thing with gnome (a little extreme, but...). You can delete you from the list of users, move your ~/ to some temporary location and create your account again as a new user. That will start a fresh gnome configuration and if need you can get your personal files from your removed home.

Good luck.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum