Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cannot compute sizeof char
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
theoakwise
n00b
n00b


Joined: 15 May 2004
Posts: 37

PostPosted: Sun Mar 20, 2005 6:12 pm    Post subject: cannot compute sizeof char Reply with quote

while emerging mysql-4.0.24, I get this error:
Code:

checking size of char... configure: error: cannot compute sizeof (char), 77
See `config.log' for more details.


config.log:
Code:

configure:27349: checking size of char
configure:27668: i686-pc-linux-gnu-gcc -o conftest -O3 -DDBUG_OFF -Os -march=athlon-xp -fomit-frame-pointer -pipe -mmmx -m3dnow -msse -DHAVE_ERRNO_AS_DEFINE=1 -DUSE_OLD_FUNCTIONS     -rdynamic conftest.c -lpthread -lz -lcrypt -lnsl -lm  -lpthread >&5
/lib/libpthread.so.0: undefined reference to `errno@GLIBC_PRIVATE'
/lib/libpthread.so.0: undefined reference to `__libc_dl_error_tsd@GLIBC_PRIVATE'
/lib/libpthread.so.0: undefined reference to `__resp@GLIBC_PRIVATE'
/lib/libpthread.so.0: undefined reference to `h_errno@GLIBC_PRIVATE'
collect2: ld returned 1 exit status


The libpthread errors occur 5-6 times in the log; I'm assuming that I have a problem with the library. I'm recompiling glibc now. See below for output of emerge --info.


Not sure if it's related, but I'm getting a lot of "aclocal" errors; stuff about "underquoted definition of..." several macro-looking things: i.e.,
Code:

/usr/share/aclocal/glib.m4:8: warning: underquoted definition of AM_PATH_GLIB
/usr/share/aclocal/gdk-pixbuf.m4:12: warning: underquoted definition of AM_PATH_GDK_PIXBUF
/usr/share/aclocal/gconf-1.m4:4: warning: underquoted definition of AM_PATH_GCONF
/usr/share/aclocal/gconf-1.m4:71: warning: underquoted definition of AM_GCONF_SOURCE
/usr/share/aclocal/g-wrap.m4:7: warning: underquoted definition of AC_GWRAP_CHECK_GUILE
/usr/share/aclocal/g-wrap.m4:23: warning: underquoted definition of AM_PATH_GWRAP
/usr/share/aclocal/audiofile.m4:12: warning: underquoted definition of AM_PATH_AUDIOFILE
/usr/share/aclocal/ao.m4:9: warning: underquoted definition of XIPH_PATH_AO
/usr/share/aclocal/ORBit.m4:4: warning: underquoted definition of AM_PATH_ORBIT


And much more. I've recompiled autoconf, libtool and m4, they're all up to date.

emerge --sync:

Code:
Portage 2.0.51.19 (default-linux/x86/2004.2, gcc-3.3.5, glibc-2.3.4.20041102-r1, 2.6.10-gentoo-r6 i686)
=================================================================
System uname: 2.6.10-gentoo-r6 i686 AMD Athlon(tm) XP 3200+
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.4-r1 [2.3.4 (#1, Feb 14 2005, 00:45:36)]
distcc 2.16 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [disabled]
dev-lang/python:     2.3.4-r1
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.4
sys-devel/binutils:  2.15.92.0.2-r1
sys-devel/libtool:   1.5.10-r4
virtual/os-headers:  2.6.8.1-r1, 2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-Os -march=athlon-xp -fomit-frame-pointer -pipe -mmmx -m3dnow -msse"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /usr/share/texmf                           /dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/                            /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-Os -march=athlon-xp -fomit-frame-pointer -pipe -mmmx -m3dnow -msse"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig distlocks sandbox sfperms"
GENTOO_MIRRORS="ftp://gentoo.mirrors.pair.com/ ftp://212.219.56.152/sites/www.ibiblio.org/gentoo/ ftp://mirror.nutsmaas.                           nl/gentoo/ http://212.219.56.131/sites/www.ibiblio.org/gentoo/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror                           /"
LANG="en_US"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 3dnow 3dnowex X acpi alsa apm avi berkdb bitmap-fonts bonobo cddb cdparanoia cdr crypt cups curl dvd emboss enc                           ode esd fam flac font-server foomaticdb fortran gdbm gif gimpprint gphoto2 gpm gtk gtk2 gtkhtml guile imagemagick imap i                           mlib java jpeg libg++ libwww mad maildir mikmod mmx mmx2 motif mp3 mpeg mysql ncurses nls odbc oggvorbis opengl oss pam                            pdflib perl png povray ppds python quicktime readline samba sdl slang spell sse ssl svga tcltk tcpd tetex tiff truetype                            truetype-fonts type1-fonts usb xml xml2 xprint xv zlib"
Unset:  ASFLAGS, CBUILD, CTARGET, LC_ALL, LDFLAGS


Any help would be appreciated, thanks in advance; if there's other diagnostic output that would help, let me know.
Back to top
View user's profile Send private message
OPelerin
Guru
Guru


Joined: 17 Jul 2004
Posts: 334
Location: Belgium

PostPosted: Sun Mar 20, 2005 8:21 pm    Post subject: Reply with quote

I've something similar I get this odd error message

Quote:
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking for off_t... yes
checking for struct stat.st_rdev... yes
checking whether time.h and sys/time.h may both be included... yes
checking whether struct tm is in sys/time.h or time.h... time.h
checking for char... yes
checking size of char... configure: error: cannot compute sizeof (char), 77
See `config.log' for more details.

!!! Please attach the config.log to your bug report:
!!! /var/tmp/portage/mysql-4.0.24/work/mysql-4.0.24/config.log

!!! ERROR: dev-db/mysql-4.0.24 failed.
!!! Function econf, Line 485, Exitcode 0
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.


the config log message show this

Quote:
root@PC-lin01 opelerin # tail -f /var/tmp/portage/mysql-4.0.24/work/mysql-4.0.24/config.log
#define SYSTEM_TYPE "pc-linux-gnu"
#define TIME_WITH_SYS_TIME 1
#define USE_RAID 1
#define VERSION "4.0.24"
#define _FILE_OFFSET_BITS 64
#endif
#ifdef __cplusplus
extern "C" void std::exit (int) throw (); using std::exit;

configure: exit 1


My emerge info look like this:


Quote:
root@PC-lin01 opelerin # emerge --info
Portage 2.0.51.19 (default-linux/x86/2004.3, gcc-3.3.5, glibc-2.3.4.20040808-r1,glibc-2.3.4.20041102-r1, 2.6.10-gentoo-r6 i686)
=================================================================
System uname: 2.6.10-gentoo-r6 i686 Intel(R) Pentium(R) 4 CPU 3.00GHz
Gentoo Base System version 1.4.16
Python: dev-lang/python-2.3.4-r1 [2.3.4 (#1, Feb 7 2005, 22:03:05)]
dev-lang/python: 2.3.4-r1
sys-devel/autoconf: 2.13, 2.59-r6
sys-devel/automake: 1.5, 1.7.9-r1, 1.6.3, 1.4_p6, 1.9.4, 1.8.5-r3
sys-devel/binutils: 2.15.92.0.2-r1
sys-devel/libtool: 1.5.10-r4
virtual/os-headers: 2.6.8.1-r1, 2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -march=pentium4 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=pentium4 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ ftp:///ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://gentoo.tiscali.nl/gentoo/ ftp://mirrors.sec.informatik.tu-darmstadt.de/gentoo/ http://ftp.gentoo.skynet.be/pub/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="x86 X alsa apache2 apm arts avi berkdb bitmap-fonts cdr crypt cups curl dvd emboss encode esd fam flash font-server foomaticdb fortran gdbm gif gnome gpm gstreamer gtk gtk2 guile imlib ipv6 jack java jpeg kde libg++ libwww mad mikmod motif mozilla mp3 mpeg mysql ncurses nls nptl oggvorbis opengl oss pam pdflib perl php png ppds python qt quicktime readline sdl slang snmp spell sse ssl svga tcpd tiff truetype truetype-fonts type1-fonts usb xml xml2 xmms xv zlib"
Unset: ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, PORTDIR_OVERLAY







Anybody know why I get this error message?
_________________
Olivier PELERIN
Back to top
View user's profile Send private message
theoakwise
n00b
n00b


Joined: 15 May 2004
Posts: 37

PostPosted: Sun Mar 20, 2005 8:33 pm    Post subject: Reply with quote

I notice that you've got ntpl going; so did I. I'm recompiling without, I'll see if that helps. Shot in the dark.
Back to top
View user's profile Send private message
NightMonkey
Guru
Guru


Joined: 21 Mar 2003
Posts: 312
Location: Brisbane, CA

PostPosted: Sun Mar 20, 2005 10:17 pm    Post subject: Reply with quote

Same error here, on only one of my machines. Here's the buzilla entry I created.
Back to top
View user's profile Send private message
Rainmaker
Veteran
Veteran


Joined: 12 Feb 2004
Posts: 1650
Location: /home/NL/ehv/

PostPosted: Mon Mar 21, 2005 1:34 am    Post subject: Reply with quote

does

revdep-rebuild --soname libpthread.so.0

do anything?
_________________
If you can't dazzle them with brilliance, baffle them with bullshit.
Back to top
View user's profile Send private message
theoakwise
n00b
n00b


Joined: 15 May 2004
Posts: 37

PostPosted: Mon Mar 21, 2005 11:59 pm    Post subject: Reply with quote

Quote:
revdep-rebuild --soname libpthread.so.0


Tried it, no difference. Incidentally (perhaps you all knew this) DON'T just recompile glibc w/o ntpl....things were very broken for a while. :oops:
Back to top
View user's profile Send private message
NightMonkey
Guru
Guru


Joined: 21 Mar 2003
Posts: 312
Location: Brisbane, CA

PostPosted: Tue Mar 22, 2005 12:16 am    Post subject: Reply with quote

theoakwise wrote:
Quote:
revdep-rebuild --soname libpthread.so.0


Tried it, no difference. Incidentally (perhaps you all knew this) DON'T just recompile glibc w/o ntpl....things were very broken for a while. :oops:


And I keep both LinuxThreads and pthreads (i.e. ntpl set, but ntplonly not set), just in case.
Back to top
View user's profile Send private message
theoakwise
n00b
n00b


Joined: 15 May 2004
Posts: 37

PostPosted: Tue Mar 22, 2005 9:02 pm    Post subject: cflags? Reply with quote

Here's my next idea: I see that OPelerin has -O3 set, and I have -Os. I took a gander at the ebuild for glibc, and it seems that it doesn't do any CFLAG filtering. So my next idea is to try overriding the optimization flags on the compile of glibc, and see if that doesn't solve the problem. I'm away from my system now, but I'll try tonight and post an edit.

Seems odd, however, I would think that optimizations would break the library for lots of packages, not just mysql.

[EDIT]
:oops: Oops. Okay, so the ebuild does strip ALL flags. Mea culpa.


Last edited by theoakwise on Wed Mar 23, 2005 12:40 am; edited 1 time in total
Back to top
View user's profile Send private message
theoakwise
n00b
n00b


Joined: 15 May 2004
Posts: 37

PostPosted: Tue Mar 22, 2005 11:18 pm    Post subject: nm resuilts Reply with quote

Found this:
Code:

ryan@loki ryan# nm /lib/libpthread.so.0 | grep -E "errno|libc_dl_error|resp" | grep "GLIBC_PRIVATE"
         U errno@@GLIBC_PRIVATE
         U h_errno@@GLIBC_PRIVATE
         U __libc_dl_error_tsd@@GLIBC_PRIVATE
         U __resp@@GLIBC_PRIVATE


But the errors are looking for:
Code:

/lib/libpthread.so.0: undefined reference to `errno@GLIBC_PRIVATE'
/lib/libpthread.so.0: undefined reference to `__libc_dl_error_tsd@GLIBC_PRIVATE'
/lib/libpthread.so.0: undefined reference to `__resp@GLIBC_PRIVATE'
/lib/libpthread.so.0: undefined reference to `h_errno@GLIBC_PRIVATE'


(note single '@') -> is there a problem with the multpile @ signs? When I did some work in Java linking to a C library that I compiled, I know I had to strip out the @ signs when compiling the library. Is this similar?

[EDIT]
posted this info to bugzilla
Back to top
View user's profile Send private message
theoakwise
n00b
n00b


Joined: 15 May 2004
Posts: 37

PostPosted: Thu Mar 24, 2005 12:58 am    Post subject: Reply with quote

Just finished a recompile of gcc and then glibc, seemed to make the problem go away. :?: :!:
Back to top
View user's profile Send private message
OPelerin
Guru
Guru


Joined: 17 Jul 2004
Posts: 334
Location: Belgium

PostPosted: Thu Mar 24, 2005 10:01 pm    Post subject: Reply with quote

8O I've tried as well. No success same error message. :(
_________________
Olivier PELERIN
Back to top
View user's profile Send private message
liuspider
Apprentice
Apprentice


Joined: 03 Feb 2003
Posts: 237

PostPosted: Thu Mar 24, 2005 10:35 pm    Post subject: Reply with quote

no error here, with "nptl nptlonly"

however, I can not start acroread :(
_________________
BLOG: http://liucougar.scim-im.org
Back to top
View user's profile Send private message
OPelerin
Guru
Guru


Joined: 17 Jul 2004
Posts: 334
Location: Belgium

PostPosted: Thu Mar 31, 2005 7:21 pm    Post subject: Reply with quote

I confirm

the error is gone after recompiling glib 2.3.4.20050125-r1 with +nptl +nptlonly. :lol:


it seems the glib compiled with nptl and linuxthreads is corrupted
_________________
Olivier PELERIN
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum