Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GTK-Applications with MacOSX
View unanswered posts
View posts from last 24 hours

 
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo for Mac OS X (Portage for Mac OS X)
View previous topic :: View next topic  
Author Message
Maintenant
n00b
n00b


Joined: 18 Jan 2005
Posts: 30

PostPosted: Wed Feb 09, 2005 10:42 pm    Post subject: GTK-Applications with MacOSX Reply with quote

I've finally managed to compile my favourite GTK application GQView under MacOSX. This is, how I did it:

emerge pkgconfig
emerge libtiff
emerge jpeg
emerge libpng
emerge fontconfig
emerge freetype
ACCEPT_KEYWORDS="~ppc-macos" emerge glib
ACCEPT_KEYWORDS="~ppc-macos" emerge atk
Unfortunately, ACCEPT_KEYWORDS="~ppc-macos" emerge pango failed to compile. So, do this instead:
export PKG_CONFIG_PATH=/usr/X11R6/pkgconfig
download pango1.4.1, unpack it, run ./configure make make install
export PKG_CONFIG_PATH=/usr/X11R6/pkgconfig:/usr/local/lib/pkgconfig
download gtk+-2.4.9 from www.gtk.org, unpack it, run ./configure make make install

Now, you have a working gtk+.2.4.9 in /usr/local

In order to install GTK applications, remember to set your PKG_CONFIG_PATH to /usr/local/lib/pkgconfig, download the application of your choice, run ./configure, make and make install. For me, it worked with gqview. In future, I wanna try to compile rox and scite.
Back to top
View user's profile Send private message
Marculin
Guru
Guru


Joined: 24 Feb 2004
Posts: 376

PostPosted: Sat Feb 12, 2005 12:23 pm    Post subject: Reply with quote

You have compiled gaim 1.1.2 and xchat 2.4.1?
_________________
Non capisco perchè continuavo ad avere cosi paura della shell.....è cosi bella :)
Back to top
View user's profile Send private message
Maintenant
n00b
n00b


Joined: 18 Jan 2005
Posts: 30

PostPosted: Sat Feb 12, 2005 10:27 pm    Post subject: Reply with quote

No, I haven't sorry. I don't really have an interest in those programs. But I successfully compiled gqview, scite and rox. Check what happens, if you do ACCEPT_KEYWORDS="ppc" emerge -p gaim . If gtk+ is the last dependency before gaim, it should be possible to compile gaim, too.
Right now, I don't have my iBook with me. But if you like, I can try to compile these programs within in the next few days and post my results here.
Back to top
View user's profile Send private message
Maintenant
n00b
n00b


Joined: 18 Jan 2005
Posts: 30

PostPosted: Mon Feb 14, 2005 10:37 am    Post subject: Reply with quote

I tried to compile gaim and xchat. Unfortunately, xchat had problems with some X11 libraries. But gaim compiled beautifully and works!
Back to top
View user's profile Send private message
Marculin
Guru
Guru


Joined: 24 Feb 2004
Posts: 376

PostPosted: Mon Feb 14, 2005 12:30 pm    Post subject: Reply with quote

oh...very good :)
It's possible make a ebuild fofr gaim and gqview and insert in portage?
gtk2 not emerge automatically and simple ;)
thank you
_________________
Non capisco perchè continuavo ad avere cosi paura della shell.....è cosi bella :)
Back to top
View user's profile Send private message
Maintenant
n00b
n00b


Joined: 18 Jan 2005
Posts: 30

PostPosted: Mon Feb 14, 2005 1:22 pm    Post subject: Reply with quote

It's probably possible. But to tell you the truth, I don't know how. I am not a Gentoo developer. At the moment, I'm rather busy with final exams. Once I have some more time, I will study ebuilds and stuff. it wouldn't be a bad thing, if somebody could repair the pango ebuild first. If that is done, it shouldn't be a problem to make ebuild for gtk, gqview and gaim. Does anybody know, who is in charge of Portage for MacOSX development?
Back to top
View user's profile Send private message
sapo_selo
n00b
n00b


Joined: 06 Feb 2005
Posts: 26
Location: Portugal

PostPosted: Mon Feb 14, 2005 8:48 pm    Post subject: Reply with quote

maybe if u ask in #gentoo-osx @ irc.freenode.org maybe somebody knows there
Back to top
View user's profile Send private message
Marculin
Guru
Guru


Joined: 24 Feb 2004
Posts: 376

PostPosted: Tue Feb 15, 2005 1:06 pm    Post subject: Reply with quote

thank...I ask in chan
@Maintenant:great ;)
_________________
Non capisco perchè continuavo ad avere cosi paura della shell.....è cosi bella :)
Back to top
View user's profile Send private message
Maintenant
n00b
n00b


Joined: 18 Jan 2005
Posts: 30

PostPosted: Thu Feb 17, 2005 1:27 pm    Post subject: Reply with quote

I've tried to repair the pango ebuild. But unfortunately, I didn't succeed. I always get a libtool error even when I exclude the gentoo libtool patches from the ebuild. Has anybody managed to emerge pango successfully? Without pango, it won't be possible to install gtk+.
Back to top
View user's profile Send private message
zojas
Veteran
Veteran


Joined: 22 Apr 2002
Posts: 1138
Location: Phoenix, AZ

PostPosted: Tue May 31, 2005 12:57 am    Post subject: Reply with quote

that doesn't count! :)

anyway, I'm stuck on pango now too. bug #63189 has the same problem in it that I do.
_________________
http://www.desertsol.com/~kevin/ppc
Back to top
View user's profile Send private message
zojas
Veteran
Veteran


Joined: 22 Apr 2002
Posts: 1138
Location: Phoenix, AZ

PostPosted: Tue May 31, 2005 2:34 pm    Post subject: Reply with quote

update: pango-1.4.1-r1 emerged fine for me. now I can't get gtk+ to find the pango library (even though it exists)
_________________
http://www.desertsol.com/~kevin/ppc
Back to top
View user's profile Send private message
Maintenant
n00b
n00b


Joined: 18 Jan 2005
Posts: 30

PostPosted: Fri Jun 03, 2005 8:11 am    Post subject: Reply with quote

That's great news! Have you performed any rituals to make it work or have you simply emerged it? I haven't tried emerging pango for quite some time now. But now I'm very anxious to do so. Now, I'm running Tiger on my machine, maybe that makes things easier....
Back to top
View user's profile Send private message
zojas
Veteran
Veteran


Joined: 22 Apr 2002
Posts: 1138
Location: Phoenix, AZ

PostPosted: Fri Jun 03, 2005 2:10 pm    Post subject: Reply with quote

I'm running on tiger too.

most of the ebuilds needed some work. after getting the dependencies emerged, pango emerged. this thread has links to all the bugs with info about how to get various dependencies to build:

http://forums.gentoo.org/viewtopic-t-343234.html

the most contentious is the one for XML Parser perl module. I used the perl module eclass which the perl herd people disapprove of. (it works great though).

another key is to add both 'macos' and 'ppc-macos' to your USE flags.

also, I've needed to use gcc 3.3. you can use the 'gcc_select' program in tiger to switch your system to use gcc 3.3.

and finally, pango emerged, but the shared libraries didn't have the .dylib filemame extension, so the configure script for gtk+ couldn't find them. some symbolic links fixed that.

now if only I could get gtk+ to build... anyway I've posted the last error I'm getting, and I also filed a bug for it. when I started out it looked hopeless, now it's almost there!
_________________
http://www.desertsol.com/~kevin/ppc
Back to top
View user's profile Send private message
zojas
Veteran
Veteran


Joined: 22 Apr 2002
Posts: 1138
Location: Phoenix, AZ

PostPosted: Fri Jun 03, 2005 2:18 pm    Post subject: Reply with quote

here's a list of all the packages I currently have emerged on my system.

I almost forgot; I had to emerge automake 1.7.9-r1 since gtk+ uses features from that version. I also had to export some environment variables so it would use the newer automake. I still need to file a bug for automake.

Code:

export WANT_AUTOMAKE_1_7=1 && export WANT_AUTOMAKE=1.7


the list:
Code:

/gnupg-1.4.1
/gentoolkit-0.2.0
/gentoolkit-dev-0.2.4
/tetex-2.0.2-r5
/atk-1.8.0-r1
/expat-1.95.8
/glib-2.4.8
/XML-Parser-2.34
/python-fchksum-1.7.1
/dialog-1.0.20050206
/intltool-0.31.2
/pkgconfig-0.15.0
/tla-1.3.2
/jpeg-6b-r4
/libpng-1.2.8
/tiff-3.7.1-r1
/libwww-5.4.0-r3
/wget-1.9.1-r3
/debianutils-2.13.1-r1
/portage-2.0.51.19
/sed-4.0.9
/automake-1.7.9-r1
/gettext-0.14.1-r1
/gnuconfig-20050324
/libsystem-7.1
/pango-1.4.1-r1
/shared-mime-info-0.14-r2

_________________
http://www.desertsol.com/~kevin/ppc
Back to top
View user's profile Send private message
Maintenant
n00b
n00b


Joined: 18 Jan 2005
Posts: 30

PostPosted: Mon Jun 06, 2005 3:08 pm    Post subject: Reply with quote

Looks like you did a great jobbing making Darwin-portage emerge automake.
How did you do that? Although all automake ebuilds have the "~ppc-macos" flag, portage refuses to emerge it.
Now, this is what I did so far:
Using gcc-4.0 (!), I emerged

1) gettext, pkgconfig, jpeg, libtiff, libpng (all stable)
2) glib, pango, atk (all testing)
The tricky part was XML-Parser. But all you need is a littel hack:

ln -s /System/Library/Perl /usr/lib/perl5

That should be sufficient to run "emerge shared-mime-libs" successfully.
Now, I've reached the point of getting gtk+ to compile because of automake.
Back to top
View user's profile Send private message
zojas
Veteran
Veteran


Joined: 22 Apr 2002
Posts: 1138
Location: Phoenix, AZ

PostPosted: Mon Jun 06, 2005 5:29 pm    Post subject: Reply with quote

It's masked out somehow, and I couldn't figure how to unmask it. so I went to the directory where the automake ebuild file was, and used ebuild:

Code:

cd /usr/portage/sys-devel/automake
ebuild ./automake-1.7.9-r1.ebuild fetch unpack compile install qmerge

_________________
http://www.desertsol.com/~kevin/ppc
Back to top
View user's profile Send private message
Maintenant
n00b
n00b


Joined: 18 Jan 2005
Posts: 30

PostPosted: Tue Jun 07, 2005 5:51 pm    Post subject: Reply with quote

I think it worked!
I emerged automake as your wrote me and added symbolic links for pango-dylibs.
Unfortunately, setting environment variables for automake-1.7.9 didn't work for me, so I created a symbolic link from automake to automake-1.7. Then, I emerged gtk+ by path like

Code:
emerge /usr/portage/x11-libs/gtk+/gtk+-2.4.14.ebuild


And now, it seems to have been successfully emerged. I haven't to emerge any gtk-depending applications yet. But, I'm going to try with scite soon. As it appears, I will have to make symbolic links for the gtk+-dylibs, too! But that shouldn't be a problem...
Wish me luck! And thanks for your input![/code]
Back to top
View user's profile Send private message
zojas
Veteran
Veteran


Joined: 22 Apr 2002
Posts: 1138
Location: Phoenix, AZ

PostPosted: Thu Jun 16, 2005 6:22 pm    Post subject: Reply with quote

that's odd, I'm getting basically the same error from 2.4.14 I got from 2.4.9-r1. a missing symbol from libJPEG:

Code:

/usr/bin/ld: warning multiple definitions of symbol _locale_charset
/usr/lib/gcc/powerpc-apple-darwin8/4.0.0/../../..//libiconv.dylib(localcharset.o) definition of _locale_charset
/usr/lib/gcc/powerpc-apple-darwin8/4.0.0/../../..//libintl.dylib(localcharset.o) definition of _locale_charset
creating im-viqr.la
(cd .libs && rm -f im-viqr.la && ln -s ../im-viqr.la im-viqr.la)
../../gtk/gtk-query-immodules-2.0 im-xim.la  im-am-et.la im-cedilla.la im-cyrillic-translit.la im-inuktitut.la im-ipa.la im-thai-broken.la im-ti-er.la im-ti-et.la im-viqr.la > gtk.immodules
dyld: Symbol not found: __cg_jpeg_resync_to_restart
  Referenced from: /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/ImageIO
  Expected in: /usr/lib/libJPEG.dylib

make[3]: *** [gtk.immodules] Error 133
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

!!! ERROR: x11-libs/gtk+-2.4.14 failed.

_________________
http://www.desertsol.com/~kevin/ppc
Back to top
View user's profile Send private message
Maintenant
n00b
n00b


Joined: 18 Jan 2005
Posts: 30

PostPosted: Sat Jun 18, 2005 9:46 am    Post subject: Reply with quote

That's really odd... Maybe it's because I didn't set the jpeg flag, I don't know.
The really odd thing is that I successfully manage to emerge gtk+, but gtk+-based applications just like scite or gqview don't recognize it!
As for now, I have stopped dealing with gtk+ under OSX. At the moment I have to worry about things that are far more important than that. But please keep me posted. This is a most fascinating thread!
Back to top
View user's profile Send private message
strogg
n00b
n00b


Joined: 19 Oct 2004
Posts: 10

PostPosted: Wed Aug 24, 2005 3:06 am    Post subject: Reply with quote

Can anyone tell me what symbolic links i should create to make the gtk+-2.4.9 compile realize that the pango libs are really there? i'm kinda stuck at that one point. thanks.
Back to top
View user's profile Send private message
zojas
Veteran
Veteran


Joined: 22 Apr 2002
Posts: 1138
Location: Phoenix, AZ

PostPosted: Wed Aug 24, 2005 3:29 am    Post subject: Reply with quote

Code:

quasar:~ root# cd /usr/lib
quasar:/usr/lib root# ls -lF|grep pango|grep dylib
lrwxr-xr-x    1 root   wheel          14 May 31 08:00 libpango-1.0.0.dylib@ -> libpango-1.0.0
lrwxr-xr-x    1 root   wheel          12 May 31 07:59 libpango-1.0.dylib@ -> libpango-1.0
lrwxr-xr-x    1 root   wheel          17 May 31 08:00 libpangoft2-1.0.0.dylib@ -> libpangoft2-1.0.0
lrwxr-xr-x    1 root   wheel          15 May 31 08:01 libpangoft2-1.0.dylib@ -> libpangoft2-1.0
lrwxr-xr-x    1 root   wheel          15 May 31 08:02 libpangox-1.0.0.dylib@ -> libpangox-1.0.0
lrwxr-xr-x    1 root   wheel          13 May 31 08:01 libpangox-1.0.dylib@ -> libpangox-1.0
lrwxr-xr-x    1 root   wheel          17 May 31 08:02 libpangoxft-1.0.0.dylib@ -> libpangoxft-1.0.0
lrwxr-xr-x    1 root   wheel          15 May 31 08:02 libpangoxft-1.0.dylib@ -> libpangoxft-1.0


the ebuild installed the files as libpango-1.0.0, etc. the 'file' command told me that they were indeed shared libraries:

Code:

quasar:/usr/lib root# file libpango-1.0.0
libpango-1.0.0: symbolic link to `libpango-1.0.0.400.1'
quasar:/usr/lib root# file libpango-1.0.0.400.1
libpango-1.0.0.400.1: Mach-O dynamically linked shared library ppc

_________________
http://www.desertsol.com/~kevin/ppc
Back to top
View user's profile Send private message
strogg
n00b
n00b


Joined: 19 Oct 2004
Posts: 10

PostPosted: Wed Aug 24, 2005 10:03 am    Post subject: Reply with quote

thanks! so far so good... it's compiling now, and it isn't seeming to let up!
Back to top
View user's profile Send private message
strogg
n00b
n00b


Joined: 19 Oct 2004
Posts: 10

PostPosted: Wed Aug 24, 2005 10:52 pm    Post subject: Reply with quote

just to let all three people who care know, i got it working! the only differences between my approach and others is the following:

--emerged automake with all dependencies using emerge /usr/portage/sys-devel/automake-whatever/blah.ebuild approach unless there is a cyclical dependency, then i emerged the wrapper first using the ebuild blah.ebuild fetch unpack compile install qmerge approach.
--i emerged EVERYTHING including gtk+ 2.4 (which i had to download the ebuild/digest/patches for since 2.4 has been removed from portage).
--i wasn't afraid to use FEATURES="-collision-protect", although i feel lucky it didn't fubar anything in the mac os base.

but i haven't tested if gtk really works or not. 2.4 is a really old, deprecated version of gtk. my goal is to get 2.6 working right now so i can run most applications out there. i'll deal with 2.8 when i have time. so far, i'm stuck at the new pango emerge. i'll post my results for people later on if anyone's interested.
Back to top
View user's profile Send private message
BennyP
Guru
Guru


Joined: 09 May 2003
Posts: 497
Location: Toronto, Canada

PostPosted: Thu Nov 24, 2005 2:09 pm    Post subject: Reply with quote

I'm keen on getting gtk working on my ibook... any progress since august?
_________________
Could it be?
Back to top
View user's profile Send private message
betaphi1319
n00b
n00b


Joined: 29 Apr 2002
Posts: 25
Location: Denver, CO, US

PostPosted: Mon Nov 28, 2005 7:26 pm    Post subject: Reply with quote

I posted a note to bug 109964 regarding Pango 1.10.1, but I'm still stuck also...
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo for Mac OS X (Portage for Mac OS X) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum