Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
关于emacs的若干问题
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index 中文 (Chinese)
View previous topic :: View next topic  
Author Message
bigmonk
n00b
n00b


Joined: 16 Nov 2004
Posts: 44
Location: china

PostPosted: Sat Jan 15, 2005 8:49 am    Post subject: 关于emacs的若干问题 Reply with quote

1、记得原来emacs可以在concole下用的,在gentoo下怎么不行了,必须要有X?是编译参数的问题吗?如何解决呀?
2、本来以为/var/tmp/portage里的东西没用的,结果删了之后emacs运行不了。报告缺那里的文件。这个目录里的文件真得那么有用吗?别人软件也是这样吗?删了会有什么后果呢?
3、gbk的locale,fcitx的输入法,输入时乱码,如何解决?
_________________
http://gentoogle.blogspot.com/
Back to top
View user's profile Send private message
Hauser
l33t
l33t


Joined: 27 Dec 2003
Posts: 650
Location: 4-dimensional hyperplane

PostPosted: Sat Jan 15, 2005 9:20 am    Post subject: Reply with quote

1. I don't use emacs, but I hope this thread will be helpful to you:
http://forums.gentoo.org/viewtopic.php?t=275757&highlight=emacs
2. /var/tmp/portage is deletable, I've done many system backup/restore practices without including this directory, never had any problems. But again, I don't use emacs, so can't comment on that.
3. Would you give more info on this? Exactly what locale variables have you exported? Under what circumstances fcitx gives you unrecognizable fonts?
_________________
AMD Athlon XP 2600+; 512M RAM;
nVidia FX5700LE; Hitachi 120Gb
2.6.9-nitro4, reiser4, linux26-headers+nptl

Do I like to compile everything?
Positive definite!
Back to top
View user's profile Send private message
bigmonk
n00b
n00b


Joined: 16 Nov 2004
Posts: 44
Location: china

PostPosted: Sat Jan 15, 2005 11:55 am    Post subject: Reply with quote

the results of locale:
LANG=zh_CN.gbk
LC_CTYPE="zh_CN.gbk"
LC_NUMERIC="zh_CN.gbk"
LC_TIME="zh_CN.gbk"
LC_COLLATE="zh_CN.gbk"
LC_MONETARY="zh_CN.gbk"
LC_MESSAGES="zh_CN.gbk"
LC_PAPER="zh_CN.gbk"
LC_NAME="zh_CN.gbk"
LC_ADDRESS="zh_CN.gbk"
LC_TELEPHONE="zh_CN.gbk"
LC_MEASUREMENT="zh_CN.gbk"
LC_IDENTIFICATION="zh_CN.gbk"
LC_ALL=

under gnome 2.8.1, I use fcitx and got unrecognizable fonts.
I heard that I could use mule-gbk to solve the problem, but I didn't find the package in gentoo.
_________________
http://gentoogle.blogspot.com/
Back to top
View user's profile Send private message
tecehux
n00b
n00b


Joined: 01 Nov 2004
Posts: 46
Location: Germany

PostPosted: Sat Jan 15, 2005 12:27 pm    Post subject: Reply with quote

use "emacs -nw"
where -nw means 'no window'
and maybe also -q, this will disable any custom setting (~/.emacs)
Back to top
View user's profile Send private message
tecehux
n00b
n00b


Joined: 01 Nov 2004
Posts: 46
Location: Germany

PostPosted: Sat Jan 15, 2005 12:33 pm    Post subject: Re: 关于emacs的若干问题 Reply with quote

bigmonk wrote:

2、本来以为/var/tmp/portage里的东西没用的,结果删了之后emacs运行不了。报告缺那里的文件。这个目录里的文件真得那么有用吗?别人软件也是这样吗?删了会有什么后果呢?


I don't have /var/tmp/portage, instead of it, I have PORTAGE_TMPDIR=/mnt/portage/tmp in make.conf, and I don't think emacs needs any file in it. maybe you run the server in emacs? which file does it need?
Back to top
View user's profile Send private message
bigmonk
n00b
n00b


Joined: 16 Nov 2004
Posts: 44
Location: china

PostPosted: Sun Jan 16, 2005 2:00 am    Post subject: Reply with quote

可能是我误解了错误提示,原来它提示找不到/var/tmp/portage/emacs.......下面的文件,但我重新emerge emacs之后,删除/var/tmp/portage/下的所有文件却无法复现这个错误。

现在只剩下乱码的问题了,我已经装了mule-gbk,但它的效果只是把原来的乱码变成了方块。我在gnome-terminal下运行emacs -nw,中文正常,但不知是不是mule-gbk的效果,因为在这之前我没这样运行过。
_________________
http://gentoogle.blogspot.com/
Back to top
View user's profile Send private message
galilette
n00b
n00b


Joined: 17 Jan 2005
Posts: 22

PostPosted: Mon Jan 17, 2005 11:48 am    Post subject: Reply with quote

bigmonk wrote:
可能是我误解了错误提示,原来它提示找不到/var/tmp/portage/emacs.......下面的文件,但我重新emerge emacs之后,删除/var/tmp/portage/下的所有文件却无法复现这个错误。

现在只剩下乱码的问题了,我已经装了mule-gbk,但它的效果只是把原来的乱码变成了方块。我在gnome-terminal下运行emacs -nw,中文正常,但不知是不是mule-gbk的效果,因为在这之前我没这样运行过。

在emacs中执行:
c-x <enter> k
然后输入chinese-iso-8bit
回车
中文输入乱码的问题就应该解决了

p.s., 不用mule-gbk
Back to top
View user's profile Send private message
bigmonk
n00b
n00b


Joined: 16 Nov 2004
Posts: 44
Location: china

PostPosted: Tue Jan 18, 2005 2:29 am    Post subject: Reply with quote

试了楼上的命令,mule-gbk用了也不行,不用也不行,还是乱码或方块。
_________________
http://gentoogle.blogspot.com/
Back to top
View user's profile Send private message
tecehux
n00b
n00b


Joined: 01 Nov 2004
Posts: 46
Location: Germany

PostPosted: Tue Jan 18, 2005 11:36 am    Post subject: Reply with quote

bigmonk wrote:
试了楼上的命令,mule-gbk用了也不行,不用也不行,还是乱码或方块。

下面的是我.emacs中的中文设置,不知道对你有没有帮助:
Code:
(defun chinese ()
  "Set the language environment to Chinese GB,
the input methode isn't finished."
  (interactive)
  (set-language-environment 'Chinese-GB)
  (set-buffer-file-coding-system 'cn-gb-2312)
  (set-keyboard-coding-system 'cn-gb-2312)
  (set-next-selection-coding-system 'cn-gb-2312)
  (set-terminal-coding-system 'cn-gb-2312)
  (setq-default enable-multibyte-characters t)
  (set-clipboard-coding-system 'cn-gb-2312)
  (prefer-coding-system 'cn-gb-2312)
  (set-selection-coding-system 'cn-gb-2312))


另外比如LC_ALL可能也会有关系,试试在运行emacs之前运行:
Code:
export LANG=zh_CN.GB2312
export LC_ALL=zh_CN.GB2312
export LC_CTYPE=zh_CN.GB2312
export LANGUAGE=zh_CN.GB2312
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index 中文 (Chinese) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum