Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Apache install....
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
ketanrp
n00b
n00b


Joined: 19 Apr 2002
Posts: 14

PostPosted: Sat Apr 20, 2002 2:41 am    Post subject: Apache install.... Reply with quote

I'm trying to install Apache (1.3.24) and PHP (4.1.2). I have been following the "Gentoo Linux Desktop onfiguration Guide" and after I emerge apache and php, I do not have a /etc/httpd directory or httpd.conf file anywhere on the disk. I've tried compiling several times now and each time I get nothing. I also have a question about PHP and qt. I have qt 3.0 installed for KDE, and when I emerge php, it tells me that it will install some 2.x verion of qt, and that will be an upgrade from the 3.0 I have. I have been using export USE="-qt" to keep it from emerging qt 2.x. Is this something I should be doing? So my question is, what am I doing wrong here?

Thanks,
ketanrp
Back to top
View user's profile Send private message
fghellar
Bodhisattva
Bodhisattva


Joined: 10 Apr 2002
Posts: 856
Location: Porto Alegre, BR

PostPosted: Sat Apr 20, 2002 2:56 am    Post subject: Reply with quote

For apache and php, try
http://forums.gentoo.org/viewtopic.php?t=55
http://forums.gentoo.org/viewtopic.php?t=72
http://forums.gentoo.org/viewtopic.php?t=139
_________________
| www.gentoo.org | www.tldp.org | www.google.com |
Back to top
View user's profile Send private message
KraGorn
n00b
n00b


Joined: 17 Apr 2002
Posts: 40
Location: Warrington, England

PostPosted: Sat Apr 20, 2002 8:59 am    Post subject: Reply with quote

Basically PHP does not install properly in spite of what emerge says! I have tried several times on here in the last 24 hours get get an answer to my problems and failed.

According to the docs you do

1) emerge apache
2) emerge php

and it all works after you run /var/tmp/pkg/php.... config, BUT IT DOESN'T, the necessary LoadModule statements aren't being added to apache.conf presumably because this script doesn't know that httpd changed to apache ... also there's no mod_php4.c on the system to use :(

Your problems are caused by the complete re-naming of various files, for httpd read apache ... ie. /etc/apache/conf/apache.conf etc ... that may make it clearer, however without a mod_php4.c you still can't get it to run.

The only way I found to get one was during the emerge process of PHP, while the source tree is expanded, grab it from there.
_________________
You'll never catch ME using a sig.!
Back to top
View user's profile Send private message
rob3rt
n00b
n00b


Joined: 18 Apr 2002
Posts: 12
Location: Prague, Czech Republic

PostPosted: Sun Apr 21, 2002 10:24 am    Post subject: how to install Reply with quote

hello everybuddy,

well i am not sysadmin nor web programer. I only want to use apache+ssl+php, so i read some articles at gentoo.org (desktop...) I folowed that steps and it did not worked for me. Then I came here a saw that there are meny changes in apache stuff. Ok, but can you give me straight instruction to have my apache working?
a) problem with emerge php (did not ./configure with nls) was solved by emerge rsync (cool)
b) apache get compiled well, but I am not sure to edit rc.conf with HTTPD_CONF="-D SSL -D PHP4" when you rename it to apache, so what to do?
c)emerge mod_ssl was succefull
c)when I start apache and do konqueror localhost I get page where I can choose from many languages (index.html.cs for example) and when I click on it there is no ssl support.
So what am I doing wrong. Do not tell me to read documentation, BECAUSE i have at least one BILLION other very important things to do right now. So time is not my luxury. It worked for me few months ago with simply :
emerge apache php

thank you very much folks
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum