Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
WebSphere Application Server
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
jfalchetto
n00b
n00b


Joined: 21 Nov 2004
Posts: 6
Location: Torino, Italy

PostPosted: Fri Dec 10, 2004 3:34 pm    Post subject: WebSphere Application Server Reply with quote

Qualcuno e' mai riuscito ad installare l'application server di WebSphere 5.x su Gentoo?

Non sembra un'installazione RPM ma un InstallShield (java).

I vari "wizard" passano fino alla fase attiva dell'installazione dove si blocca e sul log ci sono dei tentativi di modificare file non esistenti (sotto /opt/WebSphere/...)

Sigh :cry:
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 13200
Location: here

PostPosted: Fri Dec 10, 2004 3:36 pm    Post subject: Reply with quote

Ti serve qualcosa di particolare di WebSphere che eclipse non ha?
_________________
"aspetto un'emozione sempre più indefinibile"
- CCCP -
"la libertà un doveroso pericolo in verità"
- PGR -
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
jfalchetto
n00b
n00b


Joined: 21 Nov 2004
Posts: 6
Location: Torino, Italy

PostPosted: Fri Dec 10, 2004 3:41 pm    Post subject: Reply with quote

Intendo WebSphere Application Server non WebSphere Studio Application Developer (WSAD), cioe' l'application server per far girare applicazioni J2EE non l'ambiente di sviluppo.

Eclipse mi basta ed avanza :D
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 13200
Location: here

PostPosted: Fri Dec 10, 2004 3:42 pm    Post subject: Reply with quote

jfalchetto wrote:
Intendo WebSphere Application Server non WebSphere Studio Application Developer (WSAD), cioe' l'application server per far girare applicazioni J2EE non l'ambiente di sviluppo.

Ok scusa non avevo letto bene. Se lo installi ti da qualche errore?
_________________
"aspetto un'emozione sempre più indefinibile"
- CCCP -
"la libertà un doveroso pericolo in verità"
- PGR -
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
jfalchetto
n00b
n00b


Joined: 21 Nov 2004
Posts: 6
Location: Torino, Italy

PostPosted: Fri Dec 10, 2004 3:53 pm    Post subject: Reply with quote

Sul file di log dell'installazione il primo errore e':

(Dec 10, 2004 4:43:12 PM), Setup.product.install, com.installshield.wizardx.ascii.ModifyFile, err, Could not write ASCII file /opt/WebSphere/AppServer/java/jre/lib/orb.properties.

La directory esiste ma non c'e' nulla dentro escluso il file di log.

Sembra non copiare i file senza segnalare alcun errore.

Prima si lamenta perche Gentoo non e' uno dei suoi "linux"... cioe' non e' supportato. Visto che MQSeries funziona ho provato con WAS ma non sto' avendo lo stesso successo.
Back to top
View user's profile Send private message
Kind_of_blue
Guru
Guru


Joined: 10 Oct 2004
Posts: 485

PostPosted: Fri Dec 10, 2004 5:02 pm    Post subject: Reply with quote

Vi prego ... trovate il modo di installarlo! ... è l'unica cosa che mi manca su Gentoo per riuscire a non lavorare su altre macchine!
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 13200
Location: here

PostPosted: Fri Dec 10, 2004 5:05 pm    Post subject: Reply with quote

Kind_of_blue wrote:
Vi prego ... trovate il modo di installarlo! ... è l'unica cosa che mi manca su Gentoo per riuscire a non lavorare su altre macchine!

E' gratis il programma? Se si potrei provare ad installarlo
_________________
"aspetto un'emozione sempre più indefinibile"
- CCCP -
"la libertà un doveroso pericolo in verità"
- PGR -
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
jfalchetto
n00b
n00b


Joined: 21 Nov 2004
Posts: 6
Location: Torino, Italy

PostPosted: Sat Dec 11, 2004 1:36 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Kind_of_blue wrote:
Vi prego ... trovate il modo di installarlo! ... è l'unica cosa che mi manca su Gentoo per riuscire a non lavorare su altre macchine!

E' gratis il programma? Se si potrei provare ad installarlo


No e' a pagamento ma c'e' una licenza try da 60 gg scaricabile da qui: http://www-106.ibm.com/developerworks/websphere/downloads/WASsupport.html

Sto provando a fare un po' di 'strace' per capire meglio cosa succede...
sembra mancare un passo di "cp" della JVM dalla directory d'installazione al target /opt/WebSphere/AppServer.
Back to top
View user's profile Send private message
jfalchetto
n00b
n00b


Joined: 21 Nov 2004
Posts: 6
Location: Torino, Italy

PostPosted: Mon Dec 20, 2004 8:41 am    Post subject: Reply with quote

Ho semi-risolto il problema d'installazione: leggendo tra vari post (non linux) ho scovato un "bug" in funzione dei font disponibili sul proprio Xserver, la mia soluzione e' stata alquanto drastica ed ho installato il tutto su un Gentoo X86 usando una Sun come Xserver. :D

Ho notato anche un'altra simpatica cosa: il log file ha qualche "errore" che in realta' e' un "warning" (grazie Big Blue!).

Sto indagando ulteriormente per poter capire "quale" font gli manca.
Back to top
View user's profile Send private message
!equilibrium
Bodhisattva
Bodhisattva


Joined: 06 Jun 2004
Posts: 2109
Location: MI/BG/LC

PostPosted: Mon Dec 20, 2004 3:23 pm    Post subject: Reply with quote

non so se è valida come proposta, ma potresti valutare JBoss come alternativa per l'application server J2EE di IBM.

http://www.jboss.org/products/index
http://www.jboss.com/products/overview
_________________
Arch Tester for Gentoo/FreeBSD
Equilibrium's Universe

all my contents are released under the Creative Commons Licence by-nc-nd 2.5
Back to top
View user's profile Send private message
jfalchetto
n00b
n00b


Joined: 21 Nov 2004
Posts: 6
Location: Torino, Italy

PostPosted: Mon Dec 20, 2004 11:34 pm    Post subject: Reply with quote

DarkAngel76 wrote:
non so se è valida come proposta, ma potresti valutare JBoss come alternativa per l'application server J2EE di IBM.

http://www.jboss.org/products/index
http://www.jboss.com/products/overview


Purtroppo devo proprio usare WebSphere Application Server non un'altro J2EE Container.

Anche perche' e' impossibile fare un transazione in XA con MQ in JBoss.
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3020
Location: ROMA

PostPosted: Thu Jun 21, 2012 2:54 pm    Post subject: Reply with quote

Ciao!

Io sto provando a lanciare l'installer di WebSphere Application Server Community edition ma mi dice sempre che non trova java nel PATH:
Code:
No Java virtual machine could be found from your PATH
environment variable.  You must install a VM prior to
running this program.

Mi sembra strano perché comunque java è un eseguibile che è in /usr/bin e funziona perfettamente. Non so cosa voglia allora.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2908
Location: Parma (Italy)

PostPosted: Thu Jun 21, 2012 3:26 pm    Post subject: Reply with quote

prova a settare la VM com java-config-2 .
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3020
Location: ROMA

PostPosted: Thu Jun 21, 2012 4:03 pm    Post subject: Reply with quote

Ma la JVM è già settata come segue:
Sun JDK 1.6.0.33 [sun-jdk-1.6]

Che differenza c'è fra java-config e java-config-2? :roll:

EDIT: ho risolto aggiungendo la seguente riga in ~/.bashrc:
Code:
export PATH="/opt/sun-jre-bin-1.6.0.33/bin/:$PATH"

_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum