Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X servern krånglar... [fixad]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
MdaG
l33t
l33t


Joined: 09 Nov 2004
Posts: 945
Location: Stockholm, Sverige

PostPosted: Wed Dec 08, 2004 9:17 pm    Post subject: X servern krånglar... [fixad] Reply with quote

Har lyckats pajja X igen...
Jag uppdaterade nyligen linux-headers för att några spel inte vill starta annars.

Code:

# emerge -C linux-headers
# emerge linux26-headers
# USE="nptl" emerge glibc


Och nu så vägrar X starta.

Quote:
X: relocation error: X: symbol_guard, version GLIBC_2.3.2 not defined in file libc.so.6 with link time refernce
giving up.
xinit: Connection refused (errno 111): unable to connect to X server
xinit: No such process (errno 3): server error.


Är det någon som vet vad jag har gjort för dumt och hur man fixar det?


Last edited by MdaG on Thu Dec 09, 2004 5:05 pm; edited 1 time in total
Back to top
View user's profile Send private message
keyson
l33t
l33t


Joined: 10 Jun 2003
Posts: 827
Location: Sweden

PostPosted: Wed Dec 08, 2004 9:36 pm    Post subject: Reply with quote

Hej.

Nja xorg är länkat mot glibc, så jag tror att du
får kompilera om xorg.

Ett sätt är att se till att nptl är med i USE, sedan
köra

emerge -p --newuse world

Så ser du vilka paket som den anser behöver köras igen.

-Kjell
Back to top
View user's profile Send private message
mrmodin
Apprentice
Apprentice


Joined: 24 Jan 2004
Posts: 216
Location: Stockholm, Sweden

PostPosted: Wed Dec 08, 2004 10:00 pm    Post subject: Reply with quote

Du bör kompilera om hela systemet med nptl om du vill ha någon nyta av det.
Code:
emerge -e system && emerge -e world
Back to top
View user's profile Send private message
MdaG
l33t
l33t


Joined: 09 Nov 2004
Posts: 945
Location: Stockholm, Sverige

PostPosted: Thu Dec 09, 2004 5:04 pm    Post subject: Reply with quote

Jag körde bara en emerge --sync och sedan emergade jag linux26-headers och glibc igen så funkade allt igen.
Back to top
View user's profile Send private message
mrmodin
Apprentice
Apprentice


Joined: 24 Jan 2004
Posts: 216
Location: Stockholm, Sweden

PostPosted: Thu Dec 09, 2004 10:53 pm    Post subject: Reply with quote

men du borde ändå kompilera om systemet! :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum