Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Updated 12/18 shadow-sources: lots of improvements
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 959

PostPosted: Sat Dec 04, 2004 8:59 pm    Post subject: Updated 12/18 shadow-sources: lots of improvements Reply with quote

I decided to base this patchset on the Gentoo-dev-sources philosophy with individual patches instead of one large monolithic patch. This makes it easier for people to add in their own patches to the shadowpatches-extra archive file, so that the patch(es) is automatically patched in. I used patches from Gentoo-dev-sources current (2.6.9-r9), Alan Cox's patchset current (see NOTE before the patch listing), CK-sources* current, Reiser4* current, and much more.
*Depends on the use flag setting.

Shadow-sources are now hosted on sf.net at: https://sourceforge.net/projects/shadow-sources/

[UPDATE] 12/18
IMPORTANT: I changed the use flag from noreiser4 to reiser4, so if you want reiser4 support, you need to add it to the use list by doing something like:
Code:
~ # echo "sys-kernel/shadow-sources reiser4" >> /etc/portage/package.use
I did this for sanity reasons in the ebuild so I could follow it a little better. :D

I added a lot of new patches for acrchs other than amd64 and x86.

I updated swsup2 to the newest beta because there were some issues with it and breaking certain things, well, at least in my testing.

Added an updated version of the patch to fix the compile error when swsup2 is used.

Updated to the newest -ac patch.

I moved all the patched that were not in base to extra, so now there are only 2 archives to DL. They are big, though.

As such, I changed how swsup2 and kexec are handled.

Lots of changes to the ebuild to handle all this.
[/UPDATE]

See, the Readme or the Series docs for more info.

Download here. Extract in the sys-kernel portage overlay. This is on my machine, so please be careful. Please read further to see what this patchset has to offer. Also, please report back here for any bugs, and/or comments that you have. I will continue to post updates if people use it. Thanks!

I have two use flages: ckserver, and noreiser4.

Reason for ckserver flag:
CK Released to different Patchsets: A workstation version, which is what all the CK based patchsets use, and a server version, which is new and has some nice performace tweaks for a server environment. So far this is the only patchset I have seen that includes the CK-Server Patchset. See the readme included with the Shadow-sources for more information on how to use the server tweaks. NOTE: You cannot use both CK and CK server. CK Server excludes some patches that regular CK uses.

Reason for noreiser4 flag:
Reiser4 is still relatively experimental, so users may wish to not even use it, and since I designed this patchset to be modular and easy to add patches to, Reiser4 may break some patches, so if it is not going to be used, then there is no reason to patch the kernel with it.

Reason for swsup2 flag:
There are 53 patches that are associated with swsup2, so I decided to put them all in their own archive instead of putting them in extra. This is also the major reason why I have a use flag for swsup2. A lot of files are modified, and this may run the risk of breaking your patches or other things, so if you do not use it, then there is no need to have it patched in and risking a lot. Plus, I need to take into consideration server use. Well, at least the total download is smaller if you do not use swsup2. ;)

I am using this the workstation version of this kernel right now, and everything appears to work correctly and fast. :D

Also, I would appreciate it if people could test this patch out using the Server version in a real server environment. I would like to know how it handles, and the AC and Gentoo patches fix a lot of bugs and security holes, so it should be alright to use there. There are no other experimental patches other than reiser4, and you can choose not to patch that at all, so this should be very stable.
_________________
Nothing to read in this sig. Move along.


Last edited by StifflerStealth on Sat Dec 18, 2004 6:18 am; edited 9 times in total
Back to top
View user's profile Send private message
cuchumino
Guru
Guru


Joined: 24 Nov 2004
Posts: 428

PostPosted: Sun Dec 05, 2004 5:38 am    Post subject: Reply with quote

great job stealth. Im gonna try some of those out, after i get a good night's sleep :).

I already compiled some cko and nitro, and i am comparing, so it would be nice to have another patch to compare with. But for now im pooped for today. :lol:
Back to top
View user's profile Send private message
desertstalker
Apprentice
Apprentice


Joined: 18 Sep 2004
Posts: 209

PostPosted: Sun Dec 05, 2004 6:00 am    Post subject: Reply with quote

Id like to make a request. Is there any cahnce of you adding the swsusp2 patch to this patchset possibly as another USE flag. I use gentoo on a laptop and would love a stable fast kernel with swsusp2.

Thanks, hope this is possible
Back to top
View user's profile Send private message
Satyrinox
Tux's lil' helper
Tux's lil' helper


Joined: 08 Oct 2003
Posts: 110
Location: New Mexico

PostPosted: Sun Dec 05, 2004 8:09 am    Post subject: Reply with quote

Sure thing , ill try it on my server its just running regular gentoo-dev-sources , but im down for anything , so illl come back with feedback on how it went :D
_________________
[Powered By Gentoo Linux
AMD Athlon 2000+
756 Megs ddr2100 OC-Systems RAM
NVIDIA Geforce FX 5200
Leadtek Mobo]
<same config for 2 years now ;-) >
Back to top
View user's profile Send private message
mr666white
n00b
n00b


Joined: 24 Aug 2004
Posts: 52

PostPosted: Sun Dec 05, 2004 9:11 am    Post subject: Re: Shadow-sources: Gentoo, AC, CK/CK-Server, Reiser4 + ebui Reply with quote

Interesting patchset, i might try it tonight, could work nicely on my compaq i use as a workstation (see signiture).

Just one question
StifflerStealth wrote:

I am using this the workstation version of this kernel right now, and I did patch each patch by hand to make sure that everything will work correctly. I do get a nice 200 FPS more in glxgears using this kernel compared to the Gentoo-dev-sources with Reiser4.


Surely reiser4 has no effect on glxgears performance? However if i can get another 200 FPS out the compaq I'll be very impressed. It's currently running at ~29 FPS at 1024x768 16bpp @70Hz!
_________________
www.technomancer.me.uk
Back to top
View user's profile Send private message
Satyrinox
Tux's lil' helper
Tux's lil' helper


Joined: 08 Oct 2003
Posts: 110
Location: New Mexico

PostPosted: Sun Dec 05, 2004 9:49 am    Post subject: Reply with quote

well i tried , it worked , but the forcedeth drivers failed, so im going to have another try at it
but so far it took me almost an hour to compile it on a 700 mHz athlon lol :lol:
_________________
[Powered By Gentoo Linux
AMD Athlon 2000+
756 Megs ddr2100 OC-Systems RAM
NVIDIA Geforce FX 5200
Leadtek Mobo]
<same config for 2 years now ;-) >
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 959

PostPosted: Sun Dec 05, 2004 4:35 pm    Post subject: Reply with quote

Thanks for all your compliments! :D

Quote:
Id like to make a request. Is there any cahnce of you adding the swsusp2 patch to this patchset possibly as another USE flag. I use gentoo on a laptop and would love a stable fast kernel with swsusp2.
I will take a look into this. I need to be carefull with what I add because I have the server stuff going as well, so I might put it in extra, and rename the use flag from noreiser4 to something like noextra, or I may end up creating a new use flag.

Quote:
Surely reiser4 has no effect on glxgears performance? However if i can get another 200 FPS out the compaq I'll be very impressed. It's currently running at ~29 FPS at 1024x768 16bpp @70Hz!
Sorry for the confusion. I meant that I use to run the gentoo-dev-sources with Reiser4 patched in, but I get a performance increase of 200 FPS more when I switch to a kernel based on CK, which is due to Staircase. That is why I used the CK patches in this patchset. I hope that is a little clearer. Although, I do gain some I/O performace using a the newest Reiser4 patch.

Quote:
well i tried , it worked , but the forcedeth drivers failed, so im going to have another try at it
but so far it took me almost an hour to compile it on a 700 mHz athlon lol
I will look into the forcedeth drivers right now. It might be a patch that is messing with it in a strange way. Did you notice any performace gains using the server version of CK?

EDIT: AC14 is out now, and it is different than AC12/13, so I will add that to the update. Any other patches that you would like to see added to this patchset?

Again, thanks for using and bug testing this patchset.
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
Satyrinox
Tux's lil' helper
Tux's lil' helper


Joined: 08 Oct 2003
Posts: 110
Location: New Mexico

PostPosted: Sun Dec 05, 2004 5:16 pm    Post subject: Reply with quote

just had to recompile the module again , im not sure what happened there, but so far its running sweet on my server , I dont really have any complaints , because the number of patches it takes almost an hour to compile , but no biggie man!


Keep up the Good work!!!! :twisted: :twisted: :mrgreen:
_________________
[Powered By Gentoo Linux
AMD Athlon 2000+
756 Megs ddr2100 OC-Systems RAM
NVIDIA Geforce FX 5200
Leadtek Mobo]
<same config for 2 years now ;-) >
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 959

PostPosted: Sun Dec 05, 2004 5:25 pm    Post subject: Reply with quote

Satyrinox wrote:
just had to recompile the module again , im not sure what happened there, but so far its running sweet on my server , I dont really have any complaints , because the number of patches it takes almost an hour to compile , but no biggie man!


Keep up the Good work!!!! :twisted: :twisted: :mrgreen:
Thanks! Ok, I'm glad you got that fixed. The AC14 patch upgrades the Forcedeth version from 0.29 to 0.30. I will take a look at AC12 to see if it did the same. EDIT: Yeah, AC12 also upgrades forcedeth to version 0.30, so you are using the newer version. :D [/edit] That might be part of the problem you experienced, but so far that is the only patch that I have seen that modifies forcedeth.c. I went on the Forcedeth website and they have and experimental patch that adds 1 GigaBit Ethernet. I am thinking of adding that as a use flag because I know some server boards have built in GigaBit. Although, it looks like GigaBit migh be in version 0.29 already. I need to look at the files carefully.

There are a lot of patches, but the main bulk of them are bug fixes, like the big AC patch.
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
Satyrinox
Tux's lil' helper
Tux's lil' helper


Joined: 08 Oct 2003
Posts: 110
Location: New Mexico

PostPosted: Sun Dec 05, 2004 6:01 pm    Post subject: Reply with quote

ok one more thing to add , i think it breaks nvidia-kernel && nvidia-glx ,
even tho its my server, its my old gaming box , soi tried to re-emerge both , both said succesful.
now nvidia module will not load , so i switched to the standby 'nv'
its cool tho ,i have a new gaming box , and use my server mainly for my website and music , if you can figure out what happened there ,id like to know tho , still no biggie ,
im happy with your patches , and its as stable as gentoo-dev-sources ! :P
_________________
[Powered By Gentoo Linux
AMD Athlon 2000+
756 Megs ddr2100 OC-Systems RAM
NVIDIA Geforce FX 5200
Leadtek Mobo]
<same config for 2 years now ;-) >
Back to top
View user's profile Send private message
ljubo
n00b
n00b


Joined: 26 Nov 2003
Posts: 73
Location: Karlovac, Croatia

PostPosted: Sun Dec 05, 2004 6:03 pm    Post subject: Reply with quote

Works like a charm!
Forcedeth works without problems with my ABit NF7-S nForce2 mobo.

Thank You StifflerStealth!

Best regards, Ljubo

EDIT:
Satrynox: nVIDIA 1.0.6629 drivers compile and work fine on my config. Maybe your problem is not shadow-sources related.
Code:
# emerge info
Portage 2.0.51-r3 (default-linux/x86/2004.3, gcc-3.4.3, glibc-2.3.4.20040808-r1, 2.6.9-shadow i686)
=================================================================
System uname: 2.6.9-shadow i686 AMD Athlon(tm)
Gentoo Base System version 1.4.16
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-2.15.90.0.1.1-r3
Headers:  sys-kernel/linux26-headers-2.6.8.1
Libtools: sys-devel/libtool-1.5.2-r7
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-march=athlon-xp -mtune=athlon-xp -O2 -pipe -fomit-frame-pointer -frename-registers-ftracer -fprefetch-loop-arrays"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config//usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-xp -mtune=athlon-xp -O2 -pipe -fomit-frame-pointer -frename-registers -ftracer -fprefetch-loop-arrays -fvisibility-inlines-hidden"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="http://gentoo.inode.at/ ftp://gentoo.inode.at/source/ ftp://gd.tuwien.ac.at/opsys/linux/gentoo/ ftp://ftp.iasi.roedu.net/pub/mirrors/gentoo.org/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowex S3TC X alsa apm arts audiofile avi berkdb bitmap-fonts bluetooth cdparanoia cdr crypt cups dvd encode esd f77 fam fftw flac foomaticdb fortran freetype gdbm gif gimp gimpprint glut gphoto2 gpm gtk gtk2 imagemagick imlib jack jack-tmpfs java joystick jpeg kde libg++ libwww mad mikmod mmx mmxext motif mozilla mpeg mysql ncurses nls nptl nvidia odbcoggvorbis openal opengl oss pam pdflib perl pic png postgres povray ppds python qt quicktime readline real rtc ruby scanner sdl slang speex spell sqlite sse ssl svg svga tcltk tcpd tetex tiff truetype unicode usb v4l v4l2 wmf x86 xine xml xml2 xmms xprint xv xvid zlib"
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 959

PostPosted: Sun Dec 05, 2004 6:20 pm    Post subject: Reply with quote

Satyrinox wrote:
ok one more thing to add , i think it breaks nvidia-kernel && nvidia-glx ,
even tho its my server, its my old gaming box , soi tried to re-emerge both , both said succesful.
now nvidia module will not load , so i switched to the standby 'nv'
its cool tho ,i have a new gaming box , and use my server mainly for my website and music , if you can figure out what happened there ,id like to know tho , still no biggie ,
im happy with your patches , and its as stable as gentoo-dev-sources ! :P
I tracked down the problem and I think I know what it is. Just to be sure, can you apply this patch and recompile. This should fix it and I will move the patch from base workstation to base, if it does fix it. The next release will be later today. I didn't expect anyone to run the full nVidia drivers on a server. :oops:

Quote:
Works like a charm!
Forcedeth works without problems with my ABit NF7-S nForce2 mobo.

Thank You StifflerStealth!

Best regards, Ljubo
Thanks and you are welcome. :D
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
Satyrinox
Tux's lil' helper
Tux's lil' helper


Joined: 08 Oct 2003
Posts: 110
Location: New Mexico

PostPosted: Sun Dec 05, 2004 7:01 pm    Post subject: Reply with quote

ok thank you ill applky and recompile , and will be back with how it went , thanks StifflerStealth

and LoL yes my server is not only a regular server , but sometimes me and my friends have a go at enemy territory , so shes doing double-duty :D
_________________
[Powered By Gentoo Linux
AMD Athlon 2000+
756 Megs ddr2100 OC-Systems RAM
NVIDIA Geforce FX 5200
Leadtek Mobo]
<same config for 2 years now ;-) >
Back to top
View user's profile Send private message
Satyrinox
Tux's lil' helper
Tux's lil' helper


Joined: 08 Oct 2003
Posts: 110
Location: New Mexico

PostPosted: Sun Dec 05, 2004 7:10 pm    Post subject: Reply with quote

hmm strange patch , what is the syntax on it so i can be sure to not mess anything up ( and yes i have patched kernels before but its been a while)
_________________
[Powered By Gentoo Linux
AMD Athlon 2000+
756 Megs ddr2100 OC-Systems RAM
NVIDIA Geforce FX 5200
Leadtek Mobo]
<same config for 2 years now ;-) >
Back to top
View user's profile Send private message
Satyrinox
Tux's lil' helper
Tux's lil' helper


Joined: 08 Oct 2003
Posts: 110
Location: New Mexico

PostPosted: Sun Dec 05, 2004 7:12 pm    Post subject: Reply with quote

and here is my emerge info , if it helps :
Code:
Portage 2.0.51-r3 (default-linux/x86/2004.3, gcc-3.3.4, glibc-2.3.4.20040808-r1, 2.6.9-shadow i686)
=================================================================
System uname: 2.6.9-shadow i686 AMD Athlon(tm) Processor
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-2.15.90.0.1.1-r3
Headers:  sys-kernel/linux-headers-2.4.21-r1
Libtools: sys-devel/libtool-1.5.2-r7
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"                 
CFLAGS="-O2 -mcpu=i686 -fomit-frame-pointer"
CHOST="i386-pc-linux-gnu"       
COMPILER=""                     
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/share/config /var/qmail/control"                     
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -mcpu=i686 -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig candy ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="http://gentoo.osuosl.org http://distro.ibiblio.org/pub/Linux/distributions/gentoo"                         
MAKEOPTS="-j2"                 
PKGDIR="/usr/portage/packages" 
PORTAGE_TMPDIR="/var/tmp"       
PORTDIR="/usr/portage"         
PORTDIR_OVERLAY=""             
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X apm arts avi berkdb bitmap-fonts crypt cups encode esd f77 fam foomaticdb fortran gdbm gif gnome gpm gtk gtk2 imlib jpeg kde libg++ libwww mad mikmod motif mpeg ncurses nls oggvorbis opengl oss pam pdflib perl png python qt quicktime readline sdl spell ssl svga tcpd tiff truetype x86 xml2 xmms xv zlib"

_________________
[Powered By Gentoo Linux
AMD Athlon 2000+
756 Megs ddr2100 OC-Systems RAM
NVIDIA Geforce FX 5200
Leadtek Mobo]
<same config for 2 years now ;-) >
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 959

PostPosted: Sun Dec 05, 2004 7:40 pm    Post subject: Reply with quote

Satyrinox wrote:
hmm strange patch , what is the syntax on it so i can be sure to not mess anything up ( and yes i have patched kernels before but its been a while)
as root:
Code:
# cd /usr/src/linux
# patch -p1 -i /path/to/patch
If you used Genkernel or ccache, then the recompile should go very quickly. :D You do not need to go into menu config or anything, just use the --oldconfig option in genkernel, or the usual compilimg options if you do it by hand. I hope this helps.
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
Satyrinox
Tux's lil' helper
Tux's lil' helper


Joined: 08 Oct 2003
Posts: 110
Location: New Mexico

PostPosted: Sun Dec 05, 2004 7:47 pm    Post subject: Reply with quote

ahh i like to do it by hand, but thanks much! :D
i am just an old-fashoined type guy :lol:






(afterthought , i should have just RTFM'ed instead of bugging him)
_________________
[Powered By Gentoo Linux
AMD Athlon 2000+
756 Megs ddr2100 OC-Systems RAM
NVIDIA Geforce FX 5200
Leadtek Mobo]
<same config for 2 years now ;-) >
Back to top
View user's profile Send private message
Satyrinox
Tux's lil' helper
Tux's lil' helper


Joined: 08 Oct 2003
Posts: 110
Location: New Mexico

PostPosted: Sun Dec 05, 2004 7:55 pm    Post subject: Reply with quote

also ,i have a crazy idea , im going to test your kernel out for a week , if me and it can live comfortably together , then i might want to add it into my project , which is a server/gaming/.development type distro . i would like your blessings if all goes well :D
_________________
[Powered By Gentoo Linux
AMD Athlon 2000+
756 Megs ddr2100 OC-Systems RAM
NVIDIA Geforce FX 5200
Leadtek Mobo]
<same config for 2 years now ;-) >
Back to top
View user's profile Send private message
Satyrinox
Tux's lil' helper
Tux's lil' helper


Joined: 08 Oct 2003
Posts: 110
Location: New Mexico

PostPosted: Sun Dec 05, 2004 8:22 pm    Post subject: Reply with quote

ok no go , i think i might have bornked a setting or something , its reallly no matter tho , but im going to try it on my main box , just to be sure , and to see what will happen , im using
Code:
  media-video/nvidia-kernel
      Latest version available: 1.0.6111-r3
      Latest version installed: 1.0.6111-r3
, and
 media-video/nvidia-glx
      Latest version available: 1.0.6111
      Latest version installed: 1.0.6111
,
so i hope it works on this box :D cause even tho the nvidia module isnt working on my server , it can still host games and play them with the generic driver ,so its a moot matter to me at least
so at least your kernel set has found a home in my server! :twisted:

I will keep ya posted on how this box is doing
*peace*


:!:
_________________
[Powered By Gentoo Linux
AMD Athlon 2000+
756 Megs ddr2100 OC-Systems RAM
NVIDIA Geforce FX 5200
Leadtek Mobo]
<same config for 2 years now ;-) >
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 959

PostPosted: Sun Dec 05, 2004 8:33 pm    Post subject: Reply with quote

Satyrinox wrote:
also ,i have a crazy idea , im going to test your kernel out for a week , if me and it can live comfortably together , then i might want to add it into my project , which is a server/gaming/.development type distro . i would like your blessings if all goes well :D
You have my blessing. :D Thank you much.

I will still work on the nVidia problem that you are having. I find it odd. I am using:
Code:
*  media-video/nvidia-glx
      Latest version available: 1.0.6629
      Latest version installed: 1.0.6629
      Size of downloaded files: 16,116 kB
      Homepage:    http://www.nvidia.com/
      Description: NVIDIA X11 driver and GLX libraries
      License:     NVIDIA

*  media-video/nvidia-kernel
      Latest version available: 1.0.6629
      Latest version installed: 1.0.6629
      Size of downloaded files: 16,116 kB
      Homepage:    http://www.nvidia.com/
      Description: Linux kernel module for the NVIDIA X11 driver
      License:     NVIDIA

*  media-video/nvidia-settings
      Latest version available: 1.0.6629
      Latest version installed: 1.0.6629
      Size of downloaded files: 798 kB
      Homepage:    http://www.nvidia.com/
      Description: NVIDIA Linux X11 Settings Utility
      License:     GPL-2
and everything works perfectly. It must be something with the server version of CK. I am making loads of internal changes to the ebuild for the next release. I am setting the Extraversion in the ebuild to distinguish between the workstation and server versions ;) I have a lot of options with ebuilds and I want to make the most of them. :D I will definately try to get the nVidia working for server.

EDIT: I remember something about mtrr is needed for nVidia drivers, or something like that. Well, anyways, I remember something about nVidia needed something compiled into the kernel. Also, do you have nvidia in /etc/modules.autoload.d/kernel-2.6? Sometimes that is need. Also, since you recompiled your kernel again, another install of the nvidia-kernel is needed. You can tell that I am determined to squash all bugs. ;) I love bug free and stable environments. :D
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
Satyrinox
Tux's lil' helper
Tux's lil' helper


Joined: 08 Oct 2003
Posts: 110
Location: New Mexico

PostPosted: Sun Dec 05, 2004 9:35 pm    Post subject: Reply with quote

yes sir/maam , i have done all that , and am fixing to try the kernel on this box now
( my mainbox)
, and i very much appreciate the blessings
*bow*


:mrgreen:
_________________
[Powered By Gentoo Linux
AMD Athlon 2000+
756 Megs ddr2100 OC-Systems RAM
NVIDIA Geforce FX 5200
Leadtek Mobo]
<same config for 2 years now ;-) >
Back to top
View user's profile Send private message
Satyrinox
Tux's lil' helper
Tux's lil' helper


Joined: 08 Oct 2003
Posts: 110
Location: New Mexico

PostPosted: Sun Dec 05, 2004 10:21 pm    Post subject: Reply with quote

ok it worked on my main box , all modules load clean as they can be , as for fps in glxgears , i see a good advantage
this is the result of my mainbox system specs
Quote:
Mal_Mainbox_hed
--------------------------------------------
SysInfo: Linux 2.6.9-shadow | AMD Athlon(tm) XP 2000+ 1670.468 MHz
Mem: 209 used / 248 total / 38 Free [|||||||||*]
Diskspace: Filesystem Type Size Used Avail Use% Mounted on
/dev/hda3 ext3 9.1G 999M 7.6G 12% /
/dev/hdb1 ext3 7.4G 4.0G 3.0G 57% /usr
/dev/hdb2 ext3 12G 918M 9.6G 9% /home
none tmpfs 125M 0 125M 0% /dev/shm
Screen Res: 1280x1024 | Procs: 50
Up: 06:26:30 up 12 min, 3 users, load average: 0.01, 0.07, 0.07
eth0: In: 0 Megs Out: 0 Megs
--------------------------------------------


and glxgears
Quote:

glxgears
5074 frames in 5.0 seconds = 1014.800 FPS
6817 frames in 5.0 seconds = 1363.400 FPS
9132 frames in 5.0 seconds = 1826.400 FPS
9158 frames in 5.0 seconds = 1831.600 FPS



still trying to get the module to load on my server , it might have been user error :))
_________________
[Powered By Gentoo Linux
AMD Athlon 2000+
756 Megs ddr2100 OC-Systems RAM
NVIDIA Geforce FX 5200
Leadtek Mobo]
<same config for 2 years now ;-) >
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 959

PostPosted: Sun Dec 05, 2004 11:45 pm    Post subject: Reply with quote

Version bump*
I cleaned up the ebuild a lot and made it even easier to add your patches to this patchset. Just give your patch the appropriate number as defined in the readme and add that file to the shadowpatches-extra archive, then re-digest and emerge.

I also added some nice little candy to the ebuild that changes the extraversion depending on if you are using the CK-server series.

I updated AC12 to AC14 and made sure all the other patches still worked.

I cleaned all the "fuzz" out of some of the patches, so everything patches more cleanly now. ;)

The changes I made will make it easier for me to add in Software Suspend 2. There are 63 patches that I need to look at to add it and make sure they add in nicely with my modular design. That is the only problem about having a modular design, but it is worth it because some of the patches are experimental and most people will not want them in a server environment.
The old ebuild will not work because I made some directory changes. The now tar.bz2 file has an updated older version in case you need it.

I hope this fixes the nVidia issue on the Server Series. If not, I will look into it some more.
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
pilx
n00b
n00b


Joined: 27 Jun 2004
Posts: 43

PostPosted: Mon Dec 06, 2004 12:42 am    Post subject: Reply with quote

Great news this new patchset StifflerStealth! Very nice work!

Something very similar I was just about to do myself, but now I'm gona try this one of yours right away.

There are a couple of patches I miss though:
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 959

PostPosted: Mon Dec 06, 2004 1:08 am    Post subject: Reply with quote

pilx wrote:
The first one is included in the worstation version (the server version uses a different set of cfq defaults), and the second patch is included in the AC14 patch.

I hope this helps.
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum