Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2.6.9-nitro2 "Now with wings"
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
fimbulvetr
n00b
n00b


Joined: 03 Feb 2004
Posts: 51
Location: South Dakota

PostPosted: Wed Nov 03, 2004 8:35 pm    Post subject: Reply with quote

eean, not sure what you're running, but I can vouch for a substantial speedup. Especially in firefox/apollon and even copying files.
_________________
:wq
Back to top
View user's profile Send private message
Clent
n00b
n00b


Joined: 03 Nov 2004
Posts: 3

PostPosted: Wed Nov 03, 2004 9:56 pm    Post subject: Reply with quote

Hi, i'm not sure if this problem has already been submitted, but my Xorg won't start with this kernel (switching from 2.6.8.1ck7) : i got a black screen when X tries to launch gdm after startup, i can't kill anything, just got a black screen. Thus, i don't think i can give you a log :/

I use a firegl9000 with the built-in radeon drivers and xorg 6.8.0r2, which worked fine with my old kernel. Framebuffer works well though...

Please ask me if you need details, thx !
Back to top
View user's profile Send private message
ryceck
Apprentice
Apprentice


Joined: 13 Jan 2004
Posts: 195

PostPosted: Wed Nov 03, 2004 10:28 pm    Post subject: Reply with quote

Anyone here who already has the win4lin patch that can mirror it?
Cuz the site mentioned in the startpost appears to be down :/

Thnx in advance :)

Many thanx to jdkbx who supplied the patch
The patch is now mirrored at:

http://files.ryceck.com/nitro/2.6.9-nitro2-win4lin.patch.bz2

If seppe would be so kind to include that in the openingpost then the patch can be use/downloaded again
Back to top
View user's profile Send private message
Robin79
l33t
l33t


Joined: 18 Oct 2003
Posts: 632
Location: /home/valdemarsvik

PostPosted: Thu Nov 04, 2004 12:38 am    Post subject: Reply with quote

I am trying Ivman and getting this error message!! Can anyone tell me what i should do or not should do please :)

Code:

(~/)-> ivman
libhal.c 605 : Error connecting to system bus: Failed to connect to socket /var/lib/dbus/system_bus_socket: No such file or directory

** (process:22668): WARNING **: manager.c/342: Failed to initialize HAL!

_________________
Gentoo 2005.0
ASUS P5AD2 Deluxe MB
Intel P4 3.2GHz
PCI-E Nvidia Geforce PCX 5750
--------------------

Registered Linux User Nr # 319050 http://counter.li.org
Back to top
View user's profile Send private message
stalcair
n00b
n00b


Joined: 07 Aug 2003
Posts: 57

PostPosted: Thu Nov 04, 2004 3:08 pm    Post subject: to all those with reiser4 lockups Reply with quote

are the problems you have like this?

At random times (but perhaps from spikes of system, memory and disk usage, your system will begin to eat itself up.

A process ( grep -iR something, or find . -type f -exec grep -i something {} \; ) will quickly increase in its CPU usage if you monitor top, until it reaches 99.8 to 99.9.
At that time you can't log in via ssh
the mouse and screen are frozen
no keypresses are registered (including <ALT><CTRL><BACKSPACE>)
kswapd0 just happens to also be chugging along at 99.9 % CPU utilization
*important part* You CAN NOT KILL the defunct process(es) yet they are of stat R. Kill 9 does not work, and looping through until you can kill it does not work either.
Not everytime, but sometimes well before the crash, dmesg showed output of "CFQ Baddness"

If so then this is what I have found:
acpi=off and/or pci=noacpi does not help
elevator setting of "as" or "noop" does not help
renicing the reiser4 kernel processes to -10 or -15 does not help
NOT mounting the reiser4 partitions at boot does not help

This problem manifests with or without SMP (and SMT with it). I have not tried turning off preempt, but it doesn't sound like that is the problem either.

Since I have this problem without any reiser4 partitions mounted (but I have yet to recompile the kernel WITHOUT reiser4 support compiled in) then I am guessing that even though it happens more often with Reiser4 partitions mounted that this is merely a result of it hogging more resources. (e.g. given a boat with a hole in the bottom, you cannot blame heavy cargo for causing the problem... it just makes the boat sink faster)
Back to top
View user's profile Send private message
sibov
Tux's lil' helper
Tux's lil' helper


Joined: 09 Feb 2004
Posts: 147
Location: Germany

PostPosted: Thu Nov 04, 2004 3:13 pm    Post subject: Reply with quote

Clent wrote:
Hi, i'm not sure if this problem has already been submitted, but my Xorg won't start with this kernel (switching from 2.6.8.1ck7) : i got a black screen when X tries to launch gdm after startup, i can't kill anything, just got a black screen. Thus, i don't think i can give you a log :/

I use a firegl9000 with the built-in radeon drivers and xorg 6.8.0r2, which worked fine with my old kernel. Framebuffer works well though...

Please ask me if you need details, thx !


:?: Are you using vesafb / vesafb-tng :?:

sounds like framebuffer switching problem

:!: :!: If you are using ati radeon don't use the radeon fb in kernel :!: :!:
_________________
Gentoo 2.6.17-gentoo-r5 with dmraid Raid0 Dualboot
AMD64 X2 3800+, 4x512MB DDR PC3200Pro Corsair Geforce EN6600GT silencer @ 256MB
4x250GB SATAII Samsung SP120, Asus A8N Premium, Plextor PX712SA DVDRW
Logitech Dinovo, SB Audigy4
Back to top
View user's profile Send private message
eean
Guru
Guru


Joined: 10 Jun 2002
Posts: 355
Location: Kirksville, MO USA

PostPosted: Thu Nov 04, 2004 3:56 pm    Post subject: Re: to all those with reiser4 lockups Reply with quote

stalcair wrote:
are the problems you have like this?

At random times (but perhaps from spikes of system, memory and disk usage, your system will begin to eat itself up.

A process ( grep -iR something, or find . -type f -exec grep -i something {} \; ) will quickly increase in its CPU usage if you monitor top, until it reaches 99.8 to 99.9.
At that time you can't log in via ssh
the mouse and screen are frozen
no keypresses are registered (including <ALT><CTRL><BACKSPACE>)
kswapd0 just happens to also be chugging along at 99.9 % CPU utilization
*important part* You CAN NOT KILL the defunct process(es) yet they are of stat R. Kill 9 does not work, and looping through until you can kill it does not work either.
Not everytime, but sometimes well before the crash, dmesg showed output of "CFQ Baddness"
[snip]

Yes, something like this, except I don't use ReiserFS 4 (I do have a couple of ReiserFS 3 partitions). And while SSH does not work, the num lock key and LED do work, which is kind of odd. Generally if there's a full on kernel panic that breaks SSH, the num lock light does not work either.

It seems to happen while the system is multitasking under heavy load.
_________________
Amarok - Rediscover your Music
Back to top
View user's profile Send private message
ryceck
Apprentice
Apprentice


Joined: 13 Jan 2004
Posts: 195

PostPosted: Thu Nov 04, 2004 4:03 pm    Post subject: Reply with quote

Win4Lin works like a charm, but the kernel wont compile with both win4lin and swsusp2 in the kernel.

So Softwaresuspend has beenpurged from my kernel :(
Thnx to the dude who created the Win4Lin patch anyway :)
Back to top
View user's profile Send private message
Clent
n00b
n00b


Joined: 03 Nov 2004
Posts: 3

PostPosted: Thu Nov 04, 2004 4:32 pm    Post subject: Reply with quote

sibov wrote:

:?: Are you using vesafb / vesafb-tng :?:

sounds like framebuffer switching problem

:!: :!: If you are using ati radeon don't use the radeon fb in kernel :!: :!:


I just tried with vesafb, but it doesn't work either.
I'm going to try it without fb support...

edit : I've got the same problem without fb support :/
Back to top
View user's profile Send private message
pestilence
Apprentice
Apprentice


Joined: 05 Feb 2004
Posts: 213
Location: Athens / Greece

PostPosted: Thu Nov 04, 2004 6:40 pm    Post subject: Reply with quote

Please in a new release could you also include this fixes:
http://forums.gentoo.org/viewtopic.php?t=235398&highlight=
cdc_acm is broken in all the versions (at least for my modem, which is a common PTT provided modem).
After applying the patch everything works ok.
_________________
Gentoo the rising hope
Back to top
View user's profile Send private message
p-i
n00b
n00b


Joined: 20 Apr 2004
Posts: 8

PostPosted: Thu Nov 04, 2004 8:12 pm    Post subject: Reply with quote

Clent wrote:
I just tried with vesafb, but it doesn't work either.
I'm going to try it without fb support...

edit : I've got the same problem without fb support :/


I thought I was going insane since I couldn't get xorg working. Now at least I know I'm not alone :)

edit: not using FB did work for me, though.


Last edited by p-i on Sat Nov 06, 2004 2:40 am; edited 1 time in total
Back to top
View user's profile Send private message
enzobelmont
Guru
Guru


Joined: 06 Apr 2004
Posts: 345
Location: Chiapas, Mexico

PostPosted: Thu Nov 04, 2004 11:05 pm    Post subject: Reply with quote

ryceck wrote:
Win4Lin works like a charm, but the kernel wont compile with both win4lin and swsusp2 in the kernel.

So Softwaresuspend has beenpurged from my kernel :(
Thnx to the dude who created the Win4Lin patch anyway :)



there's a patch:

The patch-swsusp-win4lin patch allows you suspend whilst running Win4Lin.

it's on http://softwaresuspend.berlios.de/options.html

enjoy.

sorry my english... :wink:
Back to top
View user's profile Send private message
ryceck
Apprentice
Apprentice


Joined: 13 Jan 2004
Posts: 195

PostPosted: Thu Nov 04, 2004 11:15 pm    Post subject: Reply with quote

enzobelmont wrote:
ryceck wrote:
Win4Lin works like a charm, but the kernel wont compile with both win4lin and swsusp2 in the kernel.

So Softwaresuspend has beenpurged from my kernel :(
Thnx to the dude who created the Win4Lin patch anyway :)



there's a patch:

The patch-swsusp-win4lin patch allows you suspend whilst running Win4Lin.

it's on http://softwaresuspend.berlios.de/options.html

enjoy.

sorry my english... :wink:


Looks good but the problem is not that swsusp is not working... it just don't compile.
When I use nitro2 with Win4Lin patch only it compiles (and Win4Lin works), when I use nitro2 with swsusp-patch only it compiles (and hibernate works). When I use nitro2 with Win4Lin and swsusp-patch it doesnt compile :) (so nothing works)
Gonna look into that patch u gave me, but I think it will cause the same problem.
Thnx anyway
Back to top
View user's profile Send private message
jdkbx
n00b
n00b


Joined: 03 May 2004
Posts: 40

PostPosted: Thu Nov 04, 2004 11:16 pm    Post subject: Reply with quote

enzobelmont wrote:

there's a patch:

The patch-swsusp-win4lin patch allows you suspend whilst running Win4Lin.

it's on http://softwaresuspend.berlios.de/options.html

enjoy.

sorry my english... :wink:


nope, thats old stuff.

ryceck wrote:

Win4Lin works like a charm, but the kernel wont compile with both win4lin and swsusp2 in the kernel.

So Softwaresuspend has beenpurged from my kernel Sad
Thnx to the dude who created the Win4Lin patch anyway Smile


if u got the same problem i had, try suspend2.c from rc2. u find it on http://softwaresuspend.berlios.de/olddownloads.html
edit: could u post the error?
Back to top
View user's profile Send private message
frankjr
n00b
n00b


Joined: 13 Sep 2002
Posts: 55

PostPosted: Fri Nov 05, 2004 12:30 am    Post subject: Reply with quote

After upgrading from 2.6.8.1-nitro6 to 2.6.9-nitro2, the "less" utility quit working for me causing it to fail and return 1. Anyone else having this problem?
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2726
Location: Bay Area, CA

PostPosted: Fri Nov 05, 2004 1:31 am    Post subject: Reply with quote

seppe, does the gnome-settings-daemon die after resume in your setup? it gets killed on resume on two of my nitro2 installs.
Back to top
View user's profile Send private message
Apexman
Tux's lil' helper
Tux's lil' helper


Joined: 07 Apr 2004
Posts: 141

PostPosted: Fri Nov 05, 2004 5:27 am    Post subject: Reply with quote

charlieg wrote:
seppe: what about the bug fixes from the -ac patchset?

- LKML announcement
- Split out patches (to avoid overlapping with -ck, I think)

I just "adopted" -ac6 for nitro2 (well, simply cuted out some things :) ). So, output was:
Code:

patching file arch/i386/boot/video.S
Hunk #1 succeeded at 1944 (offset 8 lines).
Hunk #2 succeeded at 1953 (offset 8 lines).
patching file arch/x86_64/kernel/io_apic.c
patching file Documentation/i386/zero-page.txt
patching file drivers/char/agp/frontend.c
patching file drivers/char/drm/drm_vm.h
patching file drivers/char/moxa.c
patching file drivers/char/tty_io.c
patching file drivers/char/watchdog/i8xx_tco.c
patching file drivers/ide/ide.c
patching file drivers/ide/ide-disk.c
patching file drivers/ide/ide-iops.c
patching file drivers/ide/ide-pnp.c
patching file drivers/ide/ide-probe.c
patching file drivers/ide/ide-proc.c
patching file drivers/ide/ide-taskfile.c
patching file drivers/ide/Kconfig
patching file drivers/ide/legacy/ide-cs.c
patching file drivers/ide/pci/delkin_cb.c
patching file drivers/ide/pci/generic.c
patching file drivers/ide/pci/generic.h
patching file drivers/ide/pci/hpt366.c
patching file drivers/ide/pci/it8212.c
patching file drivers/ide/pci/Makefile
patching file drivers/ide/pci/pdc202xx_old.c
patching file drivers/ide/pci/trm290.c
patching file drivers/ide/setup-pci.c
patching file drivers/ieee1394/dma.c
patching file drivers/media/video/cpia.c
patching file drivers/media/video/meye.c
patching file drivers/media/video/planb.c
patching file drivers/media/video/zoran_driver.c
patching file drivers/media/video/zr36120.c
patching file drivers/net/Kconfig
patching file drivers/net/ppp_async.c
patching file drivers/net/ppp_synctty.c
patching file drivers/parport/parport_pc.c
patching file drivers/scsi/aic7xxx/aic79xx_core.c
patching file drivers/scsi/aic7xxx/aic79xx_osm.c
patching file drivers/scsi/aic7xxx/aic79xx_osm_pci.c
patching file drivers/scsi/aic7xxx/aic7xxx_core.c
patching file drivers/scsi/aic7xxx/aic7xxx_osm.c
patching file drivers/scsi/aic7xxx/aic7xxx_osm_pci.c
patching file drivers/scsi/nsp32.h
patching file drivers/usb/class/audio.c
patching file drivers/usb/media/Kconfig
patching file drivers/usb/media/Makefile
patching file drivers/usb/media/ov511.c
patching file drivers/usb/media/pwc/ChangeLog
patching file drivers/usb/media/pwc/Makefile
patching file drivers/usb/media/pwc/pwc-ctrl.c
patching file drivers/usb/media/pwc/pwc-dec1.c
patching file drivers/usb/media/pwc/pwc-dec1.h
patching file drivers/usb/media/pwc/pwc-dec23.c
patching file drivers/usb/media/pwc/pwc-dec23.h
patching file drivers/usb/media/pwc/pwc.h
patching file drivers/usb/media/pwc/pwc-if.c
patching file drivers/usb/media/pwc/pwc-ioctl.h
patching file drivers/usb/media/pwc/pwc-kiara.c
patching file drivers/usb/media/pwc/pwc-kiara.h
patching file drivers/usb/media/pwc/pwc-misc.c
patching file drivers/usb/media/pwc/pwc-nala.h
patching file drivers/usb/media/pwc/pwc-timon.c
patching file drivers/usb/media/pwc/pwc-timon.h
patching file drivers/usb/media/pwc/pwc-uncompress.c
patching file drivers/usb/media/pwc/pwc-uncompress.h
patching file drivers/usb/media/pwc/philips.txt
patching file drivers/usb/media/se401.c
patching file drivers/usb/media/sn9c102_core.c
patching file drivers/usb/media/stv680.c
patching file drivers/usb/media/usbvideo.c
patching file drivers/usb/media/vicam.c
patching file drivers/usb/media/w9968cf.c
patching file drivers/usb/serial/visor.c
patching file drivers/video/controlfb.c
patching file fs/smbfs/request.c
patching file include/asm-i386/setup.h
patching file include/asm-x86_64/acpi.h
patching file include/linux/ide.h
patching file include/linux/kernel.h
patching file include/linux/pci_ids.h
patching file net/core/skbuff.c
patching file net/packet/af_packet.c
patching file net/sunrpc/svcauth_unix.c
patching file sound/oss/ali5455.c
patching file sound/oss/au1000.c
patching file sound/oss/cmpci.c
patching file sound/oss/cs4281/cs4281m.c
patching file sound/oss/cs46xx.c
patching file sound/oss/es1370.c
patching file sound/oss/es1371.c
patching file sound/oss/esssolo1.c
patching file sound/oss/i810_audio.c
patching file sound/oss/ite8172.c
patching file sound/oss/maestro3.c
patching file sound/oss/maestro.c
patching file sound/oss/rme96xx.c
patching file sound/oss/sonicvibes.c
patching file sound/oss/trident.c
patching file sound/oss/ymfpci.c

Compiled cleanly for my config (nitro2 with swsusp2) and now running.
I don't have good web space for this 80 kb :( so if anybody cares, let me know, where to upload it...
Back to top
View user's profile Send private message
randomguy
n00b
n00b


Joined: 17 Oct 2004
Posts: 14

PostPosted: Fri Nov 05, 2004 6:33 am    Post subject: Reply with quote

Don't know if this is a known issue.

When I try to boot with nitro2 the process just stops at a random time...
It won't reach gdm.
Back to top
View user's profile Send private message
randomguy
n00b
n00b


Joined: 17 Oct 2004
Posts: 14

PostPosted: Fri Nov 05, 2004 5:32 pm    Post subject: Reply with quote

can anyone help me with this?
Back to top
View user's profile Send private message
sibov
Tux's lil' helper
Tux's lil' helper


Joined: 09 Feb 2004
Posts: 147
Location: Germany

PostPosted: Fri Nov 05, 2004 5:37 pm    Post subject: Reply with quote

Clent wrote:
sibov wrote:

:?: Are you using vesafb / vesafb-tng :?:

sounds like framebuffer switching problem

:!: :!: If you are using ati radeon don't use the radeon fb in kernel :!: :!:


I just tried with vesafb, but it doesn't work either.
I'm going to try it without fb support...

edit : I've got the same problem without fb support :/


ups i had this behaviour on my last recompile of nitro2.

framebuffer switch to xorg into a black screen.

My solution was to connect via ssh from an other system and to
reemerge me nvidia-kernel and a restart.

please make sure your symlink in /usr/src/linux --points-to->> linux-2.6.9-nitro2

:wink:
_________________
Gentoo 2.6.17-gentoo-r5 with dmraid Raid0 Dualboot
AMD64 X2 3800+, 4x512MB DDR PC3200Pro Corsair Geforce EN6600GT silencer @ 256MB
4x250GB SATAII Samsung SP120, Asus A8N Premium, Plextor PX712SA DVDRW
Logitech Dinovo, SB Audigy4
Back to top
View user's profile Send private message
teutzz
Guru
Guru


Joined: 22 Apr 2004
Posts: 333
Location: .ro

PostPosted: Fri Nov 05, 2004 5:48 pm    Post subject: Reply with quote

randomguy wrote:
Don't know if this is a known issue.

When I try to boot with nitro2 the process just stops at a random time...
It won't reach gdm.
do you have parallel start-up of services enabled?
_________________
Cand nu stii ce sa raspunzi sau ce sa spui un simplu BLA ajunge... lolz
Back to top
View user's profile Send private message
randomguy
n00b
n00b


Joined: 17 Oct 2004
Posts: 14

PostPosted: Fri Nov 05, 2004 5:54 pm    Post subject: Reply with quote

teutzz wrote:
randomguy wrote:
Don't know if this is a known issue.

When I try to boot with nitro2 the process just stops at a random time...
It won't reach gdm.
do you have parallel start-up of services enabled?


Yeah, how did you know?
Back to top
View user's profile Send private message
teutzz
Guru
Guru


Joined: 22 Apr 2004
Posts: 333
Location: .ro

PostPosted: Fri Nov 05, 2004 5:57 pm    Post subject: Reply with quote

randomguy wrote:
teutzz wrote:
randomguy wrote:
Don't know if this is a known issue.

When I try to boot with nitro2 the process just stops at a random time...
It won't reach gdm.
do you have parallel start-up of services enabled?


Yeah, how did you know?
quite a common error simpton when talking about staircase scheduler
_________________
Cand nu stii ce sa raspunzi sau ce sa spui un simplu BLA ajunge... lolz
Back to top
View user's profile Send private message
randomguy
n00b
n00b


Joined: 17 Oct 2004
Posts: 14

PostPosted: Fri Nov 05, 2004 6:18 pm    Post subject: Reply with quote

teutzz wrote:
randomguy wrote:
teutzz wrote:
randomguy wrote:
Don't know if this is a known issue.

When I try to boot with nitro2 the process just stops at a random time...
It won't reach gdm.
do you have parallel start-up of services enabled?


Yeah, how did you know?
quite a common error simpton when talking about staircase scheduler

Can you explain this a bit more?

So the solution is to shut it off...
Back to top
View user's profile Send private message
randomguy
n00b
n00b


Joined: 17 Oct 2004
Posts: 14

PostPosted: Fri Nov 05, 2004 7:41 pm    Post subject: Reply with quote

Changed that, now it gets stuck at "Calculating module dependencies"...

... help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8  Next
Page 6 of 8

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum