Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[howto] gDesklets 3.0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
3.1415
Apprentice
Apprentice


Joined: 29 Jan 2004
Posts: 199
Location: Stanford, CA, USA

PostPosted: Wed Nov 03, 2004 12:51 am    Post subject: [howto] gDesklets 3.0 Reply with quote

GDESKLETS 3.0 howto
par 3.14


Voici un petit howto pour passer a la version 3.0 de gdesklets, notamment pour les desktops sous autre chose que gnome (j'utilise fluxbox).

Note: ce howto a ete realise d'apres de nombreux threads sur les forums gentoo, aussi je remercie ceux qui ont poste sur le sujet.

Attention: certains desklets ne sont pas encore compatibles avec la version 3.0

Prologue

Code:
emerge sync


A/ Emerger les dernieres versions de pyorbit et de gnome-python

Pour cela, il faut utiliser des ebuilds modifies afin d'avoir les dernieres versions (respectivement 2.0.1 et 2.6.0):

1/ Ajouter PORTDIR_OVERLAY au make.conf

Code:
nano -w /etc/make.conf


Decommenter la ligne du PORTDIR_OVERLAY et mettre:

Code:
PORTDIR_OVERLAY="/usr/local/portage"


2/ Creer les dossiers necessaires

Code:

mkdir /usr/local/portage/dev-python/pyorbit
mkdir /usr/local/portage/dev-python/gnome-python


3/ Telecharger les ebuilds dans ces dossiers


pyorbit-2.0.1.ebuild

gnome-python-2.6.0.ebuild

4/ Generer les digest

Code:
cd /usr/local/portage/dev-pyhton/pyorbit
ebuild pyorbit-2.0.1.ebuild digest
cd ../gnome-python
ebuild gnome-python-2.6.0.ebuild digest


5/ Emerger pyorbit, puis gnome-python

Pour les utilisateurs de gnome, un simple emerge du package devrait suffire; pour les autres, un USE flag est necessaire.
Attention: bien emerger pyorbit avant gnome-python, sinon ca peut creer des problemes

Code:
emerge pyorbit
USE="gtkhtml" emerge gnome-python


B/ Re-emerger python

Juste au cas ou...

Code:
emerge python


C/ Unmerger les desklets installes

Code:
emerge unmerge desklets-*


D/ Installer la derniere version de gdesklets (3.0)

1/ Creer le dossier pour gdesklet dans l'arbre portage local

Code:
mkdir /usr/local/portage/gnome-extra/gdesklets-core


2/ Ebuild

Recuperer l'ebuild ici.
Creer le digest:

Code:
 cd /usr/local/portage/gnome-extra/gdesklets-core
ebuild gdesklets-core-3.0.ebuild digest


3/ Installation

Code:
emerge gdesklets-core


E/ Utilisation

Pour demarrer gdesklets:

Code:
gdesklets start


Pour ajouter un desklet, le mieux est de passer par le shell de gdesklet et d'indiquer ou se situe le fichier compresse contenant le desklet; sinon la commande suivante peut aussi passer:

Code:
gdesklets open <path>


F/ Desklets compatibles

Corner-XMMS
Clock

G/ Mises a jour

03/11/2004: installation utilisant l'ebuild pour gdesklets-core.3.0

Epilogue
N'hesitez pas a poster vos remarques (surtout sur les desklets compatibles), j'essaierai de tenir ce howto a jour.
Enjoy!
_________________
A 3.14% près...
3.14@jabber.aster.pl


Last edited by 3.1415 on Thu Nov 04, 2004 2:47 am; edited 2 times in total
Back to top
View user's profile Send private message
zdra
Veteran
Veteran


Joined: 30 Nov 2003
Posts: 1693
Location: Bruxelles, Belgique

PostPosted: Wed Nov 03, 2004 8:02 am    Post subject: Reply with quote

jolie :D

juste une question avant de me lancer dedans, la version 3.0 apporte vraiment des nouveautées ? beaucoup de bugfix ? Parce que pour l'instant j'utilises la version de portage et elle marche plutot bien pour les qq applets que j'aime... ça vaut donc la peine de faire toute ces manips ?

Merci !
Back to top
View user's profile Send private message
3.1415
Apprentice
Apprentice


Joined: 29 Jan 2004
Posts: 199
Location: Stanford, CA, USA

PostPosted: Wed Nov 03, 2004 10:28 am    Post subject: Reply with quote

hmm, l'avantage de la version 3.0 c le shell ki marche super bien: tu installes tes desklets depuis une interface sympa; je ne sais pas si ca existait avant

mais le gros hic c ke bcp de desklets ne sont pas compatibles avec le 3.0, en particulier la serie psi et les LT aussi il me semble (mais pour les psi ca ne saurait tarder me semble-t-il)

mais a mon dernier emerge -u world, gdesklets ne marchait plus et meme plusieurs downgrades n'y ont pu faire; du coup je suis passé au 3.0 (et en fait mes deux desklets preferes sont compatibles, donc no regrets - corner-xmms et clock)
_________________
A 3.14% près...
3.14@jabber.aster.pl
Back to top
View user's profile Send private message
UB|K
l33t
l33t


Joined: 27 May 2004
Posts: 786
Location: Villeurbanne, France

PostPosted: Wed Nov 03, 2004 3:37 pm    Post subject: Reply with quote

Merci beaucoup pour ce tuto, ça faisait qq temps que je luttais avec gdesklets mais sans succès.
J'ajouterais plusieures choses:
-il existe un ebuild pour gesklets-core-0.30 dans bugzilla: bug 60282 ce qui est quand meme plus propre que l'install que tu proposes
-certains psi marchent si on fait la manip suivante: il faut copier le répertoire "Themes" du packages PsiDisplays directement dans ~/.gdesklets et ça marche (pas pour tous: par exemple psiclock foire chez moi alors que clock-tout-court marche bien, Networkinfo s'affiche mais le sensor ne marche pas etc...)

Sinon le shell de ce nouveau gdesklet est pas mal du tout, il manque plus que le thumbnailer marche pour tout les displays et c'est le bonheur

Y a aussi une option "--translucent" pour gérer la transpence avec Xorg mais je vois pas trop ce que ça change: il y a toujours des ombres entre chaque display ce qui est pas joli du tout, donc xcompmgr et gdesklets ne font tjous pas bon ménage, dommage.

edit: diskinfo aime pas les partitions reiser4 et y a pas mal d'autres trucs qui marchent pas... va falloir attendre un peu pour que psidisplay marche vraiment avec la nouvelle version... du coup je comprend un peu mieux pourquoi tt ça n'est pas dans portage!!
Back to top
View user's profile Send private message
3.1415
Apprentice
Apprentice


Joined: 29 Jan 2004
Posts: 199
Location: Stanford, CA, USA

PostPosted: Thu Nov 04, 2004 2:49 am    Post subject: Reply with quote

merci pour l'ebuild ubik, il m'avait echappe celui-la: g mis a jour le howto en consequence (et du coup il perd en consistance! :wink:)

tu peux poster les desklets ke tu as essayes avec leur etat de fonctionnement stp?
_________________
A 3.14% près...
3.14@jabber.aster.pl
Back to top
View user's profile Send private message
Thom N2h
Apprentice
Apprentice


Joined: 03 Feb 2004
Posts: 161

PostPosted: Fri Nov 19, 2004 4:20 pm    Post subject: Reply with quote

au niveau des ebuilds que tu proposes, je pense que tu pourrais modifier les dépendances. Tu nous dis d'emerger les dernières version de gnomme-python etc, mais ton ebuild demande une version antérieur
Back to top
View user's profile Send private message
3.1415
Apprentice
Apprentice


Joined: 29 Jan 2004
Posts: 199
Location: Stanford, CA, USA

PostPosted: Sat Nov 20, 2004 4:11 am    Post subject: Reply with quote

Thom N2h wrote:
au niveau des ebuilds que tu proposes, je pense que tu pourrais modifier les dépendances. Tu nous dis d'emerger les dernières version de gnomme-python etc, mais ton ebuild demande une version antérieur


desole, ce howto n'a pas ete mis a jour ces deux dernieres semaines. disons que je suis bien occupe ces temps-ci. et c'est vrai que certains packages ont une nouvelle version maintenant.

maintenant, vu que tu sembles assez intelligent pour suggerer une modification, tu dois l'etre aussi assez pour te rendre compte que le post initial ne date pas d'hier.

le principe des ces forums, c'est la contribution et le partage. je ne te dois rien.

(comment ca? je l'ai mal pris?)
_________________
A 3.14% près...
3.14@jabber.aster.pl
Back to top
View user's profile Send private message
Thom N2h
Apprentice
Apprentice


Joined: 03 Feb 2004
Posts: 161

PostPosted: Sat Nov 20, 2004 3:31 pm    Post subject: Reply with quote

3.1415 wrote:

le principe des ces forums, c'est la contribution et le partage. je ne te dois rien.

(comment ca? je l'ai mal pris?)


Cool pas de soucis.
Le post est peut-être vieux. mais j'avais l'impression que tu proposais de nouvelles ebuilds mais sans avoir modifier correctement les dépendances. C'est juste ds le but d'améliorer ce post que je faisais cette remarque. Maintenant si tu n'as pas le temps de la modifier c'est pas grave, je peux comprendre
Back to top
View user's profile Send private message
Oni92
Apprentice
Apprentice


Joined: 01 Jun 2004
Posts: 247

PostPosted: Sat Nov 20, 2004 3:35 pm    Post subject: Reply with quote

Code:
USE="gtkhtml" emerge gnome-python

C'est pas trés propre cette façon de faire, je dirais :roll:
il faut plutôt faire :
Code:
echo "dev-python/gnome-python gtkhtml'>>/etc/portage/package.use
emerge gnome-python
Back to top
View user's profile Send private message
zdra
Veteran
Veteran


Joined: 30 Nov 2003
Posts: 1693
Location: Bruxelles, Belgique

PostPosted: Fri Jan 28, 2005 11:53 am    Post subject: Reply with quote

J'ai découvert l'option --translucent de gdesklets, pour mettre la vrai transparence si xcompmgr est lancé évidement ! ça marche partout où il y a de la transparence dans les desklets !!! magnifique !
Back to top
View user's profile Send private message
driden91
Apprentice
Apprentice


Joined: 26 Jul 2004
Posts: 232
Location: paris

PostPosted: Wed Jul 06, 2005 8:48 pm    Post subject: Reply with quote

je viens de recomiler mon systeme et gdesklets ne fonctionne plus... quelqu'un a une idée?
_________________
l'ange des tenebres vit la lumiere au fond de la nature humaine....
Back to top
View user's profile Send private message
LostControl
l33t
l33t


Joined: 02 Mar 2004
Posts: 885
Location: La Glane, Suisse

PostPosted: Wed Jul 06, 2005 8:50 pm    Post subject: Reply with quote

driden91 wrote:
je viens de recomiler mon systeme et gdesklets ne fonctionne plus... quelqu'un a une idée?

Je pense que tu trouveras tout ce qu'il te faut dans ce thread --> http://forums.gentoo.org/viewtopic-p-2539683.html

A+
_________________
http://www.jaqpot.net
http://www.fail2ban.org
Back to top
View user's profile Send private message
driden91
Apprentice
Apprentice


Joined: 26 Jul 2004
Posts: 232
Location: paris

PostPosted: Thu Jul 07, 2005 10:14 am    Post subject: Reply with quote

j'arrive maintenant a faire fonctionner certains desklets comme conerXmms, multi tail, Goodweather.... mais pas un seul concernant les infos du Systeme (ram,cpu,etat des disque,etc...) vous savez a quoi cela est du?
ma version de gdesklets est 0.33.1
_________________
l'ange des tenebres vit la lumiere au fond de la nature humaine....
Back to top
View user's profile Send private message
-KuRGaN-
Veteran
Veteran


Joined: 05 Dec 2004
Posts: 1142
Location: Besançon (25) [FRANCE]

PostPosted: Thu Jul 07, 2005 11:24 am    Post subject: Reply with quote

As-tu emerge desklets-psisensors et desklets-psiextras ???????
_________________
Knight Gent00 Industries RiDeR !!!!
Back to top
View user's profile Send private message
driden91
Apprentice
Apprentice


Joined: 26 Jul 2004
Posts: 232
Location: paris

PostPosted: Thu Jul 07, 2005 12:16 pm    Post subject: Reply with quote

-KuRGaN- wrote:
As-tu emerge desklets-psisensors et desklets-psiextras ???????


oui, je les ai recompiler pour être sur mais toujours la même chose... je lance le shell de gdesklets, je double clique sur "inkLevel Desklets" (que j'ai telecharger sur le site et installer avec le shell de gdesklets) et la j'ai une fenetre qui souvre et qui me di:
Code:
impossible de trouver le capteur "inklevel"
ceci signifie généralement qu'il n'a pas été installer

en dessous de ca ya une un bouton qui permet de voir les details que voici:
Code:
Traceback (most recent call last):
  File "/usr/local/lib/gdesklets/factory/SensorFactory.py", line 42, in create_sensor
    os.chdir(p)
OSError: [Errno 2] Aucun fichier ou répertoire de ce type: '/usr/local/lib/gdesklets/../../share/gdesklets/Sensors'

_________________
l'ange des tenebres vit la lumiere au fond de la nature humaine....
Back to top
View user's profile Send private message
-KuRGaN-
Veteran
Veteran


Joined: 05 Dec 2004
Posts: 1142
Location: Besançon (25) [FRANCE]

PostPosted: Thu Jul 07, 2005 12:24 pm    Post subject: Reply with quote

As tu bien regardé le lien de LostControl ??

Moi perso je ne jure que par la 0.32 après c'est comme tu le sens mais chez moi il n'y a que celle là qui fonctionne !!

Les autres versions me retournes des erreurs semblabes aux tiennes.
_________________
Knight Gent00 Industries RiDeR !!!!
Back to top
View user's profile Send private message
driden91
Apprentice
Apprentice


Joined: 26 Jul 2004
Posts: 232
Location: paris

PostPosted: Thu Jul 07, 2005 12:35 pm    Post subject: Reply with quote

ok j'essaye la version 0.32


bon ba le resultat est le même...
quel version as tu de gnome-python et de gtkhtml?
_________________
l'ange des tenebres vit la lumiere au fond de la nature humaine....
Back to top
View user's profile Send private message
-KuRGaN-
Veteran
Veteran


Joined: 05 Dec 2004
Posts: 1142
Location: Besançon (25) [FRANCE]

PostPosted: Thu Jul 07, 2005 2:10 pm    Post subject: Reply with quote

Je ne suis pas devant ma gentoo là mais je peux voir ça ce soir en rentrant.

Par contre as-tu essayé la solution de LostControl ds le lien qu'il t'a donné avec l'histoire du flag gtkhtml??
_________________
Knight Gent00 Industries RiDeR !!!!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum