Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
"emerge -u world"
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
cvk
Guru
Guru


Joined: 06 Jan 2003
Posts: 314
Location: Our house, in the middle of our street

PostPosted: Fri Jan 10, 2003 1:35 am    Post subject: Reply with quote

Hey I've got a new one: :)
Code:

localhost root # emerge -up world

These are the packages that I would merge, in order:

Calculating world dependencies |
!!! all ebuilds that could satisfy "virtual/xft" have been masked.
!!!    (dependency required by "x11-libs/pango-1.2.0" [ebuild])



What the heck is virtual/xft?

cvk
Back to top
View user's profile Send private message
aja
l33t
l33t


Joined: 26 Aug 2002
Posts: 705
Location: Edmonton, Canada

PostPosted: Fri Jan 10, 2003 1:47 am    Post subject: Reply with quote

I think it's the X FreeType library. But that is in x11-libs.

Better question: what the heck is virtual?
Back to top
View user's profile Send private message
zepar
Tux's lil' helper
Tux's lil' helper


Joined: 28 Jul 2002
Posts: 107

PostPosted: Fri Jan 10, 2003 3:04 am    Post subject: Reply with quote

I also having this problem:

Code:
localhost root # emerge -up world

These are the packages that I would merge, in order:

Calculating world dependencies |
!!! all ebuilds that could satisfy ">=media-libs/freetype-2.1.3-r2" have been masked.
!!!    (dependency required by "media-libs/fontconfig-2.1" [ebuild])
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7212
Location: Pelotas, BR

PostPosted: Fri Jan 10, 2003 3:13 am    Post subject: Reply with quote

There is a bug report that looks like the problem you people are having here. Could you go there and see if it is, and then contribute with more information?

I won't post there, as I am not suffering of it anymore and won't be able to help to solve it.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
zepar
Tux's lil' helper
Tux's lil' helper


Joined: 28 Jul 2002
Posts: 107

PostPosted: Fri Jan 10, 2003 4:17 am    Post subject: Reply with quote

i Hope they fix it

i could do ACCEPT_KEYWORDS="~x86" emerge -up world but i dont want unstable packages

Code:
localhost root # ACCEPT_KEYWORDS="~x86" emerge -up world

These are the packages that I would merge, in order:

Calculating world dependencies ...done!
[ebuild    U ] sys-devel/gettext-0.11.5-r1 [0.11.5-r0]
[ebuild    U ] sys-devel/gcc-3.2.1-r6 [3.2.1-r0]
[ebuild    U ] sys-apps/groff-1.18.1 [1.17.2-r3]
[ebuild    U ] sys-apps/man-1.5k-r1 [1.5k-r0]
[ebuild  N   ] sys-devel/libperl-5.8.0
[ebuild    U ] sys-devel/perl-5.8.0-r8 [5.6.1-r10]
[ebuild    U ] sys-devel/binutils-2.13.90.0.16-r1 [2.13.90.0.16-r0]
[ebuild    U ] sys-apps/baselayout-1.8.5.8 [1.8.5.5-r0]
[ebuild    U ] sys-libs/glibc-2.3.1-r3 [2.3.1-r2]
[ebuild    U ] sys-apps/netkit-base-0.17-r7 [0.17-r6]
[ebuild    U ] sys-apps/iptables-1.2.7a-r3 [1.2.7a-r2]
[ebuild    U ] sys-libs/readline-4.3-r4 [4.2a-r1]
[ebuild    U ] dev-libs/libxml2-2.4.28-r1 [2.4.24-r0]
[ebuild    U ] dev-libs/libxslt-1.0.22 [1.0.20-r0]
[ebuild    U ] sys-apps/findutils-4.1.7-r2 [4.1.7-r1]
[ebuild    U ] sys-apps/procps-3.1.5 [2.0.10-r1]
[ebuild    U ] dev-util/dialog-0.9_beta20020814 [0.9_beta20020519-r0]
[ebuild    U ] app-admin/gentoolkit-0.1.17-r9 [0.1.17-r7]
[ebuild    U ] media-libs/svgalib-1.9.17-r1 [1.4.3-r4]
[ebuild    U ] media-libs/libggi-2.0.1-r1 [2.0.1-r0]
[ebuild    U ] media-libs/libsdl-1.2.5 [1.2.4.20020601-r0]
[ebuild    U ] sys-devel/bin86-0.16.10 [0.15.5-r0]
[ebuild    U ] media-sound/mp3blaster-3.1.3 [3.1.1-r0]
[ebuild    U ] sys-apps/cpio-2.5 [2.4.2-r4]
[ebuild    U ] sys-libs/pam-0.75-r11 [0.75-r10]
[ebuild    U ] dev-libs/popt-1.7 [1.6.3-r0]
[ebuild    U ] dev-util/intltool-0.25 [0.22-r0]
[ebuild    U ] media-sound/xmms-1.2.7-r18 [1.2.7-r15]
[ebuild    U ] net-misc/dhcpcd-1.3.22_p4 [1.3.22_p3-r3]
[ebuild    U ] net-www/netscape-flash-6.0.69-r2 [6.0.69-r1]
[ebuild    U ] sys-apps/hdparm-5.3-r1 [5.2-r3]
[ebuild    U ] sys-devel/m4-1.4p-r1 [1.4p-r0]
[ebuild    U ] net-news/pan-0.13.3 [0.13.2-r0]
[ebuild    U ] dev-libs/openssl-0.9.6h [0.9.6g-r0]
[ebuild    U ] net-libs/linc-0.7.1 [0.5.5-r0]
[ebuild    U ] media-libs/libpng-1.2.5-r2 [1.2.5-r1]
[ebuild    U ] media-video/mplayer-0.90_rc2 [0.90_pre10-r0]
Back to top
View user's profile Send private message
zepar
Tux's lil' helper
Tux's lil' helper


Joined: 28 Jul 2002
Posts: 107

PostPosted: Fri Jan 10, 2003 5:58 am    Post subject: Reply with quote

I edited the freetype and fonconfig ebuild and changed the KEYWORDS="~x86" to KEYWORDS="x86"

Now it works:

Code:
localhost root # emerge -p world

These are the packages that I would merge, in order:

Calculating world dependencies ...done!
[ebuild    U ] sys-devel/binutils-2.13.90.0.16-r1 [2.13.90.0.16-r0]
[ebuild  N   ] sys-devel/libperl-5.8.0
[ebuild    U ] sys-devel/perl-5.8.0-r8 [5.6.1-r10]
[ebuild    U ] sys-apps/man-1.5k-r1 [1.5k-r0]
[ebuild    U ] media-libs/libsdl-1.2.5 [1.2.4.20020601-r0]
[ebuild    U ] sys-devel/gcc-3.2.1-r6 [3.2.1-r0]
[ebuild    U ] app-admin/gentoolkit-0.1.17-r9 [0.1.17-r7]
[ebuild    U ] sys-libs/pam-0.75-r11 [0.75-r10]
[ebuild    U ] net-www/netscape-flash-6.0.69-r2 [6.0.69-r1]
[ebuild    U ] net-news/pan-0.13.3 [0.13.2-r0]
Back to top
View user's profile Send private message
Qubax
Guru
Guru


Joined: 19 Jul 2002
Posts: 451
Location: Tirol, Austria

PostPosted: Fri Jan 10, 2003 8:43 am    Post subject: Reply with quote

do i misunderstand something? the problem is that there is a new ebuild that should be upgraded, but one of the dependences is masked, so its impossible to upgrade. so the only way to make it work is to unmask the masked dependency - equal to using unstable packages.
in my case (-u sylpheed-claws) i can either wait until pgpme-3.10 becomes stable, or "make" pgpme-3.10 stable.
Back to top
View user's profile Send private message
snakattak3
Guru
Guru


Joined: 11 Dec 2002
Posts: 468
Location: Seattle

PostPosted: Mon Jan 13, 2003 12:33 am    Post subject: Reply with quote

Quote:
I get this same thing:
%emerge world

These are the packages that I would merge, in order:

Calculating world dependencies /
!!! all ebuilds that could satisfy ">=sys-apps/groff-1.18" have been masked.
!!! (dependency required by "sys-apps/man-1.5k-r1" [ebuild])

I've tried to emerge portage 2.0.46, 2.0.47
and everything else in this thread,

Any suggestions? will this fix itself in some time?


I had this exact problem with man-1.5k-r1, and i also don't know what casues it. I did however add ACCEPT_KEYWORDS="~x86" to my make.conf as i was so graceously helped out http://forums.gentoo.org/viewtopic.php?t=29890here , and it seems to be a temporary fix for me, although i don't really like running unstable apps that much, especially the big ones (X glibc gcc and such). So now, i just weed out what upgrades i don't want when i upgrade. it takes way longer, but i still have my basic semi-stable system. I too hope this is fixed in the next portage/portage-tree. Good luck.
Back to top
View user's profile Send private message
zepar
Tux's lil' helper
Tux's lil' helper


Joined: 28 Jul 2002
Posts: 107

PostPosted: Mon Jan 13, 2003 4:02 am    Post subject: Reply with quote

did you read my posts??
Back to top
View user's profile Send private message
whitney
n00b
n00b


Joined: 14 Jan 2003
Posts: 1

PostPosted: Tue Jan 14, 2003 2:22 am    Post subject: Reply with quote

If one of the entries for the KEYWORDS in the suspect .ebuild file is "~x86" then the package is currently truley masked and should be emerged at ones own risk. I did have the other problem mentioned where "x86" not "~x86" was in the KEYWORDS varaible in the .ebuild which portage claimed was masked for me. "~alpha" was also in the ebuild. After fussing about I was able to get the package which depended on this to compile. I reccommed:

1) remove the ebuild file and emerge rsync
2) change any entries for KEYWORDS in the ebuild to non "~" which are not
"~x86" example: change "~sparc" to "sparc" if you're machine isn't a
sparc.
3) if "~x86" is not an entry for KEYWORDS in the ebuild, remove the entire
KEYWORDS line from the ebuild.
4) try adding the line
KEYWORDS="x86"
to your /etc/make.conf file
Back to top
View user's profile Send private message
hook
Veteran
Veteran


Joined: 23 Oct 2002
Posts: 1398
Location: Ljubljana, Slovenia

PostPosted: Wed Jan 15, 2003 1:47 pm    Post subject: Reply with quote

emerge portage did it ;) ...thx! ;)
_________________
tea+free software+law=hook

(deep inside i'm still a tux's little helper)
Back to top
View user's profile Send private message
tsigo
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jul 2002
Posts: 122

PostPosted: Mon Feb 17, 2003 11:15 pm    Post subject: Reply with quote

I'm getting this same thing. Did emerge rsync several times and re-emerged portage, still not working.

Code:

emerge world -up

These are the packages that I would merge, in order:

Calculating world dependencies |

aux_get(): (1) couldn't open cache entry for sys-devel/gcc-3.2-r5
               Check for syntax error or corruption in the ebuild.


!!! all ebuilds that could satisfy ">=sys-devel/gcc-3.2-r1" have been masked.
!!!    (dependency required by "sys-libs/glibc-2.3.1-r3" [ebuild])


I've tried ACCEPT_KEYWORDS="~x86" and ACCEPT_KEYWORDS="x86" and neither seemed to make a difference.
Back to top
View user's profile Send private message
ebrostig
Bodhisattva
Bodhisattva


Joined: 20 Jul 2002
Posts: 3152
Location: Orlando, Fl

PostPosted: Tue Feb 18, 2003 1:37 am    Post subject: Reply with quote

Which version portage are you running?

I had no problems on my machine.
Code:

emerge -V portage
Portage 2.0.46-r12 (default-x86-1.4, gcc-3.2.2, glibc-2.3.1-r3)


Maybe it is a portage problem?

Erik
_________________
'Yes, Firefox is indeed greater than women. Can women block pops up for you? No. Can Firefox show you naked women? Yes.'
Back to top
View user's profile Send private message
tsigo
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jul 2002
Posts: 122

PostPosted: Tue Feb 18, 2003 6:52 pm    Post subject: Reply with quote

Code:

emerge -V portage
Portage 2.0.46-r12 (default-x86-1.4, gcc-3.2.1, glibc-2.3.1-r2)
Back to top
View user's profile Send private message
ebrostig
Bodhisattva
Bodhisattva


Joined: 20 Jul 2002
Posts: 3152
Location: Orlando, Fl

PostPosted: Tue Feb 18, 2003 9:51 pm    Post subject: Reply with quote

It seems like you are trying to emerge gcc 3.2-r5 which is an old version.

Try to do: emerge -up gcc and see which version it suggests. If it still comes back with the same, try:
emerge /usr/portage/sys-devel/gcc/gcc-3.2.2.ebuild

Erik
_________________
'Yes, Firefox is indeed greater than women. Can women block pops up for you? No. Can Firefox show you naked women? Yes.'
Back to top
View user's profile Send private message
tsigo
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jul 2002
Posts: 122

PostPosted: Wed Feb 19, 2003 12:12 am    Post subject: Reply with quote

Ok it's fixed. I had to manually emerge the latest binutils and then gcc
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum