Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with label [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Wed Oct 13, 2004 4:31 pm    Post subject: Problem with label [SOLVED] Reply with quote

i'm relly new to sparc..
i was trying to install gentoo on ultra5 machine.

I forgot to create a Label on my disk :S

I though i could create it in a second time... but i was wrong..(or not?)

I'm trying with fdsik - option s

When i try to do autoconfigure it simply doesn't work.
So i take "custom" and accept default (mmm)

When a issue a "p" command i see the label...

When a i save "wq" and exit from fdisk...it seems that i loose the label..

What i'm doing wrong?
I read FAQ and Install but i didn't solve.

Can you point me to other docs?
Thank you very much
_________________
while True:Gentoo()


Last edited by xchris on Thu Oct 14, 2004 10:12 am; edited 1 time in total
Back to top
View user's profile Send private message
rkrenzis
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2004
Posts: 135
Location: USA

PostPosted: Wed Oct 13, 2004 4:40 pm    Post subject: Wrong command on save... Reply with quote

Try just using "w" to save and exit.
The "q" command is to exit without saving changes.
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Wed Oct 13, 2004 4:56 pm    Post subject: Reply with quote

I don't think so :)

i always did wq! 8O
it means write and quit!
am i wrong?
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
rkrenzis
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2004
Posts: 135
Location: USA

PostPosted: Wed Oct 13, 2004 5:01 pm    Post subject: Let's see... Reply with quote

Carefully I used fdisk on /dev/hda on my system:

These are the options:

Code:
fdisk /dev/hda

The number of cylinders for this disk is set to 4865.
There is nothing wrong with that, but this is larger than 1024,
and could in certain setups cause problems with:
1) software that runs at boot time (e.g., old versions of LILO)
2) booting and partitioning software from other OSs
   (e.g., DOS FDISK, OS/2 FDISK)

Command (m for help): m
Command action
   a   toggle a bootable flag
   b   edit bsd disklabel
   c   toggle the dos compatibility flag
   d   delete a partition
   l   list known partition types
   m   print this menu
   n   add a new partition
   o   create a new empty DOS partition table
   p   print the partition table
   q   quit without saving changes
   s   create a new empty Sun disklabel
   t   change a partition's system id
   u   change display/entry units
   v   verify the partition table
   w   write table to disk and exit
   x   extra functionality (experts only)

Command (m for help): q


You must be thinking of "vi" 8)
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Wed Oct 13, 2004 5:05 pm    Post subject: Reply with quote

yeah
i used too much vi :)

anyway..
i always used wq! and it did work.

I tried now on my ultra5... same effect [w|wq]

bye :)
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
rkrenzis
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2004
Posts: 135
Location: USA

PostPosted: Wed Oct 13, 2004 5:21 pm    Post subject: I can try it on my Ultra 5... Reply with quote

I have an Ultra 5 that needs a refresh of gentoo. The filesystems got fuxed due to a power outage and I was doing heavy i/o. I'll fdisk my system tonight and let you know if I have the same problems.

Are using 2004.2 to do your install?
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Wed Oct 13, 2004 6:35 pm    Post subject: Reply with quote

yes.. :)

does the fact that i forgot to "label" when partioning the first time,mean anything?

Thank you :)
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
rkrenzis
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2004
Posts: 135
Location: USA

PostPosted: Wed Oct 13, 2004 7:06 pm    Post subject: Installing... Reply with quote

:lol: Let me guess. You're installing gentoo now or the very confused Windo$fish 3.11. Or Better yet SCOlinux :twisted:
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Wed Oct 13, 2004 8:10 pm    Post subject: Reply with quote

?
didn't understand :)
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Thu Oct 14, 2004 10:12 am    Post subject: Reply with quote

i solved..
i re-did a fdisk from scratch...
first - disk label

and then others..
and now everything works!
i will spend so much time with org...zzzzz

thank you!
bye
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
rkrenzis
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2004
Posts: 135
Location: USA

PostPosted: Thu Oct 14, 2004 1:16 pm    Post subject: ZZZZZZZ.... oh yeah! Reply with quote

ZZZZZZZZZZZZZZ.....oh, yeah. Cool.

Now back to my ZZZZZZZZZZZZZZZZZZZZZZZZZZZZ ;-)

Good night.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum