Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[TOOL] Unclepine [VECCHIO THREAD]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2, 3 ... 11, 12, 13 ... 18, 19, 20  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools)
View previous topic :: View next topic  
Author Message
Cazzantonio
Bodhisattva
Bodhisattva


Joined: 20 Mar 2004
Posts: 4477
Location: In giro

PostPosted: Mon Oct 11, 2004 5:16 pm    Post subject: Reply with quote

Non ho trovato nessun bug :D (nemmeno di quelli creati dalla mia idiozia... :oops:, scusa ancora per il tempo che ti ho fatto perdere per la cavolata dell'altra volta)
Per fare delle prove sto togliendo la roba che necessita di aggiornamenti con -du2 (e poi la rimetto in world per farla aggiornare da emerge). Non ho riscontrato ancora nessun problema :D
che cosa manca ancora ad unclepine per diventare stabile?

xcris wrote:

sarebbe anche carino avere qualche nuova idea di disinstallazione...
..intendo qualche nuova funzionalita'...

Beh... un'idea potrebbe essere quella di unirlo ad alri programmi del gekit dediti alla raccolta di informazioni (tipo usetool) per creare un tool unico, oppure di dargli le altre funzionalità di qpkg per eliminare quest'ultimo del tutto... però dipende dal tempo che hai a disposizione, dalla voglia e dai gusti (io sono un fan dei tool unificati, altri invece preferiscono tool ben separati e distinti...)
_________________
Any man's death diminishes me, because I am involved in mankind, and therefore never send to know for whom the bell tolls; it tolls for thee
-John Donne
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Mon Oct 11, 2004 9:52 pm    Post subject: Reply with quote

Cazzantonio wrote:
Non ho trovato nessun bug :D (nemmeno di quelli creati dalla mia idiozia... :oops:, scusa ancora per il tempo che ti ho fatto perdere per la cavolata dell'altra volta)


no problem :)
l'importante e' aver capito che lo zio stava lavorando bene ;)
cmq il bug l'ho trovato io :)

Cazzantonio wrote:

che cosa manca ancora ad unclepine per diventare stabile?


molto testing :)
anche se credo non sara' mai definito stabile.
Sarebbe troppo pretezioso ;)
Cazzantonio wrote:

xchris wrote:

sarebbe anche carino avere qualche nuova idea di disinstallazione...
..intendo qualche nuova funzionalita'...

Beh... un'idea potrebbe essere quella di unirlo ad alri programmi del gekit dediti alla raccolta di informazioni (tipo usetool) per creare un tool unico, oppure di dargli le altre funzionalità di qpkg per eliminare quest'ultimo del tutto... però dipende dal tempo che hai a disposizione, dalla voglia e dai gusti (io sono un fan dei tool unificati, altri invece preferiscono tool ben separati e distinti...)


non sono molto d'accordo.
Meglio + tool separati.
(+ semplici da gestire,da programmare da usare)

magari mi riguardo qpkg e le sue funzioni e vedo quali potrei implementare. (se ne vale la pena)

Dicevo prima che ho trovato un baco.
Non e' nelle routine..quindi non aggiorno subito.
Puo' capitare con pacchetti che hanno dipendenze circolari.
Ad es gaim! -du2 non funziona... (a meno di non usarlo cosi':unclepine -du2 gaim -m)
Ci sono alcune parti delle routine ancora da ottimizzare....

Decisamente lontana da una stable :)
grazie cmq per il feedback ;)
ciao
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Tue Oct 12, 2004 9:54 am    Post subject: Reply with quote

rilasciata alpha9

- ottimizzato il codice
- rimosse vecchie routine per -du,-u (ora -du2,-u2 non esistono +)
- migliorata la routine di -du


Probabilmente quest'ultima modifica permettera' di rilevare pacchetti non rilevabili con la vecchia.

Supponiamo una sessione di esempio.
Voglio togliere gaim (e' una brutta bestia perche' ha delle dipendenze circolari)

quindi per primo farei...

Code:

unclepine -du gaim -su


Analyzing....Please Wait
If you feel bored launch it with -v switch!


!!! We cannot simulate removal!!
!!! No undependent packages found in your choiches!


mannaggia :)

vediamo chi lo blocca...

Code:

unclepine -db gaim -su

Analyzing....Please Wait
If you feel bored launch it with -v switch!


net-im/gaim-1.0.0
NEEDED BY:
        * x11-plugins/gaim-encryption-2.31
        * WORLD FILE


Ora...a questo punto... intuiamo che "gaim-encryption" fa parte di gaim..
Potremmo da subito dirgli di rimuovere entrambi....ma non ci fidiamo...
Vediamo da chi dipende gaim-encryption

Code:

unclepine -du gaim-encryption -su

Analyzing....Please Wait
If you feel bored launch it with -v switch!


x11-plugins/gaim-encryption-2.31
NEEDED BY:
        * net-im/gaim-1.0.0


ma guarda che simpatico :)
una bella dipendenza circolare..

A questo punto...con la vecchia versione non c'era modo di procedere se non con l'opzione -m (manual) e dicendo di non usare il file PDEPEND.
Posso comprendere che non sia una cosa semplice...alla portata di chiunque.

La nuova versione pero'...
Facendo:

Code:

unclepine -du gaim gaim-encryption

Analyzing....Please Wait
If you feel bored launch it with -v switch!


Packages that can be removed: 6

        * app-text/enchant-1.1.3
        * app-text/gtkspell-2.0.4-r1
        * dev-libs/nspr-4.4.1
        * dev-libs/nss-3.8
        * net-im/gaim-1.0.0
        * x11-plugins/gaim-encryption-2.31



ottimo :)

a dire il vero potevamo anche usare l'opzione -r per vedere subito che c'era una dipendenza circolare..ma forse questo approccio e' + semplice.

spero vi gusti!
ciao

EDIT:per chi ha kde...ed e' stanco di usarlo..(non io) provi a fare
Code:

unclepine -db kdelibs -x | xargs unclepine -du

_________________
while True:Gentoo()
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Tue Oct 12, 2004 10:12 am    Post subject: Reply with quote

pensavo di implementare questa routine "pericolosa"...

liberami questa dipendenza...(funziona come l'esempio sopra di kde)

se io voglio liberare un pacchetto....cosa devo togliere?

che ne pensate?
Oppure la lasciamo cosi' com'e'....volendo con un pipe si ottiene..
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 13200
Location: here

PostPosted: Tue Oct 12, 2004 10:50 am    Post subject: Reply with quote

Beh mettila che la testiamo poi vediamo :)
_________________
"aspetto un'emozione sempre più indefinibile"
- CCCP -
"la libertà un doveroso pericolo in verità"
- PGR -
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Tue Oct 12, 2004 12:30 pm    Post subject: Reply with quote

uhm...
ho cambiato idea...
e' + difficile comprendere come usarla che altro.

meglio lasciare il tool con poche e chiare opzioni. (che' gia' non e' del tutto semplice)
ciao
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
=DvD=
Veteran
Veteran


Joined: 25 Mar 2004
Posts: 1338
Location: ITALY between Pisa and Versilia

PostPosted: Tue Oct 12, 2004 12:51 pm    Post subject: Reply with quote

-u non mi va... rimuoverebbe metà sistema..
da ooo a blackdown a partire da xfce...

confesso che non ho letto tutte le 10 pagine di post precedente!
Ma non mi sembra normale sta cosa...
_________________
Guida per i nuovi arrivati a.k.a. Potresti avere la risposta tra le mani


Last edited by =DvD= on Tue Oct 12, 2004 1:39 pm; edited 1 time in total
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Tue Oct 12, 2004 12:55 pm    Post subject: Reply with quote

se vuole rimuoverti mezzo sistema significa che non tutti i pkt sono correttamente installati/gestiti.

Se ti vuole rimuove oofice significa che non e' nel world file..
Fai un paio di controlli.

Probabilmente anche un emerge -p --depclean ti da risultati simili...

Unclepine funziona "abbastanza" bene se la gentoo e' ben amministrata.
Non dovesse essere il tuo caso... potrebbe trattarsi di un bug.. ma mi sembra strano...uno di questa entita' (cmq nulla e' mai certo)

magari posta l'output,e il tuo world

ciao
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
=DvD=
Veteran
Veteran


Joined: 25 Mar 2004
Posts: 1338
Location: ITALY between Pisa and Versilia

PostPosted: Tue Oct 12, 2004 1:18 pm    Post subject: Reply with quote

trovato!
ho portage .51 e unclepine mi andava a leggere il vecchio world.
Ho rinominato il vecchio (non si sa mai) e poi creato un link virtuale in /var/cache/edb/world che punta a /var/lib/portage/world

nonostante questo ancora mi elenca cose che penso servano, tipo arts e kdelibs
_________________
Guida per i nuovi arrivati a.k.a. Potresti avere la risposta tra le mani
Back to top
View user's profile Send private message
=DvD=
Veteran
Veteran


Joined: 25 Mar 2004
Posts: 1338
Location: ITALY between Pisa and Versilia

PostPosted: Tue Oct 12, 2004 1:26 pm    Post subject: Reply with quote

Capito!!
Niente di che, una volta che ha letto il giusto file world mi vuole togliere cose che probabilmente è giusto che tolga!!
Adesso unmergo, mi fido, e se riesco a risponderti è andato tutto bene.
Arts e kdelibs erano di kde 3.2, ora ho il 3.3
(ma uso xfce... ci sta che faccio la provona)
Sono un po suonato!

Magari metti un check per vedere se esiste /var/lib/portage/world e se c'è usare quello, e non il contrario...
Se uno ha il nuovo world è probabile abbia anchora il vecchio nell'altra cartella!

Unmergo!
_________________
Guida per i nuovi arrivati a.k.a. Potresti avere la risposta tra le mani
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Tue Oct 12, 2004 1:39 pm    Post subject: Reply with quote

ahem...stai attento!!!
NON MI ASSUMO ALCUNA RESPONSABILITA'!!!!

in teoria il check che dici non serve perche' portage automaticamente symlinka un solo file...non ne lascia 2.(a quanto ne so io)

Per le prime volte usa anche lo switch -su !!!

mmm mi sa che sei un po' frettoloso :)
occhio!

EDIT:nella next release andro' a vedere prima in /var/lib/...
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
=DvD=
Veteran
Veteran


Joined: 25 Mar 2004
Posts: 1338
Location: ITALY between Pisa and Versilia

PostPosted: Tue Oct 12, 2004 1:55 pm    Post subject: Reply with quote

a me non l'ha tolto... ho dovuto fare io il link, come ho detto sopra.
Non ti preoccupare per la fretta, le cose che tolgo non sono fondamentali, e poi un tester deve essere un po matto, altrimenti che tester è?
Pensa a quelli che testano i nuovi aerei... lol

edit: le cose che pensavo non dovesse togliere erano in slot diversi, lui toglie le versioni vecchie non piu necessarie, si comporta bene!!
_________________
Guida per i nuovi arrivati a.k.a. Potresti avere la risposta tra le mani
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Tue Oct 12, 2004 1:56 pm    Post subject: Reply with quote

bhe in quest'ottica allora va bene :D
grazie per i test ;)

ho gia' corretto per il world file.
Appena faccio altre correzioni la rendo disponibile.
Grazie


ciao
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
=DvD=
Veteran
Veteran


Joined: 25 Mar 2004
Posts: 1338
Location: ITALY between Pisa and Versilia

PostPosted: Tue Oct 12, 2004 2:33 pm    Post subject: Reply with quote

Code:
!!! Error in dependencies files :~dev-libs/libcdio-0.64:

!!! Error in dependencies files :~dev-libs/libcdio-0.64:

!!! Cannot continue with corrupted /var/db/pkg

Try: emerge --oneshot =media-video/vcdimager-0.7.19


e ora? ho riemerso libcdio e vcdimager ...
_________________
Guida per i nuovi arrivati a.k.a. Potresti avere la risposta tra le mani
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Tue Oct 12, 2004 2:37 pm    Post subject: Reply with quote

prima di tutto...
c'e' un piccolo bug..

vcdimager non e' colpevole :)
pero' libcdio si!!

prova a postare i file [P|R]DEPEND

ciao

EDIT:spe'...sono fuso...ora ci penso..
contrordine :)

posta i file di vcdimager...scusa per il casino
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
=DvD=
Veteran
Veteran


Joined: 25 Mar 2004
Posts: 1338
Location: ITALY between Pisa and Versilia

PostPosted: Tue Oct 12, 2004 2:49 pm    Post subject: Reply with quote

cosa intendi con i file di vcdimager?

Prima che succedesse questo ho solo unmerso varie versioni di kernel dalla 2.6.5 per intenderci, delle quali, stupidamente invece che unmergerle cancellavo solo le cartelle in /usr/src/kernel-versione .
Quindi unmergendo non trovava i files, ma non mi pare si fosse arrabbiato più di troppo emerge...
_________________
Guida per i nuovi arrivati a.k.a. Potresti avere la risposta tra le mani
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Tue Oct 12, 2004 2:55 pm    Post subject: Reply with quote

si non dovrebbe essere importante..
attacca icq che facciamo prima...se vuoi.
ciao
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
=DvD=
Veteran
Veteran


Joined: 25 Mar 2004
Posts: 1338
Location: ITALY between Pisa and Versilia

PostPosted: Tue Oct 12, 2004 3:01 pm    Post subject: Reply with quote

roger!

edit:
Pare fosse un problema di emerge e ziopino che non devono essere lanciati contemporaneamente.
Io avevo un emerge -uD world in un altro terminale, quando ha finito l'errore se ne è andato...

Cmq non è sicuro...
_________________
Guida per i nuovi arrivati a.k.a. Potresti avere la risposta tra le mani
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Tue Oct 12, 2004 4:27 pm    Post subject: Reply with quote

già
in fatti è anomala come situazione.
Purtroppo non siamo riusciti a simularla nuovamente.
Direi che cmq non è un problema grave..

da un "chiacchiera" con =DvD= sono partiti 2 nuovi switch

--show-virtuals (soprattutto per portage nuovo o per vedere se il proprio file del vecchio è corrotto)
--show-world (e mostrerà anche quali voci non sono strettamente necessarie)

ciao
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
=DvD=
Veteran
Veteran


Joined: 25 Mar 2004
Posts: 1338
Location: ITALY between Pisa and Versilia

PostPosted: Tue Oct 12, 2004 8:41 pm    Post subject: Reply with quote

Se emergo OOo-bin mi installa app-crypt/gpgme-0.4.0 e dev-java/blackdown-jdk-1.4.1

Però poi unclepine vuole rimuovermeli.q

Deve essere questa riga quà che gli da noia.
DEPEND nell'ebuilt wrote:
|| ( >=virtual/jdk-1.3.1 >=virtual/jre-1.3.1 )


probabilmente è un problema coi virtuals.
Mentre il gpgme è una dipendenza lontana di kdenetwork (o kmail) se non sbaglio, che è dipendenza di OOo anche lui.

Ora provo fixvirtuals, o come di chiama
_________________
Guida per i nuovi arrivati a.k.a. Potresti avere la risposta tra le mani
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Wed Oct 13, 2004 7:33 am    Post subject: Reply with quote

Le dipendenze in OR rimangono l'unica spina nel fianco di unclepine.
Cmq e' stato progettato per essere conservativo...

Quindi...riassumiamo..
tu installi ooffice..bin
lanci -u e ti rimuove pacchetti necessari?

Io non vedo pero' le dipendenze di gpgme in ooffice...
Mi spieghi meglio? :)
grazie

Chris
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
=DvD=
Veteran
Veteran


Joined: 25 Mar 2004
Posts: 1338
Location: ITALY between Pisa and Versilia

PostPosted: Wed Oct 13, 2004 8:13 am    Post subject: Reply with quote

gpgme è una dipendenza di una dipendenza di una dipndenza di una dipendenza di una dipendenza di OOo. ;)
_________________
Guida per i nuovi arrivati a.k.a. Potresti avere la risposta tra le mani
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Wed Oct 13, 2004 8:33 am    Post subject: Reply with quote

saresti cosi' gentile da dirmi le varie dipendenze? :)
ciao
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
Cazzantonio
Bodhisattva
Bodhisattva


Joined: 20 Mar 2004
Posts: 4477
Location: In giro

PostPosted: Wed Oct 13, 2004 12:42 pm    Post subject: Reply with quote

=DvD= wrote:
Se emergo OOo-bin mi installa app-crypt/gpgme-0.4.0 e dev-java/blackdown-jdk-1.4.1

Però poi unclepine vuole rimuovermeli.q


Anche a me cercava di rimuovermi blackdown, siccome però era una cosa che avevo installato diverso tempo addietro, che non risultava dipendenza di niente ne' con unclepine -db n' con qpkg -q, ho semplicemente deciso di metterlo in world pensando che fosse un bug dell'ebuild di blackdown piuttosto che uno di unclepine
Oppure pensavo fosse stato installato come dipendenza di un vecchio pacchetto che nel frattempo se ne era andato
In fondo openoffice dovrebbe funzionare anche senza blackdown no?
_________________
Any man's death diminishes me, because I am involved in mankind, and therefore never send to know for whom the bell tolls; it tolls for thee
-John Donne
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Wed Oct 13, 2004 2:42 pm    Post subject: Reply with quote

per jdk...
ho riguardato meglio..

Bug!! tenchiu!!
appena ho tempo vedo di risolvere..
ciao
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools) All times are GMT
Goto page Previous  1, 2, 3 ... 11, 12, 13 ... 18, 19, 20  Next
Page 12 of 20

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum