Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Svenska tecken
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
jaghetertoffe
Tux's lil' helper
Tux's lil' helper


Joined: 06 Mar 2004
Posts: 92

PostPosted: Wed Sep 22, 2004 6:22 pm    Post subject: Svenska tecken Reply with quote

Detta börjar väl bli tjatigt, jag har sett många liknande postningar, men: åäö funkar inte med vissa program!

Code:
export LC_ALL=sv_SE


har jag sist i .bashrc.

Java kan inte skriva åäö och när man startar vissa program skriver de ut
felmeddelanden:

Code:
$ xmms&
[1] 5686
Gdk-WARNING **: locale not supported by C library



Här är min 02locale:


Code:
$ cat /etc/env.d/02locale
LC_ALL="sv_SE"
LC_TELEPHONE="sv_SE"
LANG="sv_SE"
LC_CTYPE="sv_SE"
LC_NUMERIC="sv_SE"
LC_TIME="sv_SE"
LC_MONETARY="sv_SE"
LC_ADDRESS="sv_SE"
LC_COLLATE="sv_SE"
LC_NAME="sv_SE"
LC_PAPER="sv_SE"
LC_NUMERIC="sv_SE"
SYSFONT="lat0-16"
LC_MEASUREMENT="sv_SE"
LC_MESSAGES="C"
LC_IDENTIFICATION="sv_SE"


Uppenbarligen är något fel:

Code:
#locale charmap
locale: Cannot set LC_CTYPE to default locale. Nu such file or directory
locale: Cannot set LC_MESSAGES to default locale. Nu such file or directory
locale: Cannot set LC_ALL to default locale. Nu such file or directory
ANSI_X3.4-1968


Någon som vet vad som är fel?
Jag skulle verkligen behöva åäö nu.

-toffe
Back to top
View user's profile Send private message
jaghetertoffe
Tux's lil' helper
Tux's lil' helper


Joined: 06 Mar 2004
Posts: 92

PostPosted: Thu Sep 23, 2004 2:20 pm    Post subject: Reply with quote

Någon?
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4835
Location: Gothenburg, Sweden

PostPosted: Thu Sep 23, 2004 3:15 pm    Post subject: Reply with quote

Har du /usr/share/i18n/locales/sv_SE?
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
jaghetertoffe
Tux's lil' helper
Tux's lil' helper


Joined: 06 Mar 2004
Posts: 92

PostPosted: Thu Sep 23, 2004 4:15 pm    Post subject: Reply with quote

Japp, den har jag
Back to top
View user's profile Send private message
jaghetertoffe
Tux's lil' helper
Tux's lil' helper


Joined: 06 Mar 2004
Posts: 92

PostPosted: Sat Sep 25, 2004 2:20 pm    Post subject: Reply with quote

inga andra förslag?
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4835
Location: Gothenburg, Sweden

PostPosted: Sun Sep 26, 2004 9:16 am    Post subject: Reply with quote

Om du bara kör locale? Vilken output?
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
jaghetertoffe
Tux's lil' helper
Tux's lil' helper


Joined: 06 Mar 2004
Posts: 92

PostPosted: Sun Sep 26, 2004 9:51 am    Post subject: Reply with quote

Då blir det såhär:

Code:
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=sv_SE
LC_CTYPE="sv_SE"
LC_NUMERIC="sv_SE"
LC_TIME="sv_SE"
LC_COLLATE="sv_SE"
LC_MONETARY="sv_SE"
LC_MESSAGES="sv_SE"
LC_PAPER="sv_SE"
LC_NAME="sv_SE"
LC_ADDRESS="sv_SE"
LC_TELEPHONE="sv_SE"
LC_MEASUREMENT="sv_SE"
LC_IDENTIFICATION="sv_SE"
LC_ALL=sv_SE
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4835
Location: Gothenburg, Sweden

PostPosted: Sun Sep 26, 2004 11:31 am    Post subject: Reply with quote

Det verkar som att din 02locale i läses, eller snarare att din definition id .bashrc tar över. Testa att ta bort export LC_ALL från din .bashrc. Kommentera även bort LC_ALL från 02locale. Kör sedan
Code:
env-update
source /etc/profile
locale

_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
jaghetertoffe
Tux's lil' helper
Tux's lil' helper


Joined: 06 Mar 2004
Posts: 92

PostPosted: Sun Sep 26, 2004 7:31 pm    Post subject: Reply with quote

Precis samma svar som innan.
Även efter omstart.
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4835
Location: Gothenburg, Sweden

PostPosted: Sun Sep 26, 2004 7:50 pm    Post subject: Reply with quote

Skumt, du borde ju fått LC_MESSAGES=C enligt den 02locale du postat ovan. De värden som är inom citationstecken enligt locale kommandot är ärvda, eller default, vilken inte heller verkar stämma med din 02locale då den har definitioner för allt. Testa med
Code:
equery check glibc

om din glibc är OK (kräver gentoolkit).
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
jaghetertoffe
Tux's lil' helper
Tux's lil' helper


Joined: 06 Mar 2004
Posts: 92

PostPosted: Sun Sep 26, 2004 8:01 pm    Post subject: Reply with quote

Code:
#equery check glibc
#


Jag vet inte vad som borde hända om jag kör ovanstående, men programmet terminerar utan output.
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4835
Location: Gothenburg, Sweden

PostPosted: Sun Sep 26, 2004 8:07 pm    Post subject: Reply with quote

Den säger bara till om något inte stämmer överens med det som installerades. Vet tyvärr inte vad som kan vara fel. Har du testat att byta till någon annan locale, bara för att se att den biten funkar?
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
jaghetertoffe
Tux's lil' helper
Tux's lil' helper


Joined: 06 Mar 2004
Posts: 92

PostPosted: Thu Sep 30, 2004 3:10 pm    Post subject: Reply with quote

Jag har varit bortrest, så har inte kunnat testa att byta locale förrän nu...

Jag ändrade så min /etc/env.d/02locale är

Code:
LC_TELEPHONE="C"
LANG="C"
osv


Sedan gjorde jag en
Code:
env-update
source /etc/profile
locale


Ovanstående som root.
Nu blir det skumt:

Skriver jag
Code:
locale
som min vanliga användare får jag:
Code:
LANG=C
LC_TYPE=C
...
LC_ALL=


och inga felmeddelanden.

Upprepas som root:
Code:
locale: Cannot set LC_CTYPE to default locale. Nu such file or directory
locale: Cannot set LC_MESSAGES to default locale. Nu such file or directory
locale: Cannot set LC_ALL to default locale. Nu such file or directory
LANG=C
LC_CTYPE="sv_SE"
...
LC_ALL=sv_SE


Hur fixar man det här?
Det enda jag egentligen vill är att svenska tecken ska hanteras korrekt, främst av Java.
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4835
Location: Gothenburg, Sweden

PostPosted: Sat Oct 02, 2004 4:14 pm    Post subject: Reply with quote

Förmodligen har du en .bashrc eller något annat för root. Hur som helst är felet inte i 02locale. Vet inte om det har någon betydelse men har du emergeat glibc med USE="nls"? Du kan ju testa några andra locales också, för att se om det är ett allmänt problem, eller bara relaterat till den svenska.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
jaghetertoffe
Tux's lil' helper
Tux's lil' helper


Joined: 06 Mar 2004
Posts: 92

PostPosted: Sun Oct 03, 2004 7:15 pm    Post subject: Reply with quote

Japp, jag hade en .bashrc för root som ställde till det.
Nu har jag tagit bort den aktuella raden från den filen.

Jag har inte "nls" i USE-sektionen i make.conf

Hur föreslår du att jag ska byta locale? Genom att ändra i 02locale eller köra en EXPORT? Hur testar jag sedan att allt funkar? Det är ju svenska tecken jag vill kunna skriva ut.... Nu när jag har "C" som språk i 02locale och rensat alla .bashrc får jag inga felmeddelanden.
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4835
Location: Gothenburg, Sweden

PostPosted: Sun Oct 03, 2004 8:29 pm    Post subject: Reply with quote

Det enklaste sättet att testa är att köra exemplevis
Code:
LC_CTYPE="xx_YY" xterm

där xx_YY är någon lämplig locale. Vad gäller nls är det förmodligen satt i /etc/make.profile/make.defaults, kolla med emerge info, eller equery uses glibc för att se vilka som är satta för glibc.

Hur som helst, det är ju inte C localen du vill ha, och varför det inte funkar med sv_SE vet jag inte, då du har rätt fil.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
xanthax
Tux's lil' helper
Tux's lil' helper


Joined: 16 Apr 2004
Posts: 91
Location: Bi Nary State

PostPosted: Tue Oct 12, 2004 4:12 pm    Post subject: Reply with quote

WTF,
Va gör man om man saknar 02locale filen å vill ändra de permanent då ?

Kollade i /etc/env.d/ å där låg en 02distcc.
kan man skapa 02locale endå ?

Jaja inte direkt döds viktigt iom att jag kan exporta så länge men vid reboot ?
_________________
God is only an imaginary friend for adults...
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4835
Location: Gothenburg, Sweden

PostPosted: Tue Oct 12, 2004 5:31 pm    Post subject: Reply with quote

Det är bara att skapa filen.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
NiBe
n00b
n00b


Joined: 08 Jan 2004
Posts: 38

PostPosted: Sun Nov 14, 2004 4:52 pm    Post subject: Reply with quote

Vad är det som plötsligt tvingar på en att meka med locale?
Jag har inte använt gentoo i drygt ett år nu och har kommit tillbaka till det. Sist behövde jag då inte bråka med det, och jag gillar verkligen inte att bli påtvingad något...

Edit: Kan tillägga att sist installerade jag Gentoo 1.4 releasen, nu är det 2004.2 inne på disken.
_________________
Bus error - Driver executed
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum