Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Interesting KDE somethin' or other
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Jamon
Guest





PostPosted: Wed Apr 10, 2002 4:12 pm    Post subject: Interesting KDE somethin' or other Reply with quote

Hello! I am so glad this forum is here :). I am wondering if anyone has this problem, and suggested solutions: Whenever I start X (and KDE 3.0 ) for the first time, it takes quite a while, I would say 10-20 seconds, to bring up the KDE 3 logo, after which it starts like normal. X has definitely started, and you can see the cursor. I ran top on another console, and kdeinit was running, and ksplash was also. After that wait, it seems ok. When I switch to the primary virtual console (ctrl+alt+f1), it seems that it just sits there for a while, then complains about some Qpicture not found or something (sorry, I cannot seem to find it in a lot somewhere). I tried recompiling kdebase/kdelibs with less aggressive C(XX)FLAGS, and it still does this. I am wondering if I should also try QT. I am also using mosfet liquid, if it makes any difference. Thanks for your help!

Jamon

P.S. I am running a very fast PC - Athlon 1.4 w/ 512MB of RAM. No problems there :)
Back to top
niyogi
Apprentice
Apprentice


Joined: 10 Apr 2002
Posts: 199
Location: Austin, TX

PostPosted: Wed Apr 10, 2002 7:15 pm    Post subject: Reply with quote

this is a strange suggestion but did you try using a different theme then mosfet to see whether that does anything? (although i highly doubt it)

-S
Back to top
View user's profile Send private message
Jamon
Guest





PostPosted: Wed Apr 10, 2002 8:32 pm    Post subject: Unfortunately.. Reply with quote

Unfortunately, it still does happen. I decided to play it carefully, and I was able to get the text it displays after the long wait on the primary console screen.

XFree stuff, then one blank line, then:

>> running as realtime process now (priority 50)
Mutex destroy failure: Device or resource busy
Mutex destroy failure: Device or resource busy
mcop warning: user defined signal handler found for SIG_PIPE, overriding
_IceTransmkdir: Ownerof /tmp/.ICE-unix should be set to root
mcop warning: user defined signal handler found for SIG_PIPE, overriding


Once that realtime process thingie shows up, it starts to move. It seems kinda wierd to me. Ideas?

Jamon
Back to top
gekke
Guest





PostPosted: Wed Apr 17, 2002 6:10 pm    Post subject: Reply with quote

This is a long shot, but could it be that it tries to resolve your host name and it doens't exist?

I had very slow loading times until I added my hostname to the localhost line in /etc/hosts (I have a laptop and have no fixed ip as such)
Back to top
andee
Guest





PostPosted: Thu Apr 18, 2002 4:54 am    Post subject: Re: Unfortunately.. Reply with quote

[
>> running as realtime process now (priority 50)
Mutex destroy failure: Device or resource busy
Mutex destroy failure: Device or resource busy
mcop warning: user defined signal handler found for SIG_PIPE, overriding
_IceTransmkdir: Ownerof /tmp/.ICE-unix should be set to root
mcop warning: user defined signal handler found for SIG_PIPE, overriding

I have one suggestion. Start kde as root for the first time to set owner of .ICE-unix. Whoever starts kde first is set as owner of this file.
This is going to speed up start-up time.
As for the rest of warnings I have no idea what causing it, maybe arts(sound) I have these errors too.
Back to top
Jamon
Guest





PostPosted: Fri Apr 19, 2002 4:16 pm    Post subject: Hmm.. Reply with quote

Oh, one other thing - this only happens the first time I boot up the PC. If I logout of X, and startx again, it boots up quickly. Any ideas?

Jamon
Back to top
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum