Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
hydrogen 0.9.0
View unanswered posts
View posts from last 24 hours

 
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo for Mac OS X (Portage for Mac OS X)
View previous topic :: View next topic  
Author Message
BennyP
Guru
Guru


Joined: 09 May 2003
Posts: 497
Location: Toronto, Canada

PostPosted: Mon Sep 27, 2004 10:58 pm    Post subject: hydrogen 0.9.0 Reply with quote

i get this annoying and mysterious error at the end of hydrogen compilation
Code:
g++ -DHAVE_CONFIG_H -I. -I. -I.. -I../lib -I/Developer/qt/include -I.   -DQT_THREAD_SUPPORT   -O3  -c -o SongPropertiesDialog.o `test -f 'SongPropertiesDialog.cpp' || echo './'`SongPropertiesDialog.cpp
/bin/sh ../libtool --mode=link --tag=CXX g++  -O3    -o hydrogen -L/usr/X11R6/lib -L/Developer/qt/lib  -lsndfile   -lFLAC -lFLAC++ -framework CoreAudio -L/usr/local/lib -ljack   AboutDialog.o AudioEngineInfoForm.o Button.o CpuLoadWidget.o DrumkitManager.o ExportSongDialog.o Fader.o HelpBrowser.o HydrogenApp.o FilePreview.o InstrumentPropertiesDialog.o LadspaFXProperties.o LadspaFXSelector.o main.o MidiActivityWidget.o Mixer.o MixerLine.o MainForm.o PatternEditor.o PatternEditorPanel.o PatternPropertiesDialog.o PreferencesDialog.o PlayerControl.o SplashScreen.o SongEditor.o SongPropertiesDialog.o AboutDialog_UI.o AudioEngineInfoForm_UI.o DrumkitManager_UI.o ExportSongDialog_UI.o InstrumentPropertiesDialog_UI.o LadspaFXSelector_UI.o PatternPropertiesDialog_UI.o PreferencesDialog_UI.o SongPropertiesDialog_UI.o AudioEngineInfoForm.moc.o InstrumentPropertiesDialog.moc.o FilePreview.moc.o CpuLoadWidget.moc.o PlayerControl.moc.o PatternEditor.moc.o LadspaFXProperties.moc.o SongPropertiesDialog.moc.o AboutDialog.moc.o DrumkitManager.moc.o HelpBrowser.moc.o Fader.moc.o PatternPropertiesDialog.moc.o LadspaFXSelector.moc.o SongEditor.moc.o SplashScreen.moc.o Mixer.moc.o MainForm.moc.o PreferencesDialog.moc.o MixerLine.moc.o Button.moc.o PatternEditorPanel.moc.o MidiActivityWidget.moc.o ExportSongDialog.moc.o  ../lib/libhydrogen.a ../lib/xml/libtinyxml.a ../lib/drivers/libdrivers.a ../lib/fx/libfx.a ../lib/smf/libsmf.a  -lqt-mt -lpng -lz -lm -ljpeg -lXext -lX11  -lSM -lICE -lpthread  -lpthread
libtool: link: cannot find the library `'
make[3]: *** [hydrogen] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2


could i have perhaps overwritten the macosx version of libtool? i read somewhere that apple has atool called libtool that has nothing to do with gnu libtool and that on os x, gnu libtool is called glibtool... could that be it?
_________________
Could it be?
Back to top
View user's profile Send private message
BennyP
Guru
Guru


Joined: 09 May 2003
Posts: 497
Location: Toronto, Canada

PostPosted: Fri Oct 01, 2004 1:08 am    Post subject: GNU ld Reply with quote

should i install GNU ld?
_________________
Could it be?
Back to top
View user's profile Send private message
JoseJX
Developer
Developer


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Fri Oct 01, 2004 6:49 am    Post subject: Reply with quote

No, this is a libtool issue, which version of portage are you using?
Back to top
View user's profile Send private message
BennyP
Guru
Guru


Joined: 09 May 2003
Posts: 497
Location: Toronto, Canada

PostPosted: Fri Oct 01, 2004 6:59 pm    Post subject: Reply with quote

Portage 2.0.51_pre20 (default-macos-10.3, gcc-3.3, libsystem-7.1-r0, 7.5.0 Power Macintosh powerpc)
_________________
Could it be?
Back to top
View user's profile Send private message
JoseJX
Developer
Developer


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Fri Oct 01, 2004 11:23 pm    Post subject: Reply with quote

Upgrade to the latest version (51_rc7 at the time of writing), this should alias libtool to glibtool which should fix this problem.
Back to top
View user's profile Send private message
BennyP
Guru
Guru


Joined: 09 May 2003
Posts: 497
Location: Toronto, Canada

PostPosted: Sat Oct 02, 2004 7:03 pm    Post subject: Reply with quote

okay well i did
Code:
emerge sunc
emerge portage
emerge libtool
but i still get the same problem

if you look at the output, you'll notice that the libtool bin that's being executed in the make script is inside the hydrogen-0.9.0 directory
_________________
Could it be?
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo for Mac OS X (Portage for Mac OS X) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum