Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Anyway to tell Portage that I have Apple's X11 installed?
View unanswered posts
View posts from last 24 hours

 
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo for Mac OS X (Portage for Mac OS X)
View previous topic :: View next topic  
Author Message
Evolution
Tux's lil' helper
Tux's lil' helper


Joined: 07 Mar 2003
Posts: 88
Location: NJ

PostPosted: Wed Sep 29, 2004 9:31 pm    Post subject: Anyway to tell Portage that I have Apple's X11 installed? Reply with quote

I'm trying to install a package that requires X11, the only problem is I don't know how to tell portage that I have it installed. Any ideas?
_________________
///M
Back to top
View user's profile Send private message
beergutxl
n00b
n00b


Joined: 05 Sep 2004
Posts: 10
Location: Manchester, England

PostPosted: Wed Sep 29, 2004 10:59 pm    Post subject: Reply with quote

According to the emerge man pages this is exactly what the inject option is for
Quote:
Injecting a package inserts a 'stub' for that package so that Portage thinks that it is installed.
so
Quote:
emerge inject [package its trying to install]
will prevent it from emergeing X11.
But as I'm not a mac user no idea if the OS X portage supports it. Hope I've been of some help.

Beergut


Last edited by beergutxl on Thu Sep 30, 2004 2:11 pm; edited 1 time in total
Back to top
View user's profile Send private message
Evolution
Tux's lil' helper
Tux's lil' helper


Joined: 07 Mar 2003
Posts: 88
Location: NJ

PostPosted: Thu Sep 30, 2004 12:34 am    Post subject: Reply with quote

hmm I tried that but I kept gettin an error. I made a directory called "apple-xfree" in /usr/portage/x11-base . I then made a fake ebuild file called x11-1.0.ebuild and just put "installed" in the body of the text of the file. When I tried
Code:
emerge inject x11-base/apple-xfree
I get an error that a specific cat-pkg must be used. I tried it also with x11-base/apple-xfree/x11-1.0 and apple-xfree/x11-1.0 . It DID work when I tried
Code:
emerge inject apple-xfree/x11-1.0.
but I don't know why that one worked and the other didn't
_________________
///M
Back to top
View user's profile Send private message
beergutxl
n00b
n00b


Joined: 05 Sep 2004
Posts: 10
Location: Manchester, England

PostPosted: Thu Sep 30, 2004 1:40 am    Post subject: Reply with quote

Don't know why the first didn't work but maybe is the filenames anyway...
maybe i didn't make myself clear type
Quote:
emerge -p [the program you want to install]
then enter
Quote:
emerge inject [the xserver the previous command is trying to install]
This should fool portage into thinking its already installed it.

Beergut
Back to top
View user's profile Send private message
JoseJX
Developer
Developer


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Thu Sep 30, 2004 3:16 am    Post subject: Reply with quote

With the new version of portage (that MacOSX uses) the inject keyword is depreciated. If you have recently emerge sync'd you should already have xfree provided in your profile. You may need to upgrade your portage version as well.
Back to top
View user's profile Send private message
Evolution
Tux's lil' helper
Tux's lil' helper


Joined: 07 Mar 2003
Posts: 88
Location: NJ

PostPosted: Thu Sep 30, 2004 3:32 am    Post subject: Reply with quote

beergutxl, I know what you meant, the command simply didn't work. I'm emerge syncing right now, hopefully that will clear this up. Ill let you know how it goes.
_________________
///M
Back to top
View user's profile Send private message
phaidros
n00b
n00b


Joined: 27 Jul 2003
Posts: 26
Location: germany

PostPosted: Thu Sep 30, 2004 3:40 pm    Post subject: Reply with quote

In gentoo osx' portage "emerge --inject" is depreceated.
instead is there a file /etc/portage/profile/package.provided
there u can put in already install software.
e.g.
Code:
echo "x11-base/xfree-4.3.0-r7" >> /etc/portage/packages.provided


my one (I've xcode 1.5 installed):
Code:
cat /etc/portage/profile/packages.provided
app-shells/bash-2.05b-r2
dev-libs/libxml2-2.6.7
sys-devel/libperl-5.8.1
dev-lang/perl-5.8.1
sys-devel/autoconf-2.59
sys-devel/m4-1.4
sys-apps/coreutils-0.0.0
sys-devel/automake-1.6.3
Back to top
View user's profile Send private message
DaVe&OpenMOsix
Apprentice
Apprentice


Joined: 30 Dec 2003
Posts: 213

PostPosted: Sun Oct 10, 2004 9:49 pm    Post subject: Reply with quote

i do not have package.provided in /etc/portage.
i do not have /etc/portage!
i made
Code:

mkdir /etc/portage
touch /etc/portage/packages.provided
echo "x11-base/xfree-4.3.0-r7" >> /etc/portage/packages.provided
-bash: /etc/portage/packages.provided: Permission denied

but i can't write on this file!
i tried also with nano/pico.
do you have some ideas about?
thanks, sorry for my english...
DaVe!
_________________
-- Siccome sono un informatico ho votato PCI convinto di aumentare gli slot di espansione della società --
-^v^v^v^v^v^v^v^v^v^-
DaVe the WaVe
http://dave.ccni.it
http://www.davethewave.it
-^v^v^v^v^v^v^v^v^v^-
Back to top
View user's profile Send private message
DaVe&OpenMOsix
Apprentice
Apprentice


Joined: 30 Dec 2003
Posts: 213

PostPosted: Sun Oct 10, 2004 10:03 pm    Post subject: Reply with quote

ok, sorry, i cannot write due to permissions on file.
i edited the file inserting
Code:
x11-base/xfree-4.3.0-r7

but
Code:
emerge -pv aterm
Calculating dependencies \
emerge: there are no ebuilds to satisfy "x11-base/apple-xfree".

i have to insert also x11-base/apple-xfree?
i tried this, but it no works!
bye...
DaVe
_________________
-- Siccome sono un informatico ho votato PCI convinto di aumentare gli slot di espansione della società --
-^v^v^v^v^v^v^v^v^v^-
DaVe the WaVe
http://dave.ccni.it
http://www.davethewave.it
-^v^v^v^v^v^v^v^v^v^-
Back to top
View user's profile Send private message
danie
n00b
n00b


Joined: 11 Oct 2004
Posts: 5
Location: los angeles

PostPosted: Mon Oct 11, 2004 4:20 am    Post subject: bootstrap-macos.sh Reply with quote

Did you run: /usr/portage/scripts/bootstrap-macos.sh ? This script will inject an X package so that you can use apple's X11 user and developer packages. In order for X-dependent packages to compile you need the developer X11 package, which is an extra package in the Xcode package. If you want to run X-dependent applications then you probably need to install the X11 user package (http://www.apple.com/macosx/features/x11/download/), or use Fink.

If bootstrap-macos.sh does not work then you will want to: emerge --inject x11-base/apple-xfree-4.3
The versions of emerge that I have used on OS X have pretty much ignored the package.provided files, which is probably why bootstrap-macos.sh injects all of the files in /etc/make.profile/package.provided.
Back to top
View user's profile Send private message
DaVe&OpenMOsix
Apprentice
Apprentice


Joined: 30 Dec 2003
Posts: 213

PostPosted: Tue Oct 12, 2004 10:05 am    Post subject: Reply with quote

thanks Danie!
i have already bootstrapped the system and i have already installed X11 (i use with fink a lot of software).
Code:
emerge --inject x11-base/apple-xfree-4.3

ok this command have injected the package, but aterm compile fails.
when i try to update portage, the python-fchksum fails.
Code:
gcc -Wl,-F. -Wl,-F. -bundle -framework Python -fast -mcpu=7450 -pipe build/temp.darwin-7.5.0-Power_Macintosh-2.3/fchksum.o build/temp.darwin-7.5.0-Power_Macintosh-2.3/md5.o build/temp.darwin-7.5.0-Power_Macintosh-2.3/cksum.o build/temp.darwin-7.5.0-Power_Macintosh-2.3/sum.o -lz -o build/lib.darwin-7.5.0-Power_Macintosh-2.3/fchksum.so
ld: build/temp.darwin-7.5.0-Power_Macintosh-2.3/fchksum.o has local relocation entries in non-writable section (__TEXT,__text)
error: command 'gcc' failed with exit status 1
!!! ERROR: dev-python/python-fchksum-1.7.1 failed.
!!! Function src_compile, Line 20, Exitcode 1

any ideas?
bye DaVe
_________________
-- Siccome sono un informatico ho votato PCI convinto di aumentare gli slot di espansione della società --
-^v^v^v^v^v^v^v^v^v^-
DaVe the WaVe
http://dave.ccni.it
http://www.davethewave.it
-^v^v^v^v^v^v^v^v^v^-
Back to top
View user's profile Send private message
merlin
n00b
n00b


Joined: 07 Jan 2003
Posts: 44
Location: Oregon, USA

PostPosted: Thu Oct 21, 2004 7:00 am    Post subject: Reply with quote

DaVe&OpenMOsix wrote:
[...]
when i try to update portage, the python-fchksum fails.

I've been getting the same python-fchksum error as you for some time now. (I've been waiting, hoping it would go away with an update.) I noticed today that it also comes up with jpeg-6b-r3.

Should these "relocation" errors be reported as bugs, or is there something we users need to do about them?

Thanks,
Ben
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo for Mac OS X (Portage for Mac OS X) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum