Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
zope and gentoo
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Off the Wall
View previous topic :: View next topic  
Author Message
kosh
n00b
n00b


Joined: 29 May 2002
Posts: 0

PostPosted: Wed May 29, 2002 11:47 am    Post subject: zope and gentoo Reply with quote

I am currently running debian sid on my systems with zope 2.5.1 with python 2.1.3 and I am a zope developer. What is involved in switching to gentoo. I looked around and did not see python 2.1.3 in the available packages.

Gentoo certainly looks interesting however currently zope requires python 2.1.3 becuase of all the changes that where introduced in the 2.2 branch of python.

Should I try to upgrade to gentoo at this time or just wait until some of that stuff makes it into the archives?

Also how is the stabiliyt overall I have been running debian sid for about 1 year on 5 systems and not one has crashed in all of that time and I do daily updates of software using apt-get. Can I expect similar stability?

Thanks
Back to top
View user's profile Send private message
lx
Veteran
Veteran


Joined: 28 May 2002
Posts: 1012
Location: Netherlands

PostPosted: Wed May 29, 2002 11:20 pm    Post subject: Reply with quote

Debian is the most reliable distro's out there, but well at the cost of outdated packages. Although my gentoo runs fine (even compiled with gcc 3.1) I don't think it's as stable (and well tested) as Debian, but maybe a good second. If I was you I would wait with the change if your happy with your system, wait for zope to get compatible with python 2.2 (if python 2.2 and 2.1 can coexist, you can try to build it yourself, packages are very simple to make).

If it ain't broke, don't fix it, if it's micro$oft, don't bother fixing, Alex.
_________________
"Remember there's a big difference between kneeling down and bending over.", Frank Zappa
Back to top
View user's profile Send private message
kosh
n00b
n00b


Joined: 29 May 2002
Posts: 0

PostPosted: Thu May 30, 2002 1:10 am    Post subject: Reply with quote

Debian sid is unstable which tends to be pretty new however at current it does not include xfree 4.2 or kde 3.x so even though it is fairly new it is certainly not bleeding edge.

On debian you can have 1.5.2, 2.0.1, 2.1.3, and 2.2.1 of python all installed at the same time so it is possible to have them all installed at the same time.

I doubt zope will be compat with python 2.2.x for a while becuase of the number of changes 2.2.x made to some core python structures.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Off the Wall All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum