Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Samba forstår seg ikke på æøå....
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
helmers
Guru
Guru


Joined: 16 Sep 2002
Posts: 548
Location: Oslo, Norway

PostPosted: Mon Jun 16, 2003 5:29 pm    Post subject: Samba forstår seg ikke på æøå.... Reply with quote

Hei!

Jeg sliter litt med å få samba(og en del andre programmer) til å forstå hverandre. Så jeg lurer på hvilke konfigurasjon dere andre har i kjernen, og om det er noe jeg må stille inn for å få det til å virke.

Et eksempel:
"Vår" blir i nautilus tryllet om til "V:x86r", og umulig å åpne. Og jeg har problemer med å få medarbeidere til å slutte med ÆØÅ. Når jeg lager noe med ÆØÅ, så blir det ikke riktig for dem...

Mao. har vi et komunikasjonsproblem. :roll:
_________________
C is for Cookies!
Back to top
View user's profile Send private message
Yarrick
Bodhisattva
Bodhisattva


Joined: 05 Jun 2002
Posts: 304
Location: Malmö, Sweden

PostPosted: Mon Jun 16, 2003 6:39 pm    Post subject: Reply with quote

http://forums.gentoo.org/viewtopic.php?t=47820

detta är en liknande tråd på svenska, vet ej om den löser problemet dock :)
Back to top
View user's profile Send private message
helmers
Guru
Guru


Joined: 16 Sep 2002
Posts: 548
Location: Oslo, Norway

PostPosted: Mon Jun 16, 2003 8:32 pm    Post subject: Reply with quote

Den virket litt død, men den innholdt intet svar så vidt jeg kunne se.

Det må være noen på de skandinaviske forumene som har fått SAMBA og ÆØÅ til å fungere? Kanskje sette alt til "unicode" i kjernen? :wink:
_________________
C is for Cookies!
Back to top
View user's profile Send private message
cato`
Guru
Guru


Joined: 03 Jun 2002
Posts: 430
Location: Norway, Trondheim

PostPosted: Tue Jun 17, 2003 6:14 pm    Post subject: Reply with quote

http://www.arianeskema.dk/ota/am-samba.html

Gå til seksjon 7.4.3, her står det om æøå i samba.
Back to top
View user's profile Send private message
Lemma
Guru
Guru


Joined: 19 Apr 2002
Posts: 416
Location: Uppsala, Sweden

PostPosted: Wed Oct 15, 2003 12:42 pm    Post subject: Reply with quote

Hm, testparm meddelar dock att
Code:
Unknown parameter encountered: "client code page"
, vilket betyder att 850, 865 eller vad man nu ställer in där inte fungerar. Kan detta vara en av förändringarna i 3:an?
_________________
Always make it as simple as possible, but no simpler
/Einstein
Back to top
View user's profile Send private message
Lemma
Guru
Guru


Joined: 19 Apr 2002
Posts: 416
Location: Uppsala, Sweden

PostPosted: Sun Oct 19, 2003 6:04 pm    Post subject: Reply with quote

SAMBA 3.x skall tydligen ha teckenkod 850 som standard och faller tillbaka på 437 om den första inte fungerar. Jag kör samba 3.0 och åäö fungerar. Localt kör jag unicode (utf-8) och inga andra inställnigar i smb.conf. smb.conf ser ut som följande:
Code:
[global]
        workgroup = ANALYSEN
        netbios name = Beata
        server string = Linux traning computer
        security = share
        encrypt passwords = yes
        hosts deny = ALL EXCEPT 130.238.xxx.xxx 130.238.xxx.xxx
        socket options = SO_KEEPALIVE TCP_NODELAY IPTOS_LOWDELAY SO_SNDBUF=8192 SO_RCVBUF=8192
        log file = /var/log/samba/log.%m
        max log size = 1024
        log level = 3
        password level = 6

[public]
        comment = Public area
        public = yes
        guest only = yes
        path = /home/samba/public
        browsable = yes
        read only = no
Om man kör testparm -v -i, fpår man
Code:
 dos charset = CP850
vilket altså är standard.
_________________
Always make it as simple as possible, but no simpler
/Einstein
Back to top
View user's profile Send private message
Epcylon
n00b
n00b


Joined: 24 Nov 2002
Posts: 34
Location: Oslo, Norway

PostPosted: Thu Aug 05, 2004 9:00 pm    Post subject: Reply with quote

Jeg har også slitt litt med dette, men denne posten fikk meg på rette sporet.

XP bruker UTF-8 internt, så du må sette
Code:

dos charset = UTF-8

slik som foregående poster sa.. men det er ikke enden på visa...

Fordi, ihvertfall min gentoo installasjon, som er rimelig fersk og ikke veldig spesiell... bruker ISO8859-1... så du må også sette
Code:

unix charset = ISO8859-1

for å få det helt riktig.

Nå funker det knall fint hos meg i hvertfall... :)
_________________
Epcylon
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum