Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Wireless configuration and startup - The Gentoo way
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 47, 48, 49 ... 57, 58, 59  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
jfave
Tux's lil' helper
Tux's lil' helper


Joined: 28 Jul 2004
Posts: 96
Location: Jacksonville, FL

PostPosted: Mon Aug 02, 2004 8:12 pm    Post subject: Reply with quote

got it working on my promix card.. thanks man! my fix was to reboot... i also downloaded the wireless and wireless.sh files from your site.. dont know if it was a coincidence or not.. laptop lost power, and came up working!
Back to top
View user's profile Send private message
Freejack00
n00b
n00b


Joined: 02 Aug 2004
Posts: 22

PostPosted: Tue Aug 03, 2004 2:35 am    Post subject: Reply with quote

Can someone point me in the direction of some documentation. Everything I click on leads to this thread. To someone wanting to install (with the changes and differences) reading this makes it reall hard to follow. I got mine up but everytime I reboot I have to manually enter all this.
Back to top
View user's profile Send private message
markfl
Apprentice
Apprentice


Joined: 10 Apr 2003
Posts: 240
Location: Kent, UK

PostPosted: Tue Aug 03, 2004 7:38 am    Post subject: Reply with quote

Freejack00 wrote:
Can someone point me in the direction of some documentation. Everything I click on leads to this thread. To someone wanting to install (with the changes and differences) reading this makes it reall hard to follow. I got mine up but everytime I reboot I have to manually enter all this.


Documentation for what?
I'm presuming you've installed gentoo (if not then use the install guide)
To get your wireless working:
Code:
emerge wireless-tools

Find out which driver your card uses (google for "<model number> linux" will usually help)
Compile this driver into the kernel along with wireless support.

This should get you to the state where you can get the wireless working using iwconfig/ifconfig commands. That is where wireless-config comes in.
Follow the instructions in the first post (its updated each new version) to get it installed. Edit the config file at /etc/conf.d/wireless and make sure that you follow the instructions displayed after the ebuild has finished.

If you need any more specific help then post again.

Mark
_________________
Life it seems, will fade away
Drifting further every day
Back to top
View user's profile Send private message
UberLord
Retired Dev
Retired Dev


Joined: 18 Sep 2003
Posts: 6452
Location: Blighty

PostPosted: Tue Aug 03, 2004 8:16 am    Post subject: Reply with quote

kamagurka wrote:

i have one of those intel centrino cards and i'm trying to connect to an SMC Barricade g WLAN router. i am not succeeding. it's not because of the encryption (although i'm sure i'll run into problems there, too) because the same happens with security settings turned off altogether.


Try using associate_test_wlan0="quality"
_________________
Use dhcpcd for all your automated network configuration needs
Ask for dhcpcd-ui (GTK+/Qt System Tray Network tool) to be added to Gentoo
Back to top
View user's profile Send private message
tursiops
Apprentice
Apprentice


Joined: 29 May 2004
Posts: 158
Location: Switzerland

PostPosted: Tue Aug 03, 2004 9:20 am    Post subject: Reply with quote

I found what my inboard wireless card is:
Intel Corp, Pro / Wireless 2200BG (rev 05)

Now what driver must I use pls?

Thanks!
Back to top
View user's profile Send private message
Tyger
n00b
n00b


Joined: 25 Jul 2004
Posts: 30
Location: Germany

PostPosted: Tue Aug 03, 2004 9:34 am    Post subject: Reply with quote

Have a look at http://ipw2200.sourceforge.net/

Cya
_________________
Join the adopt an unanswered question initiative now
Back to top
View user's profile Send private message
maxheadroom
n00b
n00b


Joined: 17 Feb 2004
Posts: 20

PostPosted: Tue Aug 03, 2004 11:04 am    Post subject: Reply with quote

UberLord wrote:
For those with DHCP problems, check your conf.d/net file.
If the call to wireless_down is in predown(), try renaming it to postdown().

I'm not sure if it will help, but it may do.


I changed this and it didn't have any effect on the problem.

If it would be helpful, I can give you an ssh login to this box, PM me if you're interested.
Back to top
View user's profile Send private message
UberLord
Retired Dev
Retired Dev


Joined: 18 Sep 2003
Posts: 6452
Location: Blighty

PostPosted: Tue Aug 03, 2004 11:45 am    Post subject: Reply with quote

maxheadroom wrote:
I changed this and it didn't have any effect on the problem.

If it would be helpful, I can give you an ssh login to this box, PM me if you're interested.


Technically, the DHCP problem is with Gentoo's net.eth0 - my wireless is not responsible for correct DHCP operation.

Besides, there's a patch a page or two back that does solve the problem with net.eth0
_________________
Use dhcpcd for all your automated network configuration needs
Ask for dhcpcd-ui (GTK+/Qt System Tray Network tool) to be added to Gentoo
Back to top
View user's profile Send private message
kamagurka
Veteran
Veteran


Joined: 25 Jan 2004
Posts: 1026
Location: /germany/munich

PostPosted: Tue Aug 03, 2004 4:06 pm    Post subject: Reply with quote

UberLord wrote:
kamagurka wrote:

i have one of those intel centrino cards and i'm trying to connect to an SMC Barricade g WLAN router. i am not succeeding. it's not because of the encryption (although i'm sure i'll run into problems there, too) because the same happens with security settings turned off altogether.


Try using associate_test_wlan0="quality"


i assume you mean i should put it in /etc/conf.d/wireless. it has no noticeable effect.
is it a problem that i am also hardconnected to the router when i try to get the wlan up?
_________________
If you loved me, you'd all kill yourselves today.
--Spider Jerusalem, the Word
Back to top
View user's profile Send private message
vitriol
Apprentice
Apprentice


Joined: 01 Nov 2003
Posts: 162
Location: US

PostPosted: Tue Aug 03, 2004 4:51 pm    Post subject: Reply with quote

I'm trying to use wireless-config to get my card up and running without much luck. :( My card is detected by iwconfig and I set up my /etc/conf.d/wireless. However, the card simply isn't working....I see no /etc/init.d/net.ath0. I saw the faq pointed to the docs if you don't have an interface in /etc/init.d/ but I still don't understand how to get this working! Do I need to add

Code:
iwconfig_ath0=( "dhcp" )


To /etc/conf.d/net ? I'm really confused..I tried that and rebooted but it did no good. I still don't have an /etc/init.d/net.ath0.

Code:

root@obfuscated ~ # lsmod
Module                  Size  Used by
ath_pci                34748  -
ath_hal               123408  -
wlan                   54312  -
nvidia               4811892  -


Code:

root@obfuscated ~ # iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

ath0      IEEE 802.11  ESSID:"NETWORK"
          Mode:Managed  Frequency:2.452GHz  Access Point: FF:FF:FF:FF:FF:FF
          Bit Rate:1Mb/s   Tx-Power:off   Sensitivity=0/3
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

          Link Quality=0/94  Signal level=-95 dBm  Noise level=-95 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0



Here is my /etc/conf.d/wireless:

Code:

essid_ath0="any"
mode_ath0="Managed"
#adhoc_essid_eth0="WLAN"
channel_ath0="9"
iwconfig_ath0="dhcp"
#iwpriv_eth0=""
#sleep_scan_eth0="1"
#sleep_associate_eth0="5"
key_NETWORK="s:B476D9EFC3 enc open"
#key_ESSID="s:foobar enc restricted"
#ifconfig_ESSID=( "dhcp" )
#dhcpcd_ESSID="-t 5"
#inet6_ESSID=()
#routes_ESSID=()
#ifconfig_fallback_ESSID=()
# iproute-2 style setup
#ipaddr_ESSID=( "dhcp" )
#iproute_ESSID=()
#ipaddr_fallback_ESSID=()
#nameserver_ESSID="192.168.0.1"
#domain_ESSID="some.domain"


If whatever I've done wrong is a really dumb mistake, I'm sorry. I'm posting because after about a week I still can't figure this out for myself.

Thanks
_________________
The specs on the box said windows 98 or better, so I installed gentoo.
Back to top
View user's profile Send private message
UberLord
Retired Dev
Retired Dev


Joined: 18 Sep 2003
Posts: 6452
Location: Blighty

PostPosted: Tue Aug 03, 2004 5:01 pm    Post subject: Reply with quote

kamagurka wrote:

i assume you mean i should put it in /etc/conf.d/wireless. it has no noticeable effect.
is it a problem that i am also hardconnected to the router when i try to get the wlan up?


Doubtfull.
Running any security like WPA, MAC filtering, etc on the AP?
_________________
Use dhcpcd for all your automated network configuration needs
Ask for dhcpcd-ui (GTK+/Qt System Tray Network tool) to be added to Gentoo
Back to top
View user's profile Send private message
UberLord
Retired Dev
Retired Dev


Joined: 18 Sep 2003
Posts: 6452
Location: Blighty

PostPosted: Tue Aug 03, 2004 5:05 pm    Post subject: Reply with quote

vitriol wrote:
I'm trying to use wireless-config to get my card up and running without much luck. :( My card is detected by iwconfig and I set up my /etc/conf.d/wireless. However, the card simply isn't working....I see no /etc/init.d/net.ath0. I saw the faq pointed to the docs if you don't have an
interface in /etc/init.d/ but I still don't understand how to get this working!

You need to create this yourself. Luckily, it's simple
Code:
ln -s /etc/init.d/net.eth0 /etc/init.d/net.ath0

Quote:
Here is my /etc/conf.d/wireless:

Here is a better version for you
Code:

ifconfig_ath0=( "dhcp" ) # This really belongs in /etc/conf.d/net
key_NETWORK="s:B476D9EFC3 enc open"
preferred_aps=( "NETWORK" )

Quote:

If whatever I've done wrong is a really dumb mistake, I'm sorry. I'm posting because after about a week I still can't figure this out for myself.


Hopefully I've made things a little simpler for you :)
_________________
Use dhcpcd for all your automated network configuration needs
Ask for dhcpcd-ui (GTK+/Qt System Tray Network tool) to be added to Gentoo
Back to top
View user's profile Send private message
vitriol
Apprentice
Apprentice


Joined: 01 Nov 2003
Posts: 162
Location: US

PostPosted: Tue Aug 03, 2004 5:52 pm    Post subject: Reply with quote

Wow! Thanks!! Works great now..well, except for WEP. It works if I disable WEP, but I'm wondering if I have the WEP key in the wrong format or something.

Code:

root@obfuscated ~ # /etc/init.d/net.ath0 start
  * Running preup function
 *   Configuring wireless network for ath0
 *   Scanning for access points
 *     Found "network" at 00:0F:B3:37:EF:25 (WEP required)
 *   Trying to force preferred incase they are hidden
 *   Connecting to "NETWORK" (WEP enabled)...                           [ !! ]

 *   Failed to associate with any preferred access points on ath0
 *   WEP key is not set for "network" - not connecting
 * Couldn't associate with any access points on ath0
 * Failed to configure wireless for ath0
 * preup ath0 failed



Kind of odd to get an error message like that. I checked and double checked my AP and WEP is enabled. Checked the key too, and it seems to be correct. Almost have it working! 8)
_________________
The specs on the box said windows 98 or better, so I installed gentoo.
Back to top
View user's profile Send private message
vitriol
Apprentice
Apprentice


Joined: 01 Nov 2003
Posts: 162
Location: US

PostPosted: Tue Aug 03, 2004 8:06 pm    Post subject: Reply with quote

Well, guess it was my imagination. I can't connect with or without WEP.
_________________
The specs on the box said windows 98 or better, so I installed gentoo.
Back to top
View user's profile Send private message
vitriol
Apprentice
Apprentice


Joined: 01 Nov 2003
Posts: 162
Location: US

PostPosted: Tue Aug 03, 2004 9:06 pm    Post subject: Reply with quote

I've just now noticed something strange:

the MAC address that my card sees when trying to start up is 00:0F:B3:37:EF:25

Code:

root@obfuscated ~ # /etc/init.d/net.ath0 start
 * Running preup function
 *   Configuring wireless network for ath0
 *   Scanning for access points
 *     Found "network" at 00:0F:B3:37:EF:25 (WEP required)
 *   Trying to force preferred incase they are hidden
 *   Connecting to "NETWORK" (WEP enabled)...                           [ !! ]

 *   Failed to associate with any preferred access points on ath0
 * Couldn't associate with any access points on ath0
 * Failed to configure wireless for ath0
 * preup ath0 failed


But the actual MAC is 00:0F:B3:37:EF:22. Could this be the cause of my troubles?
_________________
The specs on the box said windows 98 or better, so I installed gentoo.
Back to top
View user's profile Send private message
teedog
Apprentice
Apprentice


Joined: 09 Mar 2004
Posts: 211

PostPosted: Tue Aug 03, 2004 11:10 pm    Post subject: Reply with quote

tursiops wrote:
I found what my inboard wireless card is:
Intel Corp, Pro / Wireless 2200BG (rev 05)

Now what driver must I use pls?

Thanks!


Unfortunately IPW2200's native linux drivers are not functional yet. Use Ndiswrapper and the Windows drivers.

http://ndiswrapper.sf.net/
Back to top
View user's profile Send private message
UberLord
Retired Dev
Retired Dev


Joined: 18 Sep 2003
Posts: 6452
Location: Blighty

PostPosted: Wed Aug 04, 2004 7:36 am    Post subject: Reply with quote

vitriol wrote:
Wow! Thanks!! Works great now..well, except for WEP. It works if I disable WEP, but I'm wondering if I have the WEP key in the wrong format or something.

Code:

root@obfuscated ~ # /etc/init.d/net.ath0 start
  * Running preup function
 *   Configuring wireless network for ath0
 *   Scanning for access points
 *     Found "network" at 00:0F:B3:37:EF:25 (WEP required)
 *   Trying to force preferred incase they are hidden
 *   Connecting to "NETWORK" (WEP enabled)...                           [ !! ]

 *   Failed to associate with any preferred access points on ath0
 *   WEP key is not set for "network" - not connecting
 * Couldn't associate with any access points on ath0
 * Failed to configure wireless for ath0
 * preup ath0 failed


ESSID is case sensitive.

NETWORK != network

The MAC address reported is the wireless MAC of the AP.
So if you have a wireless router, it will have different MAC's for ethernet ports (all of them I think) and the wireless.
_________________
Use dhcpcd for all your automated network configuration needs
Ask for dhcpcd-ui (GTK+/Qt System Tray Network tool) to be added to Gentoo
Back to top
View user's profile Send private message
vitriol
Apprentice
Apprentice


Joined: 01 Nov 2003
Posts: 162
Location: US

PostPosted: Wed Aug 04, 2004 3:25 pm    Post subject: Reply with quote

Quote:

ESSID is case sensitive.

NETWORK != network

The MAC address reported is the wireless MAC of the AP.
So if you have a wireless router, it will have different MAC's for ethernet ports (all of them I think) and the wireless.


Thank you, I've learned quite a bit from this experience. You were, of course, right. That was the problem....now I'm having a problem that seems to pop up with alot of other wireless users:

Code:

* Bringing ath0 up...
 *   ath0 dhcp                                                          [ !! ]


I've seen in prior posts that other people with this problem were suggested to disable WEP. I did this, but I'm still getting the same results. So is the cvs version of madwifi fixing this problem for others? I made sure WEP was off and that my DHCP server is functioning. Try other channels?
_________________
The specs on the box said windows 98 or better, so I installed gentoo.
Back to top
View user's profile Send private message
eisenack
n00b
n00b


Joined: 07 Apr 2004
Posts: 23

PostPosted: Wed Aug 04, 2004 5:19 pm    Post subject: Reply with quote

Again thanks to Uberlord for this HowTo.
Unfortunately when one encounters a problem, it has gotten a bit complex finding the answer somewhere in almost 50 pages.
Not last because the "forums.gentoo.org" search function is quite bad (no search for phrases, only for a list of words and it does not show on which of the 50 pages the search result can be found)
Perhaps I find the time to volunteer making a special homepage with all this stuff on it.

NOW MY PROBLEM:

WLAN works WITHOUT WEP,
but DOESN'T WITH WEP.

("doesn't work" means: everything starts up, but dhcp does not receive anything and a static ip doesn't help either: no pings)

I have an Allnet ALL0192 PCMCIA WLAN card in my PowerBook 17" and I'm using kernel 2.6 (pegasos-dev-sources-2.6.7-r4).

These are my loaded modules (though I don't think this is significant to the problem):

Code:

# lsmod
Module                  Size  Used by
...
orinoco_cs             10728  1
orinoco                50292  1 orinoco_cs
hermes                 15264  2 orinoco_cs,orinoco
ds                     22788  3 orinoco_cs
yenta_socket           22304  1
pcmcia_core            78872  3 orinoco_cs,ds,yenta_socket
...


What I think is very strange, are the /var/log/messages errors:
Code:
Aug  4 18:50:13 lappi eth1: New link status: Disconnected (0002)
Aug  4 18:50:15 lappi eth1: New link status: Disconnected (0002)
Aug  4 18:50:16 lappi eth1: Error -110 setting multicast list.
Aug  4 18:50:16 lappi eth1: New link status: Connected (0001)
Aug  4 18:50:17 lappi eth1: Error -110 setting multicast list.
Aug  4 18:50:17 lappi eth1: Error -110 setting multicast list.
Aug  4 18:50:17 lappi eth1: New link status: Association Failed (0006)
Aug  4 18:50:19 lappi eth1: New link status: Connected (0001)
Aug  4 18:50:21 lappi dhcpcd[467]: infinite IP address lease time. Exiting


These errors occure WITH AND WITHOUT WEP, but as mentioned, everything (DHCP, pinging, surfing :-) ) works WITHOUT WEP but not WITH.

My questions:
- Why doesn't it work WITH WEP ? And do errors in /var/log/messages have something to do with it ?
- What is the "Error -110 setting multicast list." complaining about ?
- What means "Association Failed (0006)" ? Who is associating ?

Thank you in advance.
Regards,
Frank
Back to top
View user's profile Send private message
vitriol
Apprentice
Apprentice


Joined: 01 Nov 2003
Posts: 162
Location: US

PostPosted: Wed Aug 04, 2004 11:10 pm    Post subject: Reply with quote

Didn't realize you could get dhcpcd output from /var/log/messages. I've tried 5 different channels and still can't get an address from the dhcp server. Works fine when i'm plugged in with an ethernet cable. It also works perfectly when I boot into my wife's windows xp partition.

Code:

Aug  4 09:06:41 obfuscated ath0: association failed (reason 1) for 00:0f:b3:37:ef:25
Aug  4 09:06:48 obfuscated ath0: association failed (reason 1) for 00:0f:b3:37:ef:25
Aug  4 09:06:55 obfuscated ath0: association failed (reason 1) for 00:0f:b3:37:ef:25
Aug  4 09:07:02 obfuscated ath0: association failed (reason 1) for 00:0f:b3:37:ef:25
Aug  4 09:07:09 obfuscated ath0: association failed (reason 1) for 00:0f:b3:37:ef:25
Aug  4 09:07:16 obfuscated ath0: association failed (reason 1) for 00:0f:b3:37:ef:25
Aug  4 09:07:23 obfuscated ath0: association failed (reason 1) for 00:0f:b3:37:ef:25
Aug  4 09:07:30 obfuscated ath0: association failed (reason 1) for 00:0f:b3:37:ef:25
Aug  4 09:07:37 obfuscated ath0: association failed (reason 1) for 00:0f:b3:37:ef:25
Aug  4 09:07:39 obfuscated dhcpcd[15909]: timed out waiting for a valid DHCP server response

_________________
The specs on the box said windows 98 or better, so I installed gentoo.
Back to top
View user's profile Send private message
OkeyMor57
n00b
n00b


Joined: 28 Feb 2003
Posts: 45
Location: FortWorth

PostPosted: Thu Aug 05, 2004 1:02 am    Post subject: Reply with quote

Everything worked fine until I upgraded to baselayout-1.10.2. I lost wireless connectivity. I up-graded to wireless-config-0.5.5.ebuild and now I get an error message
Quote:
etc/init.d/wireless.sh: line 759: error: command not found
* Failed to configure wireless for eth0
* preup eth0 failed


line 759 call wireless_up() and I cannot seem to find any place where the function is defined. I am at a loss
Back to top
View user's profile Send private message
OkeyMor57
n00b
n00b


Joined: 28 Feb 2003
Posts: 45
Location: FortWorth

PostPosted: Thu Aug 05, 2004 2:22 am    Post subject: solved Reply with quote

I added
Quote:
iwconfig_eth0="dhcp"
and that seem to solve the problem.
I use ifplugd to manage network connections, if I execute
Code:
/etc/init.d/ifplugd restart
, wireless network fails to start but reports that it is already running.

I need to look into that, for now I am happy I do not have to tie myself to the hub.
Back to top
View user's profile Send private message
UberLord
Retired Dev
Retired Dev


Joined: 18 Sep 2003
Posts: 6452
Location: Blighty

PostPosted: Thu Aug 05, 2004 8:32 am    Post subject: Reply with quote

I'm getting really tired about why WEP doesn't work - it doesn't work because you haven't configured it correctly. Please read the 1st page FAQ on WEP.

Basically, if you can prove that you can get wep to work on the command line
Code:
iwconfig eth0 key s:thiskey
dhcpcd eth0
ping <your gateway ip>

and not using this config script then it is a bug - or an error your config - and I will fix it.

@eisenack
I used to get those messages all the time with my old orinoco card. Except for the failed association (which is a WEP problem afaik)

@vitriol
The CVS version is much better than the portage one. It may fix your DHCP problem
_________________
Use dhcpcd for all your automated network configuration needs
Ask for dhcpcd-ui (GTK+/Qt System Tray Network tool) to be added to Gentoo
Back to top
View user's profile Send private message
vitriol
Apprentice
Apprentice


Joined: 01 Nov 2003
Posts: 162
Location: US

PostPosted: Thu Aug 05, 2004 5:23 pm    Post subject: Reply with quote

UberLord wrote:

@vitriol
The CVS version is much better than the portage one. It may fix your DHCP problem


Thanks, that never occured to me :) I've read most of the 48 (so far) pages on this thread and it seems like there are alot of duplicate questions...maybe someone could set up a more detailed FAQ covering alot of these questions? I am sorry if anything I've asked has been excessively redundant.
_________________
The specs on the box said windows 98 or better, so I installed gentoo.
Back to top
View user's profile Send private message
vitriol
Apprentice
Apprentice


Joined: 01 Nov 2003
Posts: 162
Location: US

PostPosted: Fri Aug 06, 2004 12:28 am    Post subject: Reply with quote

I installed madwifi cvs, but am still stuck at the same dhcp problem. I'm about out of ideas and went through dmesg to see if maybe I could be missing some vital detail.

ath0: association failed (reason 1) for 00:0f:b3:37:ef:25

Not much relevant information there :(

wlan: 0.7.3.2 BETA
ath_hal: 0.9.9.13
ath_pci: 0.8.6.1 BETA
ath_pci: 0.8.6.1 BETA


^^^^^ madwifi cvs is installed. I'm lost...completely out of ideas. I can't stand to not be able to solve a problem like this. argh!
_________________
The specs on the box said windows 98 or better, so I installed gentoo.
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Networking & Security All times are GMT
Goto page Previous  1, 2, 3 ... 47, 48, 49 ... 57, 58, 59  Next
Page 48 of 59

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum