Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problems with shutdown -h now
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
+BroNNoS+
n00b
n00b


Joined: 17 Apr 2002
Posts: 46
Location: Groningen, The Netherlands

PostPosted: Wed Apr 17, 2002 10:16 pm    Post subject: Problems with shutdown -h now Reply with quote

Hi all,

Has anyone else expirienced problems when doing a 'shutdown -h now'? I get the following:

flushing ide devices: hda, hdb etc
Power Down
/sbin/rc: return : can only 'return' from a function or sourced script

and the computer hangs.

Thanks
Back to top
View user's profile Send private message
gschneider
Tux's lil' helper
Tux's lil' helper


Joined: 10 Apr 2002
Posts: 81
Location: Darmstadt, Germany

PostPosted: Thu Apr 18, 2002 8:27 am    Post subject: Reply with quote

I have the same message.
but it doesnt hang, the kernel just doesn't shut the computer off.
You have forgotten to enable APM, ACPI and/or APIC in kernel setup. (I'm not sure which is responsible for it, I think it is ACPI).

So you need to recompile your kernel.
_________________
/(bb|[^b]{2})/
Back to top
View user's profile Send private message
+BroNNoS+
n00b
n00b


Joined: 17 Apr 2002
Posts: 46
Location: Groningen, The Netherlands

PostPosted: Thu Apr 18, 2002 8:33 am    Post subject: Reply with quote

Thanks, will look into it tonight. But I'm almost sure I compiled it in already. I already figured out it has to do something with APM, APIC and ACPI stuff. I shall look into the power options more closely.
Back to top
View user's profile Send private message
Framba
n00b
n00b


Joined: 18 Apr 2002
Posts: 18
Location: Italy

PostPosted: Thu Apr 18, 2002 11:24 am    Post subject: Reply with quote

If you find it, can you tell me? I didn't compile nor ACPI nor other Power Management and I would like to keep the kernel as light as I can. Thanks
Back to top
View user's profile Send private message
Jeevz
Bodhisattva
Bodhisattva


Joined: 15 Apr 2002
Posts: 195
Location: Boston, MA

PostPosted: Thu Apr 18, 2002 8:05 pm    Post subject: Reply with quote

Hmm... if I remember correctly you can compile APM/ACPI as a module. If you can, and did, make sure you load it.
Back to top
View user's profile Send private message
Fragadelic
n00b
n00b


Joined: 18 Apr 2002
Posts: 26

PostPosted: Thu Apr 18, 2002 8:27 pm    Post subject: Reply with quote

Framba wrote:
If you find it, can you tell me? I didn't compile nor ACPI nor other Power Management and I would like to keep the kernel as light as I can. Thanks


If you want it to automatically power off after shutdown, you MUST include ACPI or APM in the kernel, depending on your motherboard capabilities. Without it there is no way to tell the motherboard to power the system off.

I need to recompile my kernel as it just reboots instead of powering off but it hasn't been a big priority with me. I might fix it tonight if I get a chance.
Back to top
View user's profile Send private message
Fragadelic
n00b
n00b


Joined: 18 Apr 2002
Posts: 26

PostPosted: Fri Apr 19, 2002 3:14 am    Post subject: Reply with quote

Okay, I recompiled my kernel tonight and the shutdown to power down works.

If you have an ACPI enabled motherboard you need to include the following in the kernel compile.

I recommend using 'make menuconfig'.

Under the 'General Setup', include the following:

[*] Power Management support
[*] ACPI support
[ ] ACPI Debug Statements
<*> ACPI Bus Manager
<*> System
< > Processor
< > Button
< > AC Adapter
< > Embedded Controller

You can check the help on the other options but that is all you need for power off after shutdown.
Back to top
View user's profile Send private message
sven
Apprentice
Apprentice


Joined: 19 Apr 2002
Posts: 274

PostPosted: Fri Apr 19, 2002 11:40 am    Post subject: Reply with quote

My computer also does not power down though I enabled ACPI and APM in my kernel. I get the same script error message after halting the system... This is how my kernel config looks like

[*] Power Management support
[*] ACPI support
[ ] ACPI Debug Statements
<*> ACPI Bus Manager
<*> System
<*> Processor
<*> Button
< > AC Adapter
< > Embedded Controller
<*> Advanced Power Management BIOS support
[ ] Ignore USER SUSPEND
[*] Enable PM at boot time
[*] Make CPU Idle calls when idle
[ ] Enable console blanking using APM
[ ] RTC stores time in GMT
[ ] Allow interrupts during APM BIOS calls
[*] Use real mode APM BIOS call to power off

I have an Epox KHAL mainboard...
Back to top
View user's profile Send private message
Fragadelic
n00b
n00b


Joined: 18 Apr 2002
Posts: 26

PostPosted: Fri Apr 19, 2002 11:48 am    Post subject: Reply with quote

If you have ACPI enabled then you should not have APM enabled. They will conflict with each other.

Disable the APM stuff and try again.
Back to top
View user's profile Send private message
sven
Apprentice
Apprentice


Joined: 19 Apr 2002
Posts: 274

PostPosted: Fri Apr 19, 2002 12:01 pm    Post subject: Reply with quote

Just did it and now it works! Thank you very much!
I just could have fixed the problem myself if I had taken a look into my BIOS setup before! Doh! ;)

Everybody who experiences the same problem should check if the BIOS supports ACPI or APM and enable/disable these in the kernel. I guess all modern mainboards use ACPI.
Back to top
View user's profile Send private message
niyogi
Apprentice
Apprentice


Joined: 10 Apr 2002
Posts: 199
Location: Austin, TX

PostPosted: Fri Apr 19, 2002 9:41 pm    Post subject: Reply with quote

cool.. i was having this problem too (although i didn't really regard it so much as a major one
Back to top
View user's profile Send private message
feend
n00b
n00b


Joined: 19 Apr 2002
Posts: 3

PostPosted: Fri Apr 19, 2002 10:50 pm    Post subject: Reply with quote

Hey it's Guybrush Threepwood! :)

Anyway. Did the /sbin/rc message ever go away out of
curiosity?
Back to top
View user's profile Send private message
+BroNNoS+
n00b
n00b


Joined: 17 Apr 2002
Posts: 46
Location: Groningen, The Netherlands

PostPosted: Sat Apr 20, 2002 12:15 am    Post subject: Reply with quote

Got it now:

- Had to recompile the kernel with no SMP support
- Had probs with kernel compilation after this change
- Had to do mrproper (thx fghellar)
- Had some troubles with 'unresolved symbols' with 'make modules'
- Deleted all modules in etc/modules (thx Google), did it again
- After this had problems with sound module, but fixed that also
- All in all compiled the kernel about 20 or more times
- But now it shuts down properly!

Man, do I LOVE Linux :-))).
Back to top
View user's profile Send private message
Jeevz
Bodhisattva
Bodhisattva


Joined: 15 Apr 2002
Posts: 195
Location: Boston, MA

PostPosted: Sat Apr 20, 2002 12:41 am    Post subject: Reply with quote

Do you need to get the acpid package to make full use of this?
Back to top
View user's profile Send private message
Guest






PostPosted: Sat Apr 20, 2002 8:46 pm    Post subject: Doesn't completely work for me :( Reply with quote

I've enabled all ACPI options, but when I shut down, my optical mouse and NIC don't power off. The NIC stays on-line and the light in my mouse still burns.

Could someone pleaze tell me what's going on?! And how te solve it :roll:


Thanx
Back to top
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16113
Location: Colorado

PostPosted: Sat Apr 20, 2002 9:26 pm    Post subject: Re: Doesn't completely work for me :( Reply with quote

Anonymous wrote:
I've enabled all ACPI options, but when I shut down, my optical mouse and NIC don't power off. The NIC stays on-line and the light in my mouse still burns.

Could someone pleaze tell me what's going on?! And how te solve it :roll:


Thanx


I've heard this (mouse anyway) can be a problem or minor "bug" with some motherboards.
For the NIC, some have a wake-on-lan setting. That implies that the NIC won't shut "off".
Not positive, those are just suggestions.

On a side not, I have a Gigabyte MB with a Slot A Athlon... my optical mouse stays on
even when I just used Windows..
Back to top
View user's profile Send private message
knopper
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2002
Posts: 104
Location: The Netherlands

PostPosted: Sun Apr 21, 2002 8:21 am    Post subject: Reply with quote

No when I shut down in Windows it all works fine. And I don't use Wake up on LAN (the cable isn't connected) And like I said, in Windows (XP) everthing goes off correctly.


I'm the same user as "guest" but now i'm logged in :lol:
Back to top
View user's profile Send private message
lodger
n00b
n00b


Joined: 16 Apr 2002
Posts: 53

PostPosted: Sun Apr 21, 2002 3:33 pm    Post subject: Reply with quote

shutdown -h powers off hda but not hdb where I have gentoo
Back to top
View user's profile Send private message
knopper
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2002
Posts: 104
Location: The Netherlands

PostPosted: Sun Apr 21, 2002 6:51 pm    Post subject: Reply with quote

lodger wrote:
shutdown -h powers off hda but not hdb where I have gentoo


Ooh, great :roll:
Back to top
View user's profile Send private message
lain iwakura
Apprentice
Apprentice


Joined: 09 May 2002
Posts: 176
Location: sd, ca

PostPosted: Sun May 19, 2002 3:09 am    Post subject: Reply with quote

I've got a similar problem with the gentoo r1 sources.

I've compiled in ACPI support, bus and system support, and when I use 'shutdown -h now' it goes through the shutdown process and and at the end of the sequence, it just says 'POWERING DOWN" but doesn't.

anyone know what could be the deal here?
Back to top
View user's profile Send private message
sibn
n00b
n00b


Joined: 15 May 2002
Posts: 36

PostPosted: Sun May 19, 2002 3:34 am    Post subject: Reply with quote

+BroNNoS+ wrote:
Got it now:

- Had to recompile the kernel with no SMP support
- Had probs with kernel compilation after this change
- Had to do mrproper (thx fghellar)
- Had some troubles with 'unresolved symbols' with 'make modules'
- Deleted all modules in etc/modules (thx Google), did it again
- After this had problems with sound module, but fixed that also
- All in all compiled the kernel about 20 or more times
- But now it shuts down properly!

Man, do I LOVE Linux :-))).


Really? I always found it easier to open /usr/src/linux/Makefile and change EXTRAVERSION (fourth line) to something else before recompiling. Helps to avoid problems with modules (etc.), such as the one you had. :)
_________________
Hey um, this is my signature.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum