Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xine encryption messege
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
rommel
Veteran
Veteran


Joined: 19 Apr 2002
Posts: 1140
Location: Williamsburg Virginia

PostPosted: Tue May 14, 2002 1:03 am    Post subject: xine encryption messege Reply with quote

i am not able to get xine play a dvd this is the out put i get from the konsole

This is xine (X11 gui) - a free video player v0.9.9
(c) 2000-2002 by G. Bartsch and the xine project team.
Built with xine library 0.9.9 [Mon 13 May 2002 19:37:53]-[gcc version 2.95.3 20010315 (release)]-[Linux 2.4.18 i686].
Found xine library version: 0.9.9 (0.9.9).
Display is not using Xinerama.
configfile: error - tried to update non-string type 0 (key video.logo_file, value /usr/share/xine/skins/xine_logo.zyuy2)
video_out_xv: using Xv port 119 from adaptor NV10 Video Overlay for hardware colorspace conversion and scaling.
video_out_xv: double buffering mode = 1
video_out_xv: port attribute XV_COLORKEY value is 66046
video_out_xv: port attribute XV_AUTOPAINT_COLORKEY value is 1
video_out_xv: port attribute XV_BRIGHTNESS value is 0
video_out_xv: port attribute XV_CONTRAST value is 4096
video_out_xv: port attribute XV_SATURATION value is 4096
video_out_xv: port attribute XV_HUE value is 0
video_out_xv: this adaptor supports the yuy2 format.
video_out_xv: this adaptor supports the yv12 format.
load_plugins: video output plugin Xv successfully loaded.
audio_arts_out : supported modes are mono stereo
load_plugins: audio output plugin arts successfully loaded.
xine: xine_init entered
xine: using MMXEXT optimized memcpy()
xine-scr_init: complete
load_plugins: input plugin found : CDA
load_plugins: input plugin found : DVD
load_plugins: input plugin found : stdin_fifo
load_plugins: input plugin found : MMS
load_plugins: input plugin found : TCP
load_plugins: input plugin found : file
load_plugins: input plugin found : RTP
load_plugins: input plugin found : VCD
load_plugins: input plugin found : HTTP
load_plugins: demux plugin found : MPEG_TS
load_plugins: demux plugin found : QUICKTIME
load_plugins: demux plugin found : MPEG
load_plugins: demux plugin found : ASF
load_plugins: demux plugin found : AVI
load_plugins: demux plugin found : CDA
load_plugins: demux plugin found : MPEG_ELEM
load_plugins: demux plugin found : MPEG_PES
load_plugins: demux plugin found : OGG
load_plugins: demux plugin found : MPGAUDIO
load_plugins: demux plugin found : MPEG_BLOCK
video decoder plugin found : vfw (win32) video decoder
audio decoder plugin found : vfw (win32) audio decoder
audio decoder plugin found : a/52dec
audio decoder plugin found : dts
audio decoder plugin found : mad
video decoder plugin found : divx4 video decoder
spu decoder plugin found : spucc
spu decoder plugin found : spudec
video decoder plugin found : mpeg2dec
audio decoder plugin found : lpcm
libavcodec: CPU flags: mmx mmxext sse
video decoder plugin found : ffmpeg video decoder
spu decoder plugin found : sputext
audio decoder plugin found : vorbis
video_out: copying logo image
video_out: thread created
metronom: start_clock (at 0)
input_cda: open(/dev/cdaudio) failed: No such file or directory.
input_cda: open(/dev/cdaudio) failed: No such file or directory.
xine_play: xine open dvd://VTS_01_0.VOB, start pos = 0, start time = 0 (sec)

input_dvd: Sorry, xine doesn't play encrypted DVDs. The legal status of CSS
decryption is unclear and we will not provide such code.


input_dvd: Sorry, xine doesn't play encrypted DVDs. The legal status of CSS
decryption is unclear and we will not provide such code.

input_dvd: Unable to find >VTS_01_0.VOB< on dvd.
input_dvd: Unable to find >VTS_01_0.VOB< on dvd.
input_mms: trying to open 'dvd://VTS_01_0.VOB'
libmms: invalid url >dvd://VTS_01_0.VOB< (should be mms:// - style)
xine: cannot find input plugin for this MRL

does anyone know why this is not installing or do you have to patch this in some what to get aroung the encryption stuff...anyone ...anyclue?

ciao
Back to top
View user's profile Send private message
Guest






PostPosted: Tue May 14, 2002 1:15 am    Post subject: Reply with quote

Install one of decss enabled dvd plugins: xine-d4d, xine-d5d, or xine-dvdnav. I like d5d personally, but dvdnav is supposedly nice too (Didn't work for me).
Back to top
rommel
Veteran
Veteran


Joined: 19 Apr 2002
Posts: 1140
Location: Williamsburg Virginia

PostPosted: Tue May 14, 2002 1:47 am    Post subject: Reply with quote

this is waht happens with d4d installed

This is xine (X11 gui) - a free video player v0.9.9
(c) 2000-2002 by G. Bartsch and the xine project team.
Built with xine library 0.9.9 [Mon 13 May 2002 19:37:53]-[gcc version 2.95.3 20010315 (release)]-[Linux 2.4.18 i686].
Found xine library version: 0.9.9 (0.9.9).
Display is not using Xinerama.
configfile: error - tried to update non-string type 0 (key video.logo_file, value /usr/share/xine/skins/xine_logo.zyuy2)
video_out_xv: using Xv port 119 from adaptor NV10 Video Overlay for hardware colorspace conversion and scaling.
video_out_xv: double buffering mode = 1
video_out_xv: port attribute XV_COLORKEY value is 66046
video_out_xv: port attribute XV_AUTOPAINT_COLORKEY value is 1
video_out_xv: port attribute XV_BRIGHTNESS value is 0
video_out_xv: port attribute XV_CONTRAST value is 4096
video_out_xv: port attribute XV_SATURATION value is 4096
video_out_xv: port attribute XV_HUE value is 0
video_out_xv: this adaptor supports the yuy2 format.
video_out_xv: this adaptor supports the yv12 format.
load_plugins: video output plugin Xv successfully loaded.
audio_arts_out : supported modes are mono stereo
load_plugins: audio output plugin arts successfully loaded.
xine: xine_init entered
xine: using MMXEXT optimized memcpy()
xine-scr_init: complete
input_d4d: unable to open raw dvd drive (/dev/rdvd): No such file or directory
load_plugins: input plugin found : d4d
load_plugins: input plugin found : CDA
load_plugins: input plugin found : DVD
load_plugins: input plugin found : stdin_fifo
load_plugins: input plugin found : MMS
load_plugins: input plugin found : TCP
load_plugins: input plugin found : file
load_plugins: input plugin found : RTP
load_plugins: input plugin found : VCD
load_plugins: input plugin found : HTTP
load_plugins: demux plugin found : MPEG_TS
load_plugins: demux plugin found : QUICKTIME
load_plugins: demux plugin found : MPEG
load_plugins: demux plugin found : ASF
load_plugins: demux plugin found : AVI
load_plugins: demux plugin found : CDA
load_plugins: demux plugin found : MPEG_ELEM
load_plugins: demux plugin found : MPEG_PES
load_plugins: demux plugin found : OGG
load_plugins: demux plugin found : MPGAUDIO
load_plugins: demux plugin found : MPEG_BLOCK
video decoder plugin found : vfw (win32) video decoder
audio decoder plugin found : vfw (win32) audio decoder
audio decoder plugin found : a/52dec
audio decoder plugin found : dts
audio decoder plugin found : mad
video decoder plugin found : divx4 video decoder
spu decoder plugin found : spucc
spu decoder plugin found : spudec
video decoder plugin found : mpeg2dec
audio decoder plugin found : lpcm
libavcodec: CPU flags: mmx mmxext sse
video decoder plugin found : ffmpeg video decoder
spu decoder plugin found : sputext
audio decoder plugin found : vorbis
video_out: copying logo image
video_out: thread created
metronom: start_clock (at 0)
xine_play: xine open d4d://i1t0c0t0, start pos = 0, start time = 0 (sec)
input_d4d : input_plugin_open media type correct. file name is i1t0c0t0
input_d4d: playing title 0 from chapter 0 -> chapter 0
input_d4d: chapter encrypted
input_d4d: lb_end 158644 title_start 79715 cellp_pos 78929
input length : 161648640
xine: using input plugin >d4d< for this MRL (d4d://i1t0c0t0).
using input plugin 'd4d' for MRL 'd4d://i1t0c0t0'
input_d4d: 4 bytes is not a sector
demux_mpeg_block: mrl d4d://i1t0c0t0 is new, will estimated bitrate
system layer format 'MPEG_BLOCK' detected.
metronom: video discontinuity #1, type is 0, disc_off is 0
metronom: waiting for audio discontinuity #1
metronom: audio discontinuity #1, type is 0, disc_off 0
metronom: audio vpts adjusted with prebuffer to 3680681
metronom: waiting for in_discontinuity update #1
metronom: video vpts adjusted to 3680681
input_d4d : chapter end reached (80270 + 79715 >= 158644)
input_d4d: dvd_plugin_next_lb returned 0
video_decoder: new pts 3735
metronom: video discontinuity #2, type is 2, disc_off is 3735
metronom: waiting for audio discontinuity #2
metronom: audio discontinuity #2, type is 2, disc_off 3735
metronom: audio vpts adjusted with prebuffer to 3837691
metronom: waiting for in_discontinuity update #2
metronom: video vpts adjusted to 3837691
Using MMXEXT for IDCT transform
Using MMXEXT for motion compensation
video_decoder: using decoder >mpeg2dec<
using video decoder plugin 'mpeg2dec'
libmpeg2: frame size is 0 x 0, ratio is 4
libmpeg2: frame size has changed to from 0 x 0 to 720 x 480
libmpeg2: old frames freed.
audio_decoder: using audio decoder plugin 'a/52dec'
audio_out: stream audio format is 48000 kHz sampling rate, 16 bits. mode is 8.
audio_arts_out: ao_open bits=16 rate=48000, mode=8
audio_arts_out: 2 channels output
Segmentation fault

i must need to configure something differently....
Back to top
View user's profile Send private message
ASCI Blue
Tux's lil' helper
Tux's lil' helper


Joined: 07 May 2002
Posts: 132

PostPosted: Tue May 14, 2002 2:12 am    Post subject: Reply with quote

I just tried out that d5d plugin, and it worked. :D
Back to top
View user's profile Send private message
Guest






PostPosted: Tue May 14, 2002 3:50 am    Post subject: Reply with quote

ok so what did you do...like what order did you emerge and what pkgs total?...unless you wnat to keep a secret...lol
Back to top
rommel
Veteran
Veteran


Joined: 19 Apr 2002
Posts: 1140
Location: Williamsburg Virginia

PostPosted: Tue May 14, 2002 4:06 am    Post subject: Reply with quote

well i just unmerged all the xine stuff and emerged ogle...ihad already installed the libdvdcss tar.gz from hteir site adn its working perfectly...go figure.
Back to top
View user's profile Send private message
ShadowIce
n00b
n00b


Joined: 12 May 2002
Posts: 20
Location: Germany

PostPosted: Fri May 17, 2002 7:32 pm    Post subject: Reply with quote

I get the same error in xine when trying to play a dvd, so I installed ogle. But that program crashes after 4 seconds of playing.

Messages:
opening a 2 channel audio driver
No accelerated IMDCT transform found
Note[ogle_a52]: resetting offset
!!!Sample rate 48000
Note[ogle_a52]: resetting offset
Note[ogle_a52]: resetting offset
#Note[ogle_a52]: resetting offset
*demux: Segmentation fault
Debug[ogle_ctrl]: child: 21103 exited with 0
Debug[ogle_ctrl]: pid: 21103 exited with status: 0
Debug[ogle_ctrl]: child: 21101 killed
Debug[ogle_ctrl]: pid: 21101 terminated on signal: 2
Debug[ogle_ctrl]: child: 21104 exited with 0
Debug[ogle_ctrl]: pid: 21104 exited with status: 0
Debug[ogle_ctrl]: slaying child: 21102
.......
Debug[ogle_ctrl]: removing shmid: 57737223
ctrl: ipc_rmid: Invalid argument
Debug[ogle_ctrl]: removing shmid: 57769992
Debug[ogle_ctrl]: removing shmid: 58458121
Note[ogle_ctrl]: exiting

Any help/ideas?
_________________
Go on, prove me wrong. Destroy the fabric of the universe. See if I care.
-- Terry Pratchett
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum