Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
DVD-toisto
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Finnish
View previous topic :: View next topic  
Author Message
Toomuch
n00b
n00b


Joined: 16 Mar 2004
Posts: 45

PostPosted: Sat May 08, 2004 8:38 pm    Post subject: DVD-toisto Reply with quote

Pitkästä tunaamisesta huolimatta en ole saanut DVD:itä pyörimään kunnolla. Ääni toimii mutta kuva tökkii. Vaikka koneeni on vanha, jää prossutehosta Setiathomelle 30% joten vika on jossain muualla. Lisäksi taannoisella Mandrake-harharetkelläni sekä Windowsissa dvd toimi hyvin.

Prossu on siis P2-350MHz, näytönohjain NVidia GeForce32MX, muistia 320MB, dvd-asema Liteon DVD/CDRW combo (DMA, 32-bit w/sync, unmaskirq, readahead 64)

Kerneli on 2.6.5-love4, Nvidian kernel module toimii (opengl pelittää), ei rivafbtä, ääniä pyörittelee alsa. Sama ongelma toistuu Xinessä, MPlayerissä ja Oglessa. Xinen bufferoinnin lisääminen ei auta.

Mitäköhän tässä vielä yrittäisi?

t
Back to top
View user's profile Send private message
Tronic
Apprentice
Apprentice


Joined: 28 Jul 2003
Posts: 194
Location: Finland

PostPosted: Sat May 08, 2004 10:32 pm    Post subject: Reply with quote

Onko UDMA päällä?

(emerge hdparm)
hdparm -c3 -m16 -d1 -u1 <tähän kaikki IDE-laitteet, erityisesti DVD-asema>

Jos tuon jälkeen toimii, editoi /etc/conf.d/hdparm, laita sinne tuo vastaava "-c3 -m16 -d1 -u1"-rotla ja lisää hdparm käynnistymään default-runlevelillä:
rc-update add hdparm default
_________________
There are no alternative energy sources to fossil fuels. Whoever claims otherwise doesn't know the difference between mW and MW. -Kurki-Suonio
Back to top
View user's profile Send private message
Toomuch
n00b
n00b


Joined: 16 Mar 2004
Posts: 45

PostPosted: Sun May 09, 2004 8:31 pm    Post subject: Reply with quote

Tronic wrote:
Onko UDMA päällä?


on, hdparmissa on määritetty

Code:
cdrom0_args="-d1 -a64 -u1 -c3"


onkohan tuolla read-aheadin koolla minkälainen merkitys?

enivei, spekseihin piti lisätä että emo on p2b, näytönohjain on agp-väylässä ja agpgart on käännetty kerneliin. mitähän oleellista tieto vielä puuttuu?

en oikein usko että kyse on tuostakaan kun dvd lukee kovin rennon näköisesti dataa ja välillä on tullut ilmoitus 'too much data in buffer' tjsp.

t
Back to top
View user's profile Send private message
Tronic
Apprentice
Apprentice


Joined: 28 Jul 2003
Posts: 194
Location: Finland

PostPosted: Mon May 10, 2004 4:49 pm    Post subject: Reply with quote

Kokeile mplayer -ao none ja mplayer -vo null tai edellisten yhdistelmää ja katso vieläkö tökkii (kellon pitäisi pyöriä oikealla vauhdilla, eikä saa tulla "your computer is too slow to play this").
_________________
There are no alternative energy sources to fossil fuels. Whoever claims otherwise doesn't know the difference between mW and MW. -Kurki-Suonio
Back to top
View user's profile Send private message
Toomuch
n00b
n00b


Joined: 16 Mar 2004
Posts: 45

PostPosted: Mon May 10, 2004 9:41 pm    Post subject: Reply with quote

Tronic wrote:
Kokeile mplayer -ao none ja mplayer -vo null tai edellisten yhdistelmää ja katso vieläkö tökkii (kellon pitäisi pyöriä oikealla vauhdilla, eikä saa tulla "your computer is too slow to play this").


no eka kerralla se neuvoi kokeilemaan "echo 1024 > /proc/sys/dev/rtc/max-user-freq" jonka laitoin local.starttiin.
kello pyörii oikein, ääni kuuluu oikein (jos -ao ei o null), mutta kuva tökkii. ei tule ilmoitusta liian hitaasta koneesta.

xinellä kuvaa tulee pehmeästi aina vähäsen ja sit se töksähtelee, oglella kuva pyörii tasaisimmin (huonolla frameratella tosin) mutta ääni rätisee.

tässä vielä mplayerin palaute:

Code:
$ mplayer -ao null -vo null dvd://
MPlayer 1.0pre4-3.3.2 (C) 2000-2004 MPlayer Team

CPU: Intel Celeron Covington/Pentium II Deschutes,Tonga/Pentium II Xeon 351.4 MHz (Family: 6, Stepping: 1)
Detected cache-line size is 32 bytes
CPUflags:  MMX: 1 MMX2: 0 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX

Reading config file /usr/share/mplayer/mplayer.conf
Reading config file /home/tuomas/.mplayer/config
Reading /home/tuomas/.mplayer/codecs.conf: Can't open '/home/tuomas/.mplayer/codecs.conf': No such file or directory
Reading /usr/share/mplayer/codecs.conf: 66 audio & 176 video codecs
font: can't open file: /home/tuomas/.mplayer/font/font.desc
Font /usr/share/mplayer/font/font.desc loaded successfully! (206 chars)
Using Linux hardware RTC timing (1024Hz).
Can't open input config file /home/tuomas/.mplayer/input.conf: No such file or directory
Input config file /usr/share/mplayer/input.conf parsed: 53 binds

Playing dvd://.
Reading disc structure, please wait...
There are 18 titles on this DVD.
There are 4 chapters in this DVD title.
There are 1 angles in this DVD title.
DVD successfully opened.
Cache fill: 18.36% (1540096 bytes)    MPEG-PS file format detected.
VIDEO:  MPEG2  720x480  (aspect 2)  29.970 fps  5400.0 kbps (675.0 kbyte/s)
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
No accelerated IMDCT transform found
AC3: 2.0 (stereo)  48000 Hz  224.0 kbit/s
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, 16 bit (0x10), ratio: 28000->192000 (224.0 kbit)
Selected audio codec: [a52] afm:liba52 (AC3-liba52)
==========================================================================
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 480 (preferred csp: Mpeg PES)
VDec: using Mpeg PES as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [null] 720x480 => 720x540 Mpeg PES
Selected video codec: [mpegpes] vfm:mpegpes (Mpeg PES output (.mpg or Dxr3/DVB card))
==========================================================================
Checking audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 48000 hz, little endian signed int
AF_pre: 48000Hz 2ch Signed 16-bit (Little-Endian)
AO: [null] 48000Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
Starting playback...
A:  15.4 V:  15.4 A-V:  0.004 ct:  0.048  456/456   0%  0%  5.2% 0 0 46%


t
Back to top
View user's profile Send private message
Tronic
Apprentice
Apprentice


Joined: 28 Jul 2003
Posts: 194
Location: Finland

PostPosted: Mon May 10, 2004 10:31 pm    Post subject: Reply with quote

Okei, seuraavaksi
-vo xv (rautaskaalaus, overlay)
-vo x11 (softalla, ei skaalausta)
-vo aa (tekstirendaus, jos käänsit tuen tälle, eli USE="aalib" vai oliko "aa")

Jos xv ei toimi ollenkaan, on näyttödriverin asetuksissa jotain mätää. Jos xv toimii hitaasti, on näyttödriverissa jotain mätää (ATI:lla turhankin tuttua). Yleensä x11 on "idioottivarma" ratkaisu, mutta se kyllä vetää sitten konetehoa aika runsaasti (erityisesti jos sanoo vielä -zoom, jolloin kuva skaalataan softalla).

Aalib on sitten sellainen toisenlainen ratkaisu, jolla voi hyvin pitkälti eliminoida näyttöongelmat, mutta näkee silti kuvan... Voi testailla vaikka konsolissa, ei tartte äksää.
_________________
There are no alternative energy sources to fossil fuels. Whoever claims otherwise doesn't know the difference between mW and MW. -Kurki-Suonio
Back to top
View user's profile Send private message
Toomuch
n00b
n00b


Joined: 16 Mar 2004
Posts: 45

PostPosted: Tue May 11, 2004 9:39 pm    Post subject: Reply with quote

Tronic wrote:
Okei, seuraavaksi
-vo xv (rautaskaalaus, overlay)
-vo x11 (softalla, ei skaalausta)
-vo aa (tekstirendaus, jos käänsit tuen tälle, eli USE="aalib" vai oliko "aa")


Kaikissa näissä sama lopputulos, eli tonne 49%:iin putoo. x11 ja aa antaa lisäksi 'Your system is too slow to play this' kun taas xv ei anna.

aa onkin aika jännä ilmestys :) -ao:n vaihtaminen sdl:ään ei vaikuttanut mitenkään, täytyy vielä kokeilla jotakin muuta.

t
Back to top
View user's profile Send private message
Tronic
Apprentice
Apprentice


Joined: 28 Jul 2003
Posts: 194
Location: Finland

PostPosted: Wed May 12, 2004 1:41 am    Post subject: Reply with quote

Kummallisen alhainen CPU-kulutus, jos vielä jää 49 % muuhunkin. Pitäisi kyllä ottaa huomattavasti enemmän tuollaisella koneella. Kokeile lopettaa kaikki muut CPU:ta merkittävästi käyttävät ohjelmat.
_________________
There are no alternative energy sources to fossil fuels. Whoever claims otherwise doesn't know the difference between mW and MW. -Kurki-Suonio
Back to top
View user's profile Send private message
Toomuch
n00b
n00b


Joined: 16 Mar 2004
Posts: 45

PostPosted: Wed May 12, 2004 7:00 am    Post subject: Reply with quote

Tronic wrote:
Kummallisen alhainen CPU-kulutus, jos vielä jää 49 % muuhunkin. Pitäisi kyllä ottaa huomattavasti enemmän tuollaisella koneella. Kokeile lopettaa kaikki muut CPU:ta merkittävästi käyttävät ohjelmat.


Öö, toi 49% on siis se minkä mplayer antaa tossa viimesenä. Ihan alussa kun kuvassa ei oo mitään se on 99% mut sitten kun alkaa tapahtua niin se tippuu.

Mutta en usko että kyse on cpu:sta, koska hardis- ja softarendauksella tulos on prikulleen sama. Ja toimihan se jopa wintoosassa riittävän hyvin että jaksoi katsoa leffoja läpi, vanhemmalla näytönohjaimella jopa.

t
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Finnish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum