Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
can't move windows in gnome/sawfish
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
nurey
n00b
n00b


Joined: 01 May 2002
Posts: 14
Location: Toronto, Canada

PostPosted: Sun May 12, 2002 11:30 am    Post subject: can't move windows in gnome/sawfish Reply with quote

I've configured something in Sawfish settings which caused a problem whereby I cannot move any windows. Attempting to move a window results in a beep sound.

Anyone know which setting causes this?
Back to top
View user's profile Send private message
Coogee
Apprentice
Apprentice


Joined: 23 Apr 2002
Posts: 184
Location: E.U.

PostPosted: Sun May 12, 2002 5:26 pm    Post subject: Reply with quote

I found out that .sawfishrc must be 100% error free. If it beeps during sawfish startup then you got an error and the configurations in this file are not taken.

I also had this window moving problem, but in my case it had something to do with the merlin extensions. I do not need these extensions, therefore I removed all the "require merlin..." stuff in .sawfishrc.

But if your changes are faulty then you are the only one who knows what to change... :wink:
Back to top
View user's profile Send private message
Da Masta
n00b
n00b


Joined: 28 Apr 2002
Posts: 3

PostPosted: Thu May 16, 2002 11:17 pm    Post subject: Actually, I think the config files are to blame... Reply with quote

I remember that I did not have this problem when logging in as root, only when logging in as a normal user. I looked at the /etc/skel.d dir, and indeed there are certain default .sawfish* files/dirs which are copied to user home dirs when they are created. Since I noticed my root dir didn't have them before I started Gnome for the first time, I simply removed all these sawfish files in my user dir and Gnome/Sawfish runs "fine". I also found that sawfish-merlin extensions seem to load for a brief second on my desktop before disappearing and I've go no clue why.

Anyway, that's just a way to get rid of the beeping, but perhaps is not a real solution. Can someone familiar with sawfish explain why this happens, and also perhaps some solutions to both the original window moving problem and the lack of pager-thingie? The .sawfishrc can be made pristine from /etc/skel.d if necessary, and the copies in those are untouched since my initial emerge of sawfish and friends.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum