Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
XVR-100 Radeon VE experimentation.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
stonent
Veteran
Veteran


Joined: 07 Aug 2003
Posts: 1139
Location: Texas

PostPosted: Sun May 02, 2004 11:42 pm    Post subject: XVR-100 Radeon VE experimentation. Reply with quote

I was doing some perusing of the Sun website and was reading about their XVR-100 video card. So upon finding a pic ( http://www.sun.com/smrc/photos-prod/downloads/ppmicroXVR100-04sm.jpg )

I noticed it was just a regular ATI Radeon VE card.

If you look at the part number on top, you can google for it and find it is in fact a plain Radeon VE/7000 card:

http://www.allstarshop.com/shop/product.asp?store%5Fid=100&pid=7843&sid=R5GVC0V3D1S08NQ9WSJCDQWTBDK29NG4#

There was a post in another sparc forum from a sun employee mentioning because the Macintosh OpenFirmware is related to Sun OpenBoot that a Mac card might work in a Sun workstation.

If it doesn't come up as a primary display, we could try it as a secondary display seeing if Solaris recognized it first and then go from there.

Unfortunately, I have a Radeon VE AGP version so I have no way to do any testing at the moment. Also if you had a XVR-100 card, you could put it in a PC and backup the flash to disk and load it on another card :)

So if anyone has access to a PCI Radeon VE and/or Radeon 7000. I'd be interested in seeing what you can come up with.

The Evil Wizard card here appears to be a perfect match

http://www.newegg.com/app/ViewProductDesc.asp?description=14-131-228&depa=0

This Sapphire card looks close as well, just using a different color PC board

http://www.newegg.com/app/ViewProductDesc.asp?description=14-102-318&depa=0
_________________
Inspiron 4100 & Sun UltraAXe
Portage on Solaris|Dell Laptop Hacks
The way you feel about organized religion is the same way I feel about organized socialism.
Back to top
View user's profile Send private message
rkrenzis
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2004
Posts: 135
Location: USA

PostPosted: Mon Aug 15, 2005 7:20 pm    Post subject: XVR-100 working with FBDEV... Reply with quote

I was able to get the XVR-100 working with FBDEV. Xorg recognizes it as:

Quote:
(II) FBDEV(0): Hardware: ATI Radeon QY (vidmem: 65536k)


But I am unable to get any of the accelerated drivers to work. I have posted my configuration to another thread with my results. Grandted, the xvr-100 is slow with fbdev...but it is better than nothing.

You can get a working configuration for fbdev here for the xvr-100:
http://forums.gentoo.org/viewtopic-t-227308-highlight-xvr100.html

Regards,

Ryan
Back to top
View user's profile Send private message
GenTimJS
Guru
Guru


Joined: 03 May 2003
Posts: 406
Location: NH, USA

PostPosted: Fri Aug 19, 2005 12:48 pm    Post subject: Reply with quote

While I do not know much about the PCI bus protocol, i would suppose that:

Given the nature of *nix and xorg, and the capability for multiple video devices:
we could take any pci based system which reports the pci bus IDs to "userland" in the "normal"? way,
add in a pci graphics card, and configure xorg to point to it

now this may not make it work on bootup for console and such, but are there any low-level reasons why this wouldnt work?

if its a case where the bios does not send some kind of "init" signal to the card telling to to "turn on", there has GOT to be a way to do that with software ..... ?

is PCI a proprietary protocol?
_________________
-Tim Smith
Back to top
View user's profile Send private message
stonent
Veteran
Veteran


Joined: 07 Aug 2003
Posts: 1139
Location: Texas

PostPosted: Fri Aug 19, 2005 5:08 pm    Post subject: Reply with quote

X86 cards have to be 100% compatable with the original mid-80's IBM VGA BIOS Cards for Mac and Sparc to not need have that requirement.

Technically any DOS program that used VGA should still work today on even the most advanced or cheapest video x86 video cards.
_________________
Inspiron 4100 & Sun UltraAXe
Portage on Solaris|Dell Laptop Hacks
The way you feel about organized religion is the same way I feel about organized socialism.
Back to top
View user's profile Send private message
Weeve
Retired Dev
Retired Dev


Joined: 30 Oct 2002
Posts: 641

PostPosted: Sun Aug 21, 2005 4:39 pm    Post subject: Re: XVR-100 working with FBDEV... Reply with quote

[quote="rkrenzis"]I was able to get the XVR-100 working with FBDEV. Xorg recognizes it as:

Quote:
(II) FBDEV(0): Hardware: ATI Radeon QY (vidmem: 65536k)


What kind of box do you have one of these in?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum